Help - Search - Members - Calendar
Full Version: Ipk For Rubu 1.8.1 Or 1.8.2
OESF Forums > General Forums > General Support and Discussion > Software
SNi
Anyone have an ipk for Ruby 1.8.1 +?? I have the 1.8.0-1 but need 1.8.1 or higher to try a couple of wikis (Instiki, Pimki).
Thanx,
SNi
P.S. SL-C700 with stock ROM
mars
Googling, I eventually found an ipk of ruby 1.8.2 on the net here: ruby_1.8.2-1_arm.ipk

But I think it will be an uphill battle getting instiki working since there are a lot of dependencies on other ruby packages. I gave it a quick try, and libzlib-ruby is missing at least.

If you were to try the Debian/Xqt route, after loading in a number of ruby packages and installing gems I got instiki to work. However, instiki pimki didn't seem to look/work very good with dillo -- but the interesting thing is once instiki is running from Debian/Xqt, netfront3 (and I assume opera) can access it from qtopia. Maybe this is because I "mount -t proc /proc /usr/mnt.card/debroot/root/proc" . Instiki still seems to be running when I close Debian/Xqt. Instiki is also pretty useable with netfront (haven't tried with opera).

After a trial and error approach of running instiki, seeing what package was missing, installing the package and redoing the process, instiki seemed to require ruby-gems. So I installed ruby-gems by following the procedure on this page: Rails on Debian Unstable

If you want a ruby wiki that works with the existing ruby 1.8.0 from this page, I've found MiniRubyWiki to work reasonably (although not as full featured as instiki). Note I only had success getting the old stable version to work.

- mars
lareya
I couldn't seem to get this ruby to install. Has anyone else have this problem?

Lareya
lareya
Okay,

can someone please tell me how to either install this latest version of ruby listed here (ruby1.8.2-1_arm.ipk) or please roll another one for me? It isn't in a correct format somehow. sad.gif In the gui it doesn't even see it. and in the command line, it won't run it even if I do a -no depend. It just says error need to run ipkg update, and of course that doesn't ever work! I can install other stuff either gui or command line, and when I have errors, I do go in and erase the error messages, so that the gui installer works again.

I have been looking at all the faq about repacking ruby myself. Oh gees! This is even a bigger endeavor than I thought. I am sorry, I am still newbie, and I bought the latest book on ruby, and really want to just walk thru the examples with it. I downloaded the source for ruby 1.8.2, and untared it to the Z, but that is as far as I got. I am unsure where every thing is supposed to live? I want it in my SD drive, since it never leaves my Z.

Thanks alot of for anyone willing to to package it up for me! tongue.gif

Lareya
lareya
Okay,
I have been having some problems, so I re-installed cacko, the updated ROM, and now I have finally got the ruby to work. However, it wanted to be in the internal memory. but oh well....

So, I guess I fixed it myself.

Thanks!

Lareya
xjqian
yeah, the 1.8.2 version is only willing to live in the internal flash. It runs fine. But seems ruby-qte 0.5.2 not compatibile with this version.

edit: ruby 1.8.2 is actually working from the SD card. I installed from the sharp add/remove. It seems stucking in there forever don't know how to quit the gui. So I waited 15min, hit reset, reboot. And checked, all the files are there and the ruby 1.8.2 are populated in the uninstall menu. Runned minirubywiki (thanks mars for pointing that out) successfully. Seems good to me. Only problem is can't run EBT with it because looks like incompatibile with ruby-qte 0.5.2
SNi
Another wiki that works (with Ruby 1.8.2) is Soks.
SNi

http://www.soks.org
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.