Help - Search - Members - Calendar
Full Version: Death Of A C860
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > Cxx0 Hardware
Here is a tale of woe....

Over the Christmas period my C860 sat in my pocket hardly used, until Christmas Day when I got a new 1GB CF card. This all worked fine for a while until everything froze. I pulled the battery and waited for a few minutes, as this usually fixes all and switched on. Nothing happened except the mail light started flashing repeatedly. I manage to get a reboot by power cycling lots of times but lots of weird thing started happening (sym links disappearing, qt freezing, application disappearing).

At this stage I was running Cacko 1.21b and knew it would be a couple of days until the new version so I thought, “I will just wait and reflash the new rom”. I did this, and for the two days it worked I can say 1.22 is great but the same things started happening.

It was at this stage I decided to investigate the service menus. I checked for bad nand blocks and yes there is one (or more) in the first block of the nand memory – the boot area. A full erase of the nand cleared a couple of bad blocks out of the higher addresses but the one in the boot area is always left. This has left my Zaurus unusable.

The worst thing is that I got it cheap on ebay so no warranty and return to Japan for repair is likely to work out more expensive than just biting the bullet and getting a new one from shirtpocket with a warranty service.

So at the end of the day instead of a c860 with 1GB CF and new leather case I am having to use my old, reliable sl-5500 (with the 1 GB CF wink.gif)

I have trawled the zug and googled for the last couple of days but if any one has any ideas let me know. I am now at the stage I will try anything.
*quick post before bed*

Search the forums for posts made by me a couple of months ago, I had a similar problem. If you can't find anything helpful I'll try and help you tomorrow. Good luck smile.gif
Hi Foxdie,

Thanks for your reply. I have already looked at you posts on this and they did help. I tried a full nand erase which fixed things for you. This did help as it cleared out 5 or 6 bad blocks from high address areas (the data sheet for the nand chip says in has spare blocks that the built in controller will map over bad blocks during a nand format). My problem is that one of the bad blocks is in the first area of the nand, i.e. the are where the diag tool and boot sector live. The full erase does not touch this.

In the shower this morning I had what may be a crazy idea but that is the stage I am at. I know there is the 'nor' technique to flash but no files for the c860. In theory the require data should be in a full nand back-up so I am going to hack around the one I downloaded with dd and a hex editor.

Thanks again
Just to let you know there is bad blocks on every Zaurus near the start of the flash chip address range. It may just be normal.
Managed to flash a NAND image on to my Z so can get a bit more info. Running - badblocks /dev/mtdblock1 - tells me blocks 512 to 515 are bad. Dmesg then contains many lines along the lines of
sharp_sl_nand_read_ecc: Failed ECC read page 0x00000400

The numbers are 0x00000400 to 0x00000403.

The current nand image runs okay as long as I only use the terminal and don't try restarting to often.
I don't want to jinks this but after repeated nand erases and flash attempt I finally have managed to get it working again. I even managed to flash from the Sharp nand to Cacko 1.22 (I partitioned the root area 28MB instaed of 27MB to be on the safe side).

I have no idea why it is working now or if it will work long term as I still have a number of bad blocks in what is the part of the rom with the diagnostic system.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.