Help - Search - Members - Calendar
Full Version: X/qt-2 On Opie
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus - Everything Development > X/Qt
Has anyone run the latest X/Qt on the Opie/OZ ROM? The X/Qt server that can be built through OE runs okay, but it's version 0.9 and trying to get fonts to work correctly is a nightmare. I can run the latest X/Qt server using the compat libs, but it won't detect the Qt server and so needs to be started as a server itself. That just leaves me with a flickering opie and an X server that doesn't accept any input.

I've tried to compile X/Qt-2 myself, but I can't get by the ./build DevWorld step. Has anyone compiled this successfully (for anything, not specifically Opie), and can maybe outline a few steps needed to get started?
I hve had no problem on a 6k using server 1.9.0 following the instructions here, and lardmans instructions to move /home/zaurus/.* to /root. I didn't even know there was one that could be compliled'on oe. Anyway, I can't really be more precise than what has already been said, and to verify that it CAN work. Oddly over several flash/install repeats, firefox under pocket workstation gave pretty consitant bus errors -- so all is probably not perfect.
So is that running X/Qt using Opie?
Yes, though I think it was XQt v1. Do a search of this part of the forum for my posts (which are relatively few you'll be glad to hear) and take a look at what I did (not much).

Let us know if XQt 2 works with Opie.

Yes, I was talking about an X/QT 2 ( i used it to get smuelas xmodmaprc working--it spits errors on xqt1)on OZ 3.5.2 opie installation that i did to run pocket workstation. I'd love to see native oz/opie xqt ipks that could use xqt to take advantage of the OZ x11 stuff. That would be incredible.
edit: integrated oz/opie/xqt built from oe would also solve the xqt/minimo issue cmisp discusses on a nearby thread, wouldn't it?
Okay so I hacked together a build of X/Qt 2 that runs on Opie without the compat libraries. I haven't used it for that long, and not sure if I did it all right. I tried to make up a nice .bb file for openembedded to compile, but I don't understand it enough and couldn't get it to work.

Instead I hacked one together that drops the new xqt driver into the already working Xqt .bb file and it compiled no problem.

This is the code from the xqt2 directory on the xqt cvs server. If anyone tries it let me know if you had any success.

Oops looking at the depends it seems to need oz-compat? Have to look into it some more, maybe it isn't any better. I'll leave it up though if anyone wants to try it, just force the depends.
I fixed my OE issues, and it seems to be compiling pretty clean. No annoying oz-compat dependencies anymore. I've also modified the keymap, so I don't need to use xmodmap anymore.

To anyone that wants to try X/Qt-2 on Opie: If you have a 6000 you are in good shape, if not you'll have to write up a new xmodmap file since the ones on the net now are for JP106 codes. I've attached the KeyMap.h file that I modified so you can take a look at how they are mapped out in the binary. This is JUST the binary, so no startup scripts or xbase apps. I think you need the misc fonts package, I haven't tried it without. Put the fonts anywhere you want and link them to /usr/lib/X11/fonts/misc.

If you already have a working X/Qt going, hopefully it'll just drop into place. This is ONLY for Opie!

Another Note: I've compiled this against some newer packages then are probably in the 3.5.2 feed. I don't know what kind of issues this might cause, but I'd like to know if it works for other people. If it doesn't I can try to compile it against 3.5.2 packages.

Problems I've noticed:
  • No Right Shift
  • No Caps Lock
  • No Num Lock
  • Application (Dot) key is a - and ! sign (useless?)
  • Underscore doesn't work. Also it doesn't seem to be set right in qkeyboard_qws.h for tosa keyboards.
  • X/Qt crashes when you try to use the Opie on-screen keyboard
I think I've read about these problems before and they are caused by Opie or the kernel, and not X/Qt.

Could someone that's using oz-compat and X/Qt let me know if it crashes for them too when used with the onscreen keyboard? I never had a problem on Sharp ROM, like to know if it's my build or the change in environment.

Try'd to upload the package right to the forum but it failed time and time again, so here it is in a gzip'd fashion. Make sure you gunzip before trying to install it.
At the moment I'm playing with sharprom and gulhelm's softloat kernel/libsdl
But my usual thing has been opie/Xqt2 from the feed-testing feed using compat on my 6000

I haven't explicitly tested it, but I don't remeber any crashing when I used the virtual keyboard.

However, since you mention it, I was checking out gpe the other day. noticed I had no understrike, and used the virtual keyboard for it. Every time I fired up the virtual keyboard, rxvt crashed immediately, though it would work fine if loaded after the vkeyboard. This must be either an oz x thing, or an oz rxvt thing. Were you crashing out of rxvt, and bringing things down that way? If so would it be too much trouble to let us know if the same thing happens in xterm?

btw thanks for the xqt2 for opie... will use as soon as I switch back
have you had any luck running firefox in your config?
Working native Xqt2 binary for OZ3.5.4.1RC2 here (no compat lib needed):

Espect more enhancements soon.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.