OESF Portables Forum

Model Specific Forums => Sharp Zaurus => Zaurus - Other distros support => Topic started by: indigi on February 12, 2017, 08:38:24 am

Title: New Sharp Zaurus Sl-5500 User - Need Help To Start! :)
Post by: indigi on February 12, 2017, 08:38:24 am
Hi guys!

I'm new Zausrus SL-5500 user. I have 2 Zaurus units, dock station, WiFi and BT CF cards.

1. I'm trying to find OpenZaurus software. Website is dead, Google won't help... Maybe someone have it?

2. Second thing is that I'm trying run NewtonOS emulator - called Einstein - on my Zaurus. Anyone have some experience and could help?

Mor info about it: https://github.com/pguyot/Einstein (https://github.com/pguyot/Einstein)

ANY help will be priceless!!!

Title: New Sharp Zaurus Sl-5500 User - Need Help To Start! :)
Post by: Varti on February 13, 2017, 05:31:44 am
Hi and welcome to the OESF forum!

The 5500 was the first Zaurus model (excluding the developer's only SL-5000D model) running a customised Linux distro. Regarding your questions:

1) OpenZaurus.org used to have a feed, but, as you have noticed, it is now offline. OpenZaurus has been replaced in 2007 by Angstrom, which is still under development. I have tried to find a still working mirror of the feed, but all of them are either offline or don't host the files anymore. I have also tried to check the mirrors on archive.org, but with no avail, the files are listed there but can't be downloaded. These are all the mirrors that have been used in the past, and that don't work anymore:

http://www.openzaurus.org/download/ (http://www.openzaurus.org/download/
http://openzaurus.sourceforge.net/web/ (http://openzaurus.sourceforge.net/web/)
http://ewi546.ewi.utwente.nl/mirror/www.op...e/ (http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/
http://oz.hentges.net/mirror/ (http://oz.hentges.net/mirror/) and http://mirror.hentges.net/www.openzaurus.org/ (http://mirror.hentges.net/www.openzaurus.org/
http://oz.pdai.org/ (http://oz.pdai.org/)
ftp://ftp.fu-berlin.de/unix/linux/openzaurus/ (http://ftp://ftp.fu-berlin.de/unix/linux/openzaurus/) (doesn't host the files anymore)
http://openzaurus.linuxtogo.org/download/ (http://openzaurus.linuxtogo.org/download/
http://openzaurus.jaduncan.net/mirror/ (http://openzaurus.jaduncan.net/mirror/)
http://divbyzero.homelinux.net:8080/mirror...openzaurus.org/ (http://divbyzero.homelinux.net:8080/mirrors/www.openzaurus.org/)

Does anybody know any other working feed, or have a local copy of the files? It would be nice to have again a working mirror, at least for archival purposes.

In alternative, you might want to give Angstrom a go, although you'll need a lot of time and patience to find out how to install it: the Zaurus is officially still supported, but it has not been tested since some years. Anyway, here are the latest available prebuild binaries for your model (5500 a.k.a. Collie): http://dominion.thruhere.net/angstrom/nigh...2016.06/collie/ (http://dominion.thruhere.net/angstrom/nightlies/v2016.06/collie/)

There are also other distros available, like PdaXRom and an older Cacko version for the 5500 (on archive.org: http://web.archive.org/web/20090527004703/...org/~crow/cacko (http://web.archive.org/web/20090527004703/http://www.schwag.org/~crow/cacko) ).

2) I have never tried to run Einstein (never had an Apple Newton myself), but I see that someone has in the past managed to make it run, albeit slowly, under OpenZaurus:

https://www.oesf.org/forum/index.php?showtopic=17156 (https://www.oesf.org/forum/index.php?showtopic=17156)
https://www.oesf.org/forum/index.php?showtopic=19745 (https://www.oesf.org/forum/index.php?showtopic=19745)

The best thing would be, since it is open source since some years, to compile its latest version for OpenZaurus. The old version, compiled for OZ, can be anyway downloaded here: http://web.archive.org/web/20060425073934/...ewton/einstein/ (http://web.archive.org/web/20060425073934/http://www.kallisys.com/newton/einstein/)

Title: New Sharp Zaurus Sl-5500 User - Need Help To Start! :)
Post by: Varti on February 14, 2017, 05:51:00 am
Update - I have finally found a working OpenZaurus feed:

http://feed.zaurusfr.org/openzaurus/ (http://feed.zaurusfr.org/openzaurus/)

You should modify your /etc/ipkg.conf to use the feed for the OpenZaurus version you are using, e.g. http://feed.zaurusfr.org/openzaurus/3.5.4/ (http://feed.zaurusfr.org/openzaurus/3.5.4/) . AFAIK 3.5.4 is the last OZ version to run on the 5500.

In case the above feed is down, there's a mirror available here:

https://feed-zaurus.dahwa.fr/ (https://feed-zaurus.dahwa.fr/)