OESF Portables Forum

Model Specific Forums => Cosmo Communicator => Cosmo Communicator - Android => Topic started by: PartyMarty on February 01, 2020, 02:02:08 pm

Title: How to type Cyrillic characters without modifier key using Russian keyboard? - RESOLVED
Post by: PartyMarty on February 01, 2020, 02:02:08 pm
Hi all,

I just got my cosmo recently which i ordered with a Cyrillic keyboard.

In the Planet Keyboard app i have the language set to English and they layout set to Russian when using the Configure option.
On the main page of the Planet Keyboard app this seems to set the system Languages to English and Russian which is what i want but i can't get the keyboard to enter Cyrllic characters without having to hold the Alt key.

If i switch the onscreen virtual keyboard to Russian this works for the virtual keyboard but the physicial keyboard doesn't change whether the on screen one is visible or hidden.

To test i tried using the Planet Keyboard app to disable the Use system languages option and manually set it to Russian only and after a full restart this made no difference.
I then tried using the Configure option in the Planet Keyboard app and set the system language to Russian with the Russian keyboard layout and all the GUI updated to reflect this, the virtual onscreen keyboard also switches to Russian by default with the option of changing to English as a secondary, but the physicial keyboard still types in English by default and only enters Cyrillic characters while holding alt.

Does anyone know how to setup the Cyrillic physical keyboard to input Cyrillic characters without having to continually hold alt for non numericals?

Due to the timing of mine arriving i've not been able to update the firmware past V15 yet so hoping this is just a bug.

thanks for any help,
Martin
Title: How to type Cyrillic characters without modifier key using Russian keyboard? - RESOLVED
Post by: vldmr on February 01, 2020, 04:04:32 pm
I think you have selected "Russian (english)" layout - at least that is how I recall it used to work. Change it to plain "Russian" in settings->Languages&Input->Physical keyboard->Integrated keyboard and use Control-Spacebar to switch layouts.
Title: How to type Cyrillic characters without modifier key using Russian keyboard? - RESOLVED
Post by: PartyMarty on February 01, 2020, 04:12:22 pm
Quote from: vldmr
I think you have selected "Russian (english)" layout - at least that is how I recall it used to work. Change it to plain "Russian" in settings->Languages&Input->Physical keyboard->Integrated keyboard and use Control-Spacebar to switch layouts.

Hi vldmr,

thanks for your reply.

To confirm under Settings->System->Languages and input->Physical keyboard it shows an Integrated keyboard option which can be toggled between Russian, or Russian (english) and has the message advising to control-spacebar to toggle.

I never thought to check in there as figured it would be related to the Planet Keyboard app somehow.

The control-spacebar shortcut was exactly what i needed, thanks very much for your help.