OESF Portables Forum

Model Specific Forums => Cosmo Communicator => Cosmo Communicator - General Discussion => Topic started by: MonkeyControl on August 05, 2021, 01:36:17 am

Title: In a pickle
Post by: MonkeyControl on August 05, 2021, 01:36:17 am
I've got myself in a bit of a pickle. 

Long version
I've been running Ubuntu Touch on a Cosmo Communicator for a while without incident, until last weekend. 
I noticed I was getting no network coverage, and I have been unable to get it back. 
After a lot of unsuccessful tinkering I did a fresh flash from recovery mode as per Planet instructions: 
with a 'Wipe data/factory reset', 'Change the partition table of your Cosmo', 'Install custom OS on your Cosmo' (Debian into Slot 3). 
Then I reinstalled Ubuntu Touch into Slot 4 and thought all would be good, but still no network. 
I have tried a couple of sim cards from different providers, in Android, Debian and Ubuntu Touch with no joy.  I have tried the sims in another (damaged but functional) Cosmo, and get network no problem. 

At the time the issue appeared I had just been tinkering with SSH and Libertine to install LibreOffice: 
but all was working well until I realised I had lost network. 

Short version
Could I have bent some mobile network setting in a way that would not be fixed by a factory reset and flash (that I could reset by some other means), or may I have a hardware problem? 

Any help very much appreciated, thanks in advance. 
Title: Re: In a pickle
Post by: jakfish on August 05, 2021, 12:55:52 pm
Ach, sorry to hear that. Not certain what's going on, but I use Gemian-only on my Cosmo because my wifi/bt just quit one day, gone on Android, Linux, whatever. With cam1965's help, I compiled the kernel to permit use of usb wifi adapters.

His .config file is actually set up for usb modems (and I've successfully used his .config and gotten data with a Huawei), but that's obviously Plan B for you. Since you've flashed successfully to other OSs, it sounds as if you've done due diligence, Can't imagine your tinkering with software would blow away network, even after reflash.

I guess you could truly go back to factory settings by reflashing the whole thing just for stock Android only and see if that had different results. Stock Android screamed at me about my missing bluetooth, so at least I had confirmation of hardware failure.

Title: Re: In a pickle
Post by: MonkeyControl on August 07, 2021, 02:54:21 am
Thanks for your help. 
I took your advice and did a reset back to Android by reflashing but selecting 'Reserve all space for Ugly Android' from recovery mode rather than going down the Linux route (I think this is what you meant by 'Stock Android'), and booted into Android.  At first I still had no network, so I then gave up and decided to reflash back to my Ubuntu Touch setup, with or without network, and when I did, I had a network connection :). 
The connection is a bit sporadic, but I'm out in the sticks at the moment, so I need to get home and update Ubuntu Touch and test from a known signal strength area, but I have a network connection for the first time in a week :) 8) :). 
I'll see how I go when I get back into civilisation, update Ubuntu Touch, do some more swotting up on the whole connection issue based on your other comments, and buy you beer if you ever get to NZ. 
Thanks again
Title: Re: In a pickle
Post by: jakfish on August 08, 2021, 11:23:35 am
Wow, that is very strange. Especially since you wisely cross-referenced your SIM/signal-strength by confirming with another Cosmo, I don't understand why it would suddenly give network now. Unless it's an intermittent hardware issue. You already wiped everything so there's no software miscalculation to explore. Weird.

If it is hardware, I wonder how hard it would be to pull the necessary components from your broken Cosmo...

Do post back with your findings and fingers crossed that this issue is just a gremlin.

(I would love to see NZ sometime in my life. Ever since watching TOP OF THE LAKE :) That's some gorgeous country and hats off to NZ's Covid measures.)

Title: Re: In a pickle
Post by: MonkeyControl on August 12, 2021, 04:37:12 am
In a pickle update: 

Long version: 
Well I've tried everything I can think of to fix the sketchy cellular data connection on my shiny Cosmo. 
I've checked IMEI numbers against the numbers on the box, checked they weren't blacklisted online, checked APN settings for consistency, build numbers, image parts, etc, every setting I can see looks okay. 
I've repartitioned and reflashed to Android or Linux, reinstalled Debian and Ubuntu Touch, unlocked the bootloader via FastBoot, started again, and again, but still no reliable network connection on my new Cosmo, whereas the old damaged one still works after the same routines. 
I've tried multiple sims in both slots, with or without the sd card present, on all operating systems, but still no joy on my newer Cosmo. 
I tried going back to Android V19 firmware but I couldn't get recovery mode to see the installer on my sd card.  Probably wouldn't have done any good. 
I haven't tried the SP FlashTool yet.  I haven't read up enough on it yet, haven't found the relevant files, I'm not sure how relevant this tool still is, and I'm out of my depth. 
I've done everything I dare to get busted old Cosmo and shiny new Cosmo back to identical settings to satisfy myself that this is not a software or network issue but a hardware issue, but for a couple of reasons I'm still not sure. 
After a 'Factory Reset', reflashing via recovery mode, boot options on old cosmo vs new cosmo are still different?  That doesn't sound like a reset to me.  I would expect behaviour to be consistent, (if annoying), on any device after a Factory Reset.  Is there a more fundamental level of reset available? 
In Ubuntu Touch I've also noticed some weird behaviour when I try to make a call or send a text.  On occasion the messaging or call app brings up the message 'No sim card, please insert a sim card and try again', whilst at the same moment I can open the pull down menu and see my sim card sitting in either slot, recognised and displaying 2G or 3G.  Surely that's got to be software, (or firmware or settings), but not hardware.  (See attached screenshot) 
On Android I'm also getting some strange behaviour where if the network connection is showing off, and I try to turn it on, a popup asks me if I'm sure I want to turn it off, when it's already off. 
Next stop a report and email to Planet to see if they can help, before I'm tempted to open the bonnet and lose half the fixings down the back of the couch. 

Short version: 
To be continued. 
Title: Re: In a pickle
Post by: jakfish on August 12, 2021, 05:21:40 pm
>> Short version:
To be continued. << :)

Thanks for posting back and sorry that this dilemma goes on. I'm certainly on record about my concern for Cosmo hardware, but at least I knew right away when things were broken. You're still mired in the gray, it seems.

I'm very interested to hear PC's response.

Title: Re: In a pickle
Post by: MonkeyControl on August 13, 2021, 05:16:17 am
Thanks for your support. 
Definitely 'To be continued'.  A lot of developers, community members and Planet have put a lot of effort into our devices, the least I can do is give it my best shot to fix my own little (probably self inflicted tinkering at the command line) problem.  Sorry to vent with the 'Long version' but maybe someone else will read my long winded waffle six months from now and dig themselves out of a similar hole.  OESF and UBPorts have done that for me many times. 
I haven't had your hardware issues, I mean, I have had hardware issues, but again, only self inflicted, usually involving the wrong trousers and long falls onto hard concrete.  Don't get me started on trousers. 
Every time I've stuffed up software on my Cosmo in the past a reflash has sorted it out, cost me a bit of data, and taught me a lesson, but I just can't fix this one. 
I had the perfect setup, UT on Cosmo, not everyone's perfect setup, but it works so well for me.  Isn't that the beauty of it, a choice. 
I hope to have a solution soon, I'm not out of patience or love, but I'm out of ideas. 
To be continued, Watch this space.
Title: Re: In a pickle
Post by: MonkeyControl on September 10, 2021, 06:03:41 am
I have a solution. 
It's called the F(x)Tec Pro1 X
Title: Re: In a pickle
Post by: ArchiMark on September 10, 2021, 09:47:51 am
What was PC's response?


Title: Re: In a pickle
Post by: MonkeyControl on September 10, 2021, 05:00:36 pm
What was PC's response?
We had quite a discussion, 10 out of 10 for effort, but ultimately fruitless. 
It got to the point where I thought we weren't getting anywhere so I knocked it on the head. 
The Cosmo soldiers on as a pda, sort of like a wifi only Gem with a backlit keyboard. 
Back to the PinePhone for daily driver duties for now. 
I still get to keep Ubuntu Touch though, which is nice. 
Title: Re: In a pickle
Post by: ArchiMark on September 10, 2021, 10:26:55 pm
Sorry to hear that it didn't help.

Did PC offer to repair it if you were to send it to them?

Title: Re: In a pickle
Post by: MonkeyControl on September 12, 2021, 12:26:32 am
Did PC offer to repair it if you were to send it to them?
I suggested a return to base for an out of warranty repair at one point but didn't get an answer.  To be fair I think the comment got buried in the barrage of clutter I was sending them.  I reckon I generated more case notes than the Roswell autopsies on this one. 
Oh well, moving on.  Must go, I will need to get some serious brownie points before I can order my Pro1 X, this will be my fourth new phone in the last two years.