OESF Portables Forum

Everything Else => General Support and Discussion => Zaurus General Forums => Archived Forums => Software => Topic started by: tawalker on December 11, 2003, 04:10:13 pm

Title: Reinstalling libqpe
Post by: tawalker on December 11, 2003, 04:10:13 pm
I hope someone can help, as I\'ve just made a rather stupid mistake...  

To cut a long story short, I\'ve accidentally uninstalled the \"libqpe\" library, and as a result, can\'t boot into the Qtopia GUI. Is it possible to install the package from a basic terminal/command line, or will I have to reflash the ROM?

In hope of a lifeline, many thanks...

Title: Reinstalling libqpe
Post by: lardman on December 11, 2003, 05:55:11 pm
What ROM are you running?

If it\'s OZ, then as long as you still have ssh access I assume it would be possible. If you\'re running one of the Sharp ROMs (and I\'m confused as to how you managed to uninstall it in this case) then it should be even easier, just a matter of re-creating a symlink somewhere (though I don\'t know where as I use OZ).

Title: Reinstalling libqpe
Post by: allyrfriends on December 11, 2003, 07:00:00 pm
If you are using OZ and you can get an ssh connection as Simon suggested, or startup is dropping you straight into the command line (which it did for me when I broke Opie), type:

Code: [Select]
ipkg -d root install /path/to/.ipk

Similarly, I don\'t know about the Sharp ROM. But, no, you shouldn\'t have been able to remove it completely from that anyway... so you could try running find / -name libqpe* to work out where the file is you need to symlink.
Title: Reinstalling libqpe
Post by: tawalker on December 12, 2003, 05:03:44 am
Thanks for these suggestions - I\'ll try them out when I get home (I left the Z there). I mentioned this problem on another thread, and tumnus suggested another solution, so fingers crossed, one or more of these will save the day.

How did I uninstall libqpe? If tumnus is right, I probably didn\'t, but may have deleted a symlink or something. This is what happened:

- Went to install libopie from OZ Sharp ROM feed (qpe-gaim apparently needs this library, even though they don\'t say so on the Web site)
- Used package manager to download libopie from feed
- Package manager gave error message (\"something went wrong\" - what, though?)
- Went to terminal, but look/feel of this app had changed (new window buttons, etc., but most of the icons had disappeared)
- Went to package manager - no libopie installed, but I thought I or the manager had installed libqpe by mistake (the two are next to each other in the feed list)
- libqpe was in package list, so I thought this was the mistakenly-installed package, and I tried to uninstall it
- Z started acting strangely (no wonder), so tried rebooting
- Now, Z won\'t boot into GUI

BTW: My Z is running tkcROM v1. I\'ve considered OZ before, and probably will again, partly as the GUI looks more interesting to me than the Sharp-based ROMs. But that\'s a topic for another thread...

Thanks again for your help - if it weren\'t for forums like this, I\'d probably still be on Sharp ROM v2.38 :wink: