Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - dys

Pages: [1] 2
1
Linux Issues / ! Multisync And Gentoo Linux Warning !
« on: January 27, 2005, 02:24:53 pm »
Thought it was to good to be true  

To get the opie plugin to compile USE="opie" must be passed to emerge, everything compiles without error but when you start up multisync the 'opie' plugin is mysteriously absent !
Looking in /usr/lib/multisync the opie modules have indeed been built but the base .so for libopie_sync (and infact libirmc_sync) are missing - meaning they can't be loaded by multisync.

Solution:

Code: [Select]
ln -s libopie_sync.0.0.0 libopie_sync.so(And the same for libirmc_sync if needed)

Now multisync is a happy bunny.

Again, hopes this can save some ppl some wasted time.

Oh, I went to file a bug report at gentoo but someone had got there before me  Bug Report

dys

2
Linux Issues / ! Multisync And Gentoo Linux Warning !
« on: January 27, 2005, 09:26:21 am »
Just to finish the thread gentoo now finally has an updated ebuild which fixes the problems described above. app-pda/multisync-0.83_20050115.

dys

3
Linux Issues / ! Multisync And Gentoo Linux Warning !
« on: January 18, 2005, 05:27:55 am »
Hi all,
        Haven't posted here for quite a while but thought I would give people a heads up on a problem I encountered with Gentoo Linux and multisync so hopefully they can avoid the annoyance / waste of time i didn't

If multisync is installed from portage (emerge -v multisync) then the multisync source that is fetched and compiled is the 0.82 source NOT the newer 0.82-1 source. As far as I have found out the multisync author posted 0.82 source, realised there was a  bug and very quickly posted newer source (named 0.82-1). The Gentoo ebuild however doesn't take account of this and gets the older, buggy source and builds that. While it appears that multi sync works fine, it has problems with the opie/openzaurus plugin and fails to sync at all. See post from multisync user list Multisync users mailing list post and the (as yet still unresolved) bug post at gentoo Gentoo bug tracker (link to ebuild patch there as well).

Before I found this info I spent quite a loooooooong time changing ROMS, recompiling the (what I thought was the stable relese) source, dumping network packets to see what commands were being sent and generally pulling my hair out in annoyance! (If anyone is interested the network dumps showed the zaurus complaing about unregistered channels, and thus refusing to flush() the relevent apps)
 As soon as I grabed the newer 0.82-1 source everything went swimmingly and I could sync with evolution.

Hope this can saved others some hours of palying about, when only a recompile is needed

Oh and Gentoo, this bug has been around for aaaaaaaaaaaggggggggggggeeeeeeeeeessssss can someone please fix the portage tree as the patch is so simple its silly.

dys

4
Software / ozone - OpenZaurus cloning tool
« on: May 05, 2004, 05:03:37 pm »
Quote
I reflashed my SL-5500 from OZ 3.3.6-pre1 32/32 to 48/16 memory setup using ozone. Backup, reflash with just created initrd and 48/16 kernel. After that I moved things from mnt/ram backup into /mnt/ram and it works OK.


Cool, glad that someone else has found it useful

5
Software / ozone - OpenZaurus cloning tool
« on: April 12, 2004, 06:22:33 am »
Sorry Mickeyl but the ipk installs fine but is asking for version 2.3 of libc.so.6 and as far as I know I only have version 2.2 on my 5500 (OZ 3.3.5). Is there any chance of building against libc 2.2 ?? Sorry to be a pain

dys

6
Software / ozone - OpenZaurus cloning tool
« on: April 12, 2004, 06:19:53 am »
Cheers Mickeyl, really appreciate you doing that. I\'ll get onto getting a version that runs natively on the Zaurus.

cheers
          dys

7
Software / ozone - OpenZaurus cloning tool
« on: April 09, 2004, 05:52:37 am »
Quote
Yeah, no problem in making one.

Cool if you could send a copy to me I really appreciate it [ ozone[at]iodboi.co.uk]. I pretty sure with that I will be able to get a quick and dirty version of ozone going that will run on the zaurus itself.

cheers
          dys

8
Software / ozone - OpenZaurus cloning tool
« on: April 08, 2004, 08:45:33 pm »
Done a quick update, there is now a new configuration variable CLONE_MSK which makes it easier to alter which directories will NOT be included in the flashable image. This should make it easier for people who have non-standard filesystem layouts (e.g. /opt on a SD card) to use the cloning without having to dig through the main script. Check the README for details. Did a few other cleanups as well. Get the new version from the same place as last time:
http://www.iodboi.co.uk/ozone/

dys

9
Software / ozone - OpenZaurus cloning tool
« on: April 08, 2004, 05:15:19 pm »
Hi Mickeyl, at the moment it is run from the desktop PC (linux) but i\'m sure it can easily be done on the Z and the initrd created on CF/SD.  Is there a version of mkjffs2 that runs on the zaurus itself ?

dys

10
Software / ozone - OpenZaurus cloning tool
« on: April 08, 2004, 02:14:01 pm »
Quote
i just have to ponder any possible implications of having my /usr and /opt on sd partitions

all you would need to do is add ./opt/* and ./usr/* to the list of files that are being written to the file ozclone_exclude on the zaurus (its in an ssh\'d echo statement near the start of the ozclone function in the ozone script). This file list is used to exclude parts of the filesystem from the initrd image. Now the clone will not use the contents of /opt or /usr but still leave the mount points there. Upon flashing with that image all should be well as long as /opt and /usr on the SD haven\'t changed much.

I was going to put in some configuration options to exclude extra parts of the file system easily rather than having to hack up the main script. I\'ll try and put that in the next version.

Has anyone (other than me !!) successfully cloned an image and reflashed yet ??? I\'d appreciate feedback

cheers
         dys

11
Software / ozone - OpenZaurus cloning tool
« on: April 08, 2004, 03:59:26 am »
Yeah I was thinking about this the other night, I think all I would to know for each ROM are the mountpoints so as the script can get the partitions right. I\'m off to work now but I\'ll try and have a look into it tonight, hopefully it shouldn\'t prove too much of a prob.

Cheers
           dys

12
Software / ozone - OpenZaurus cloning tool
« on: April 07, 2004, 07:47:20 pm »
Hi all,
        Just thought I\'d post to say that I have written a little script that makes a flashable image (clone) of an openzaurus filesystem. I wrote this for myself but it works good for me so I thought someone else might benefit from it so I thought I\'d release it

In a nutshell what it does:

- Can create a flashable image of an OZ system so as if the system needs reinstalling (for whatever reason) then it can be done with some apps/data etc already there.
- Can also create a regular backup (tarball) of an OZ system. This tarball can be encrypted if required.

What I\'ve found it useful for:

- Checking out new ROM\'s. I just took an image of the OZ with the old ROM and then could test out the new ROMs without worrying about loosing anything / doing a lengthy reinstall of old ROM + Apps if I didn\'t like the new ROM.
- As I play round LOTS with my zaurus there is always the chance I will kill it somehow. If I have a recent flashable image its very quick and easy to restore back to a good and happy zaurus

Anyway I thought that someone other than me might find it useful so here ya go. If you do like it / dont like it / want to see new features or bugfixes feel free to let me know and I\'ll try and do them.

!! --WARNING-- !!
I have only tested it on a 5500 but it \"should\" (cough) work on the other models that OZ works on as I have included the initrd build values from the OZ CVS. In any case if it does work on another model / you tweak the script to get it to work on another model it would be cool if you let me know.

It can be downloaded from my website :
http://www.iodboi.co.uk/ozone/

cheers
           dys

13
Angstrom & OpenZaurus / Quality Team For OZ
« on: March 03, 2004, 02:36:13 pm »
The above post was me !!! my session timed out.

14
Accessories / Retractable USB sync / charger
« on: January 30, 2004, 10:32:36 am »
Hi all  
             I ordered one of these from shirt pocket and it came today !!
http://www.shirtpocket.co.uk/cat/product_i...4741cdc9acd4b5f

It only cost £8.95 so I was a bit suspicious, but it fact it was far better than I expected  . Its all in clear plastic, with clear cableing and seems sturdy enough to be retracted and chucked in my bag. NowI dont have to lug the cradle AND transformer to and from work every day as this little beauty charges straight from the USB port !! I have tried on 3 machines at home and 2 at work and they all sync and charge just fine with it, no probs what so ever.

The iceing on the cake is the mechanism that allows you to extend the cables as far as you want, then applies a brake so they stay there and dont retract.

I\'d recomend one of these for anyone who needs to sync their Z in different places and doesn\'t want to go to the bother of taking a cradle and power supply with them.

Cheers
           dys

15
5x00 Hardware / Do you need headphones??
« on: January 09, 2004, 08:32:41 am »
I use OZ 3.2 and with xmms the buzzer is used to play music if no headphones are plugged in. The buzzer is able to reproduce ok music (i.e. you can make out the words of songs fine)at low volumes, but it distorts alot the louder it gets. This means to have undistorted playback the volume must be fairly low and so you can only hear it properly if you put the Z next to your ear

Maybe not all that useful, but a sweet hack none the less !

dys

Pages: [1] 2