Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - jackschmidt

Pages: 1 [2]
16
Sharp ROMs / Configuring Qpe-terminal
« on: May 14, 2007, 07:51:56 pm »
I'm starting to think it's related to how the OS starts.  I do note that in Zynergy or Sharp ROM it does launch as zaurus and it seems in Watapon, it starts as root though I'd have to reflash to answer it definitively, which I don't want because this is quite customized already to what I like.

This is kind of scary, but I hope there's a way to fiddle this to launch as zaurus instead of root.  init perhaps?  Hmm...

17
Sharp ROMs / Configuring Qpe-terminal
« on: May 13, 2007, 06:51:01 pm »
No.  The home directory is not in the SD card.  I'll check the .bash_profile and see what I can make out.

Edit:

Just checked it.  .bash_profile does not exist in the home directory.  Only .bash_history.

I'm checking /etc, here's the only seemingly relevant files:
busybox.conf
tinylogin.conf

Doesn't seem to be much.  I'm going to try grep -R su . on '/'.  Hmm... seems grep here does not support the recursive flag...

18
Sharp ROMs / Configuring Qpe-terminal
« on: May 11, 2007, 07:08:15 pm »
I don't have the size to do a system backup.  So, I'm afraid that wouldn't work.

I just installed qkonsole and checked what it would start as.  But it starts as root also.  Does that mean something is wrong with my ROM?

I wonder what the solution could be.

19
Sharp ROMs / Configuring Qpe-terminal
« on: May 09, 2007, 06:39:08 pm »
Quote
theres two consoles you can use: Konsole (real one from KDE) or qpe-terminal (the sharp one)
NOTE: Konsole has a config screen (ie you can make up special terminals for say kismet)
[div align=\"right\"][a href=\"index.php?act=findpost&pid=160842\"][{POST_SNAPBACK}][/a][/div]

I'll try to check again when I get the chance later.  Would installing another terminal application help?  I wonder...

20
Sharp ROMs / Configuring Qpe-terminal
« on: May 08, 2007, 09:02:40 pm »
Quote
another shot in the dark, have you tried EmbeddedKonsole or another terminal?

if that comes up as a root console then the shell is being retarded
[div align=\"right\"][a href=\"index.php?act=findpost&pid=160805\"][{POST_SNAPBACK}][/a][/div]

Honestly, I think there's no qpe-terminal binary in the qpe-terminal package.  It's EmbeddedKonsole.  Or at least I think.  I did install qpe-terminal but it seems to install embeddedkonsole.

21
Sharp ROMs / Configuring Qpe-terminal
« on: May 08, 2007, 07:44:46 am »
Quote
just a shot in the dark ,but what if you try launching another instance of it from qpe-terminal from qpe-terminal? This might let you know if the problem is in the shortcut or a config file.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=160697\"][{POST_SNAPBACK}][/a][/div]

When I do that... it's another root terminal.  Config problems, I think.  Not sure how though.

22
Sharp ROMs / Configuring Qpe-terminal
« on: May 06, 2007, 11:53:35 pm »
I need some help here.  I'm running Watapon ROM and installed qpe-terminal (by mistake actually because I think Watapon had one already).

I uninstalled qpe-terminal and then figured it removed the application so I put it back.

qpe-terminal is running though I'm finding something strange with it.

When I launch it, it opens up as root, not zaurus.  I've tried tap and hold on the icon to see the 'run as root' check box and I notice I don't have it ticked... but it still starts up as root.

How can I get it to run as user instead of root?

23
Sharp ROMs / Watapon
« on: April 28, 2007, 10:05:33 pm »
Quote
Does anyone have the last watapon release? As chaos's website no longer exists.

Thanks.
[div align=\"right\"][{POST_SNAPBACK}][/a][/div]

Try here.
[a href=\"http://www.tyrannozaurus.com/?q=node/77]http://www.tyrannozaurus.com/?q=node/77[/url]

24
5x00 General discussions / Best Rom For 5600?
« on: April 26, 2007, 06:26:12 pm »
Update.  Managed to flash with the Sharp ROM.  It's working fine now.  I'm fiddling with this to see what it has.  I also have the Watapon ROM and will plan to use that to see what I can find.

Thanks for your help xamindar and sdjf!  

25
5x00 General discussions / Best Rom For 5600?
« on: April 25, 2007, 08:18:33 am »
Quote
Yes, it should be okay to flash the sharp rom.  I believe the Zynergy is one of the modified sharp roms.  Kind of a dark picture of a girl on startup right?  I think I remember having problems with the package installer on that ROM.  In my experience with my 5600 it is nearly impossible to brick it as flashing the rom does not overwrite the "bios" of the device.  So if you flash a failed OS then you can just reflash until you get it right.  NAND flashing on the 3100 and so on are what can brick it but that's not the way we flash with the 5600.   Someone please correct me if I am wrong. 
That is so awesome news!    Yeah, dark picture of the girl at the startup.  And yeah, installer problems here.  So that means I can use the Sharp ROM without fear of bricking it.  That's the best news I've heard in a while.

Quote
Well, it will overwrite the "OS" of the device which includes all your default applications but it does not erase the home directory until you format.  So once you flash it you need to go back into the flash utility and format it to erase all your settings and home directory so you get a clean boot up.
I think selecting format is part of the procedure for flashing roms anyway, right?  So home directory does go bye bye.  I base that from this.
http://ozwiki.u32.net/Poodle/Install

Quote
Yes he can. the 5500 you can not, but the 5600 you can.
Wow.  More wonderful news!  This is making me feel excited!  Oh wow!!!

Quote
Have fun flashing, don't worry, you can't brick it.  Just make sure the file names are exactly how they are supposed to be, it is even case sensitive.  Filenames depend on the updater.sh file you use so they can be different.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=159707\"][{POST_SNAPBACK}][/a][/div]
I'll keep an eye on this one.  I guess I'll use the Sharp ROM and see how that goes.   Thanks a lot for the response!!!

26
Sharp ROMs / Zynergy Questions
« on: April 24, 2007, 09:24:34 pm »
I've got some questions on Zynergy.  I'm thinking of flashing my sl5600.  It has Zynergy installed and I'm thinking of reflashing it because my sl5600 is a hand-me-down.

I've had some problems though... the battery detection is a little weird because sometimes it says "status is charging" even though it isn't.  The File Manager is also quite difficult to use.

Any ideas?

Also, I don't seem to have root access.  Any thoughts?

Thanks!

27
5x00 General discussions / Best Rom For 5600?
« on: April 23, 2007, 08:07:22 pm »
Quote
Quote
Can I use SD cards for flashing my rom or do I need a CF card?  Thanks all.

Jack
[div align=\"right\"][a href=\"index.php?act=findpost&pid=159604\"][{POST_SNAPBACK}][/a][/div]

Yes you can use SD cards to flash.  The rom you want depends on what you like.  I used the watapon rom because it had all the modifications to the sharp rom that I would end up doing anyway if I was on the sharp rom.  I personally stuck with the sharp rom because everything just worked with it.  Openzaurus never became stable and probably never will.  It's up to you though.
[div align=\"right\"][a href=\"index.php?act=findpost&pid=159606\"][{POST_SNAPBACK}][/a][/div]

Thanks for the swift response.  I've read conflicting reports on this.  But I suppose there are more SL-5600 owners here.  I do suppose that it's possible then.

Well, I'm not sure what ROM to pick.  I presume best choice is one that is stable and that allows me to install and uninstall applications.  I want to use my Zaurus primarily for Surfing, Writing docs, e-mailing, and instant messaging.  I've read at the first page of the thread that Sharp ROM is the most stable, but I believe the ROM this Z came with is OpenZaurus or something.  Not sure though since it has a 'zynergy' splash screen at boot up.

28
5x00 General discussions / Best Rom For 5600?
« on: April 23, 2007, 06:46:31 pm »
Hi.  My friend gave me a Zaurus SL-5600, albeit an incomplete package.  I have the device though and I have encountered problems with security permissions and all that although the original owner ensured me he did not tweak such things.

I posted at Tyrannozaurus and they recommended me to post here and they also advised me to flash the device.  I'm not sure what my ROM is running at although I may be lead to believe that my Zaurus runs on OpenZaurus.

I don't really know what ROM to use though.  Here's the URL to my thread in tyrannozaurus.

http://www.tyrannozaurus.com/?q=node/784#comment-2045

Please help me in trying to figure this out.  Is there a way to revert my Zaurus to the Sharp ROM or should I pick one of the other roms out there?

Can I use SD cards for flashing my rom or do I need a CF card?  Thanks all.

Jack

Pages: 1 [2]