Recent Posts

Pages: 1 ... 8 9 [10]
91
Zaurus - Other distros support / Re: Word/Spreadsheet for Openzaurus sl3000
« Last post by sealbait on July 18, 2022, 10:49:02 pm »
Yes, saying it depends on something and to install that.
92
Zaurus - Other distros support / Re: Word/Spreadsheet for Openzaurus sl3000
« Last post by Varti on July 18, 2022, 03:39:42 am »
Does it return what dependencies it requires? Failing that, the required packages for each ipk are listed in the archive itself, it's in a file called control, compressed as control.tar.gz. It can be extracted with

Code: [Select]
tar zxOf whatever.ipk ./control.tar.gz | tar zxOf - ./control | grep '^Depends: '
For example, the list of dependencies for abiword_2.4.4-r1_armv5te.ipk is
Code: [Select]
enchant, glibc-gconv-ibm850, glibc-gconv-cp1252, glibc-gconv-iso8859-15, glibc-gconv-iso8859-1, libgcc1 (>= 3.4.4), libc6 (>= 2.3.5+cvs20050627), libglade-2.0-0 (>= 2.5.1), gtk+ (>= 2.6.10), libatk-1.0-0 (>= 1.9.0), pango (>= 1.8.1), libglib-2.0-0 (>= 2.6.4), libsm6 (>= 6.0.3), libice6 (>= 6.3.3), libx11-6 (>= 6.2.1), libgnomeprintui-2-2-0 (>= 2.8.2), libgnomeprint-2-2-0 (>= 2.8.2), libgnomecanvas-2-0 (>= 2.12.0), libxml2 (>= 2.6.10), libz1 (>= 1.2.3), libart-lgpl-2-2 (>= 2.3.16), enchant (>= 1.2.5), libfribidi0 (>= 0.10.4), libpng12-0 (>= 1.2.8), libpopt0 (>= 1.7), libxft2 (>= 2.1.6), libfreetype6 (>= 2.1.10), libxrender1 (>= 0.8.4), libfontconfig1 (>= 2.2.95), libstdc++6 (>= 3.4.4)
Varti
93
Zaurus - Other distros support / Re: Word/Spreadsheet for Openzaurus sl3000
« Last post by sealbait on July 17, 2022, 01:28:26 am »
Tried both. Won't install, get error - missing packages. Anyone with any ideas?
94
Cosmo Communicator - CoDi / Re: Codi firmware 1.1.1.16
« Last post by Pali on July 16, 2022, 04:09:43 pm »
Hello.  Please tell me: "Where can I download the firmware files 1.1.1.16?"  Thank you.

url: http://p2w.pripla.com/stm32flash/V1.1.1.16/Cosmo_firmware-stem_ospi2_1_1_1_16.bin
md5sum: 6691e09ce307d078f94f0841a9ca1f6e
95
Cosmo Communicator - CoDi / Re: Manual CoDi flash
« Last post by Pali on July 16, 2022, 04:07:08 pm »
Latest version of firmware image V1.1.1.16 is here: http://p2w.pripla.com/stm32flash/V1.1.1.16/Cosmo_firmware-stem_ospi2_1_1_1_16.bin
Latest version of resources image V1.1.1.14 is here: http://p2w.pripla.com/stm32flash/V1.1.1.14/Cosmo_resource-stem_resource_1_1_1_14.bin
Both images (firmware and resource) are linked from the official update file used b CoDi on: http://fota.planetcom.co.uk/stm32flash/cosmo_stm32_firmware_versions.txt

(Note that on https://support.planetcom.co.uk/index.php/Latest_Cosmo_Firmware#Manual_CoDi_firmware_update is older version V1.1.1.14 of firmware image, resources are latest)

CoDi Assistant in automatic update mode first flashes resources image (bigger one) and after that it flashes firmware image (smaller one). If flashing any image fails then doing retry start reflashing both images.

In case CoDi Assistant successfully flashed resources image in automatic mode then it is enough to just flash firmware image and no need to reflash big resources again. So in this case it is better to manually flash just firmware image manually via advanced menu.

And as @MarcHover wrote, always store images for flashing into top level storage and not into Downloads directory. CoDi Assistant is unable to read image files from Download directory and crashes.

Hopes this help in situation when flashing procedure successfully flashes resources and repeatly fails in 80% during flashing firmware image.
96
Zaurus - Other distros support / Re: Word/Spreadsheet for Openzaurus sl3000
« Last post by sealbait on July 16, 2022, 11:00:38 am »
Thanks, I'll try it
97
New products and alternatives / Re: MNT Pocket Reform
« Last post by Varti on July 15, 2022, 03:18:09 am »
I have been following MNT's products development since they started to develop their first product, the VA2000 video card for the Amiga. Interesting stuff, the most attractive part is the CPU/RAM module, which means you'll be able to upgrade the device with a faster module in the future, providing that they will be available.

Varti
98
Zaurus - Other distros support / Re: Word/Spreadsheet for Openzaurs sl3000
« Last post by Varti on July 15, 2022, 03:11:51 am »
You could give abiword and gnumeric a try:

https://feed-zaurus.dahwa.fr/zaurusfr/openzaurus/3.5.4.1/feed/x11/

This feed is for 3.5.4.1, there are feeds for older OZ versions as well. The packages themselves are old, for newer ones you could try to upgrade to Ångström.

Varti
99
Zaurus - Other distros support / Word/Spreadsheet for Openzaurus sl3000
« Last post by sealbait on July 14, 2022, 11:22:46 pm »
Could anyone guide to a spreadsheet and word for a sl3000 running openzaurus
100
Zaurus - Other distros support / Re: Linux kernel version 6 support
« Last post by greguu on July 14, 2022, 01:40:55 am »

Good stuff, great to see someone picking up the void build.
It's a bit work to keep following upstream, but if regularly build, it's manageable.
I dropped the ball on it as there was not really much of a user-base, at least not known to me via this forum.

In regards to the DT patched for the ZipIt, these can be found here: https://github.com/openwrt-zipit/openwrt-pxa-target/tree/master/pxa/patches-4.4
The ZipIt is quite different in some aspects to the Zaurus, but the CPU is the same.
The patches may give some insight on how to move from platform file to DT though.

..

Yes, need to try the latest kernels. How does the 5.16 work for you vanilla ?
I would think it will just boot, but did mmc and pcmcia/cf work out of the box ?
Does the screen fade white if not used for a while ?
Yatli did some fixes for 5.4 here recently as well : https://github.com/yatli/linux-zaurus-5.4

..

I build kexecboot natively on Arch Linux ARM the last time as always keen to avoid setting up OE build chain for some reason.
There should be support for DT in kexecboot, but I never used it. 

For a new kexecboot kernel that eventually will use DT, we will need to append the .dtb to the zImage as the Zaurus bootloader will not understand DT.
I hope we can actually trim a newer 5.x or even 6.x to fit into the kernel Zaurus kernel partition! It was getting pretty tight with 4.x even.

Pages: 1 ... 8 9 [10]