OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Can Python 2.5 Co-exist With Python 2.4?
Capn_Fish
post Oct 16 2007, 02:15 PM
Post #1





Group: Members
Posts: 2,342
Joined: 30-July 06
Member No.: 10,575



I was going to install my Python package, but then remembered it didn't have all of the modules that the pdaXrom Python 2.4 package has, and so you can't run the config apps. Can you install Python 2.5 and have it exist nicely with 2.4? Otherwise, I could just compile the modules wink.gif

Thanks.
Go to the top of the page
 
+Quote Post
Mickeyl
post Oct 17 2007, 04:24 AM
Post #2





Group: Members
Posts: 1,495
Joined: 12-November 03
From: Germany
Member No.: 907



Depends on the actual packaging. If properly packaged, then you could use update-alternatives for the actual python binary and have python25 is /usr/bin and this reads from /usr/lib/python2.5/*.
Go to the top of the page
 
+Quote Post
Capn_Fish
post Oct 17 2007, 11:00 AM
Post #3





Group: Members
Posts: 2,342
Joined: 30-July 06
Member No.: 10,575



OK, it seems to be OK then (there's a python2.4 and a python2.5 IIRC).

Thanks.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th March 2019 - 05:52 PM