OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
uduo doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
No Information
Joined: 19-March 19
Profile Views: 287*
Last Seen: 20th March 2019 - 05:03 PM
Local Time: Dec 10 2019, 07:49 PM
1 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
20 Mar 2019
Notice that I said myself, I dont have any interest in sending my phone to planet computers to be serviced.

That being said, after a flash I lost my NVRAM and subsequently my IMEI. I've tried just about everything and I THINK I could get it to work if I could find the valid MTK drivers for Windows but that doesnt seem to be working either.


I've found a few ways to go about this.

APPS: (Requires root)
  • Chamelephon
  • MTK Engineering mode
  • Termux

Software: (Requires MTK drivers)
  • Read&Write by WangWenJiang
  • SN Writer Tool
  • Maui Meta

So, as far as my experiences with them.

Chamelephon is the only one I've been able to get to work, and somehow the only time it worked was when I had flashed rooted android, but had not fully rooted it with magisk. I was able to go from no sim card detected to invalid IMEI. With the invalid IMEI status I was able to text and call but not receive cellular data. So I thought maybe if I completed the root with Magisk and tried again I would get cellular but no, after giving Chamelephon root privileges and trying again I went back to no SIM Detected

MTK Engineering mode is supposed to let you change IMEI under CDS Information, but that was not an option listed on my phone.

Rooted Termux apparently allows you to send some 'AT' commands to /etc/radio or something or other but that seemingly had no effect.

I am unable to get ANY of the software to work because I cannot install the MTK drivers properly. I have allowed for unsigned drivers each time and installed via add legacy programs in the device manager manually each time and while I am able to get them installed the drivers are listed as Code 10 (This device cannot start) each time. I have tried the MTK 65xx drivers and the MT6577 drivers, both giving me USB VCOM 8/9 Ports with code 10.

I just want my phone to work as a phone again If anyone has any extra avenues to try, or knows of the proper drivers that work with IMEI Writing software, let me know.
Attached thumbnail(s)
Attached Image
Last Visitors

20 Mar 2019 - 0:02

Other users have left no comments for uduo.

There are no friends to display.
RSS Lo-Fi Version Time is now: 10th December 2019 - 04:49 PM