OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Jeffrey Mark Siskind doesn't have a personal statement currently.
Personal Info
Jeffrey Mark Siskind
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 11-July 18
Profile Views: 500*
Last Seen: 29th September 2018 - 07:00 PM
Local Time: Dec 13 2019, 12:51 AM
10 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

Jeffrey Mark Siskind

Members


Topics
Posts
Comments
Friends
My Content
29 Sep 2018
After a virgin install of Debian, I do an apt-get update and apt-get upgrade. It asks whether I should replace /etc/connnman/main.conf with the developer version. What is the difference? Which version do I want?
29 Sep 2018
I just reflashed. In the past, the first step I do after reflash is apt-get update and apt-get upgrade. Now apt-get update on a virgin reflash
can't find http://http.debian.net/debian or http://cdn-fastly.deb.debian.org/debian

Is this transient or permanent? If the latter, where is the repo now?
23 Sep 2018
Gemini Debian is not able to reliably poweroff. (I'll explain this more below.) It often crashes when trying to poweroff. When this happens, it often is not able to reboot. It just hangs in the splash screen and doesn't display "Linux".

Through various analyses, I have come to believe that the cause of the problem is that a reboot after a crash runs fsck and that often requires user input. AFAIK, Gemini has no equivalent of the grub and VT screens from Debian on amd64 that allow answering fsck queries or booting into a recovery mode.

In my case this is exacerbated by the fact that I have a 512GB SDXC card formatted as one large ext4 partition that I mount with an entry in /etc/fstab. I have discovered that this is likely the cause of the failure to reboot because when that happens, I reinstall Debian into the main flash device, reboot without the /etc/fstab entry, and manually run fsck on the SDXC card, discovering the errors.

This issue has required me to reinstall Debian from scratch 4 times now.

My two questions:

1. Is there an analog of grub booting to a recovery mode or booting with a VT so that I can answer fsck queries?
2. How can I reliably poweroff so this doesn't happen?

I mount the SDXC card as /fs. I have /home/qobi redirected to /fs/home/qobi. And when logged in as qobi, I run twm through .xsession instead of lxqt. I could try to reduce the likelihood of this occurring by eliminating the /etc/fstab entry but this would require me, every time I poweron, to login as gemini to lxqt, mount /fs, logout from gemini, and then login as qobi. And it would require me, every time I poweroff, to logout from qobi, login as gemini to lxqt, umount /fs, then try to poweroff, suspend, or hibernate. This would be tedious.

I poweroff, suspend, and hibernate by running the lxqt variants within my environment. Sometimes some of them work, sometimes not. Even when I use them from within lxqt logged in as gemini, sometimes they work, sometimes not.

It takes me 4 hours to reinstall and reconfigure Debian the way I like it from scratch. I am currently in an unbootable state so an answer to (1) above can help save me 4 hours.
17 Jul 2018
How do you type the "Insert" key?
14 Jul 2018
I'm running DebianTP2. I did an apt-get upgrade today. It broke with unmet dependencies that centered on libreoffice. I am in a state where I am unable to install/remove/upgrade packages with apt. So I removed libreoffice.

apt remove libreoffice \
libreoffice-avmedia-backend-gstreamer \
libreoffice-base \
libreoffice-base-core \
libreoffice-base-drivers \
libreoffice-calc \
libreoffice-common \
libreoffice-core \
libreoffice-draw \
libreoffice-gtk2 \
libreoffice-impress \
libreoffice-java-common \
libreoffice-librelogo \
libreoffice-math \
libreoffice-report-builder-bin \
libreoffice-script-provider-python \
libreoffice-style-galaxy \
libreoffice-writer \
python3-uno

Now I am in a state where all of libreoffice is removed except libreoffice-base. If I attempt to do

root@njere:~# apt-get remove libreoffice-base
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
libreoffice-base
0 upgraded, 0 newly installed, 1 to remove and 52 not upgraded.
20 not fully installed or removed.
After this operation, 6356 kB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 242184 files and directories currently installed.)
Removing libreoffice-base (1:5.2.7-1+deb9u3) ...
dpkg-divert: error: mismatch on package
when removing 'diversion of /usr/lib/libreoffice/share/basic/dialog.xlc to /usr/lib/libreoffice/share/basic/dialog.xlc.noaccess by libreoffice-base'
found 'diversion of /usr/lib/libreoffice/share/basic/dialog.xlc to /usr/lib/libreoffice/share/basic/dialog.xlc.noaccess by --add'
dpkg: error processing package libreoffice-base (--remove):
subprocess installed post-removal script returned error exit status 2
Errors were encountered while processing:
libreoffice-base
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@njere:~#

I am close but still not able to install/remove/upgrade packages with apt.

Any ideas on how to fix? Once I get back to a state where apt works and I have a consistent set of package installations, I'll try to figure out how to get libreoffice installed again.

I am running an unmodified /etc/apt/sources.list* from DebianTP2.

Thanks.
Last Visitors


11 Jul 2018 - 11:07

Comments
Other users have left no comments for Jeffrey Mark Siskind.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 12th December 2019 - 08:51 PM