OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> Problem Booting
post Oct 23 2010, 04:07 PM
Post #1

Group: Members
Posts: 104
Joined: 14-August 06
Member No.: 10,798


i use a sl-c3100
i have untar zubuntu-desktop and spitz-root_addition, taken from : http://www.omegamoon.com/blog/index.php?en...ry090829-014821 : zubuntu 2 for spitz.
on my sd card (/dev/sda1)
on my sd card i have a swap (/dev/sda2)

on my hda1-2-3-5, i have a debian.

since today, i installed kexecboot (i tried 2.6.2, 2.6.34-rc-3 and 2.6.34-rc4), i can't boot on my debian, kexecboot don't see it (before i use u-boot).
kexecboot sees the zubuntu zImage on " /mnt/boot/zImage" on sda1. when i try to load it, just, after recognizing the partition on my hda
zubuntu blocks (won't continue) on this message :

waiting for root device /dev/mmcblk0p1....

the only key of the keyboard who is "recognize" at this point is "on/off"... it tells me that i pressed it when i push it, but the zaurus won't stop. to stop it, i have to remove the battery and the power cable.

what can i do to make something work (old debian, zubuntu... other) ?

ask for others details if needed.
Thank you :)


edit 1 : problem solved after reinstall total of cacko and reinstall zubuntu

edit 2 : after a while booting zubuntu or debian, both on sd card, with kexecboot, problem reappeared (i don't know why).
it seems that only reinstall cacko doesn't help the problem.
i remembered installing android after cacko. and then, reflashed with kexecboot (2.6.34-rc4) .
but no, still doesn't work.

i obviously miss something, but what ?
does anyone as a clue to pass this :
"waiting for root device /dev/mmcblk0p1..." ???
thank you a lot
Go to the top of the page
+Quote Post
post Oct 25 2010, 02:58 PM
Post #2

Group: Members
Posts: 161
Joined: 23-June 05
Member No.: 7,429

Some copies of kexecboot out there don't support SD cards well, and some not at all. Even some 1Gig cards have problems. I wish I could recommend some that work, but I just gave up and moved everything to CF.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 3rd June 2020 - 09:20 AM