OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
gabs5807 doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Birthday Unknown
Gemini PDA, SailfishOS, Debian
Joined: 10-November 18
Profile Views: 1,420*
Last Seen: 9th March 2020 - 08:29 AM
Local Time: Jun 5 2020, 02:55 AM
21 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
25 Dec 2019
At the Jolla Blog i read the following conversation:

ghling on November 20, 2019 at 8:29 am

Any news on the Cosmo Communicator support? With the device finally being in construction and the first batch already shipped to backers (me included), I wonder when we’ll see the first SFOS build for it. The fact that it is mentioned at no point in this post really concerns me.
Does the license offer for existing users apply to the Cosmo as well?
Log in to Reply

James Noori on November 21, 2019 at 2:31 pm

The special offer applies to the supported Xperia devices, as you may see in the table featured in this blog. We cannot speak on behalf of another company, therefore we encourage you to get directly in touch with Planet Computers.

This means, that Planaet should do the first step to get Sailfish on the Cosmo ohmy.gif .

It seems that we have a hen-egg problem here - who do the first step sad.gif ?
So what is the way to trigger the Jolla - Planet communication?

On the PDA the first step was do setup a community Port.
But i did not see any actions for the Cosmo, or did i miss something?

Best regards gabs5807
26 Aug 2019
here a quick HowTo to install gemian beside a licensed SailfishOS on the PDA.

I use a Scatter file from planet partitioning tool with following settings:

First: SailfishOS
Second: recovery
Third: empty (it seems, that there also is the sailfishos_boot.img flushed like at First)
Fourth: TWRP

After downloading all files from Planet and Jolly i modified the content of the .../etc/sysconfig/init from the ramdisk on the sailfishos_boot.img:
# Common settings for normal and recovery init.

# Amount of space to keep unallocated for refilling root or home later on.

# Default size for root LV

Then i rebuild the ramdisk and the sailfishos_boot.img.
After installation there is 20G free space on the sailfish LVM.

On SailfishOS i create a new logical volume named gemian on the free space:
lvcreate -v -ay -Ay -l 100%FREE -n gemian sailfish

Next i extracted the latest linux-boot-lvm-stretch.img and gemian-stretch.img.xz from Adam Boardman (see the thread Final call for TP3) many thanks to Adam.
xzcat gemian-stretch.img.xz | dd of=/dev/sailfish/gemian bs=1024k
dd if linux-boot-lvm-gemian.img of=/dev/disk/by-partlabel/boot2 bs=1024k # 1)

And expand the filesystem on /dev/sailfish/gemian
e2fsck -f /dev/mapper/sailfish-gemian
fsadm resize /dev/sailfish/gemian

Then reboot the PDA using the silver Button to the installed system.

1) It should also be possible to change the filename at boot2 from sailfishos_boot.img to linux-boot-lvm-gemian.img at the Scatter file,
then it should be not necessary to write the stretch boot image on SailfishOS to /dev/disk/by-partlabel/boot2.

Many thanks to all who make this possible biggrin.gif

26 Aug 2019
i updated my Debian 9 to Debian 10 (buster).
Now the Linux Flash Tool did not work anymore unsure.gif.
I also tried it on a new installation.
The PDA is detected, but readback or flush did not work.
The error is:

Then i tried to compile it by myself, but compiling also did not work:
$ make HOST=linux BUILD_TYPE=release
make BUILD_TYPE=release HOST=linux LOG=off  2>&1 | tee build_log.txt
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIC -DQT_NO_CAST_FROM_CAST -D_LINUX -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_GUI_LIB -DQT_XMLPATTERNS_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I../../../SP-Flash-Tool-src-master -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtXmlPatterns -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -isystem /usr/include/libdrm -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -o AppCore.o ../../../SP-Flash-Tool-src-master/Public/AppCore.cpp
In file included from ../../../SP-Flash-Tool-src-master/Public/AppCore.h:16,
                 from ../../../SP-Flash-Tool-src-master/Public/AppCore.cpp:8:
../../../SP-Flash-Tool-src-master/Public/../Utility/Utils.h: In function ?€˜void Utils::SetTextCodec()?€™:
../../../SP-Flash-Tool-src-master/Public/../Utility/Utils.h:114:17: error: ?€˜setCodecForTr?€™ is not a member of ?€˜QTextCodec?€™
../../../SP-Flash-Tool-src-master/Public/../Utility/Utils.h:116:17: error: ?€˜setCodecForCStrings?€™ is not a member of ?€˜QTextCodec?€™
../../../SP-Flash-Tool-src-master/Public/AppCore.cpp: In member function ?€˜bool AppCore::IsSecuLoaded(APKey)?€™:
../../../SP-Flash-Tool-src-master/Public/AppCore.cpp:135:26: warning: catching polymorphic type ?€˜class BromException?€™ by value [-Wcatch-value=]
     }catch(BromException e){
../../../SP-Flash-Tool-src-master/Public/AppCore.cpp: In member function ?€˜bool AppCore::IsAuthLoaded(APKey)?€™:
../../../SP-Flash-Tool-src-master/Public/AppCore.cpp:152:26: warning: catching polymorphic type ?€˜class BromException?€™ by value [-Wcatch-value=]
     }catch(BromException e){
../../../SP-Flash-Tool-src-master/Public/AppCore.cpp: In member function ?€˜int AppCore::CheckSecUnlock(APKey, int)?€™:
../../../SP-Flash-Tool-src-master/Public/AppCore.cpp:169:26: warning: catching polymorphic type ?€˜class BromException?€™ by value [-Wcatch-value=]
     }catch(BromException e)
../../../SP-Flash-Tool-src-master/Public/AppCore.cpp: In member function ?€˜bool AppCore::GetScatterVersion(APKey, char*)?€™:
../../../SP-Flash-Tool-src-master/Public/AppCore.cpp:187:26: warning: catching polymorphic type ?€˜class BromException?€™ by value [-Wcatch-value=]
     }catch(BromException e)
make[2]: *** [Makefile:2437: AppCore.o] Fehler 1
make[2]: Verzeichnis ?€ž/home/gabs/Software/Gemini/_Output/linux/release?€œ wird verlassen
make[1]: *** [Build/build-linux.mk:54: all] Fehler 2
make[1]: Verzeichnis ?€ž/home/gabs/Software/Gemini/SP-Flash-Tool-src-master?€œ wird verlassen

The planet support give me the following answer:
Unfortunately, we do not provide support for the flash tool with Linux. Linux tends to fail 9/10 times when tried to flash our devices with it. This is due to Linux often lacking libraries or settings necessary for the flash tool work, combined with a general lack of understandable diagnostics and issue reports to the user.

The quickest fix here would be to use an available Windows (ideally windows 7) machine. You can also use a virtual machine running Windows 7 through Debian.

I did not have any Windows on my computers (and don't think to buy one ;-)).
So did anyone solved this problem?
Or did i miss some files/packages on my system?

Many thanks

12 Jan 2019
today i read at https://together.jolla.com/question/186471/...anet-computers/ that the SailfishOS Version is released by Jolla (older versions came from Community).

At the link above there is a detailed description howto install it.
Third party licensed Software is not included, but landscape mode should work out of the box rolleyes.gif .

I installed it per ssh and after having a short look on it everything worked fine laugh.gif .
Last Visitors

7 Feb 2020 - 10:03

30 Dec 2019 - 17:02

27 Dec 2019 - 7:13

29 Nov 2018 - 15:22

Other users have left no comments for gabs5807.

There are no friends to display.
RSS Lo-Fi Version Time is now: 4th June 2020 - 05:55 PM