OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Lockscreen Freeze [Partial workaround found]
klf!
post Sep 19 2018, 02:15 AM
Post #1





Group: Members
Posts: 2
Joined: 14-August 18
Member No.: 828,223



From time to time, but overall quite regularly, I'm not able to unlock debian on my gemini anymore.

Usually when on debian, with wifi on, the screen gets locked due to inactivity or manually by a short Fn+Esc hit. Unlocking normally works by hitting Esc (worldmap appears), typing pwd and Enter. So far so good. But from time to time, there is no response on the Esc-wakeup keystroke. The screen just stays black, no worldmap screen showing up.

Trying to login blindly (?screen wakeup problem?) did not succeed. I tried the whole process from login to shutdown blindly by keyboard(*), but the system/device does not respond in any way. Also waiting does not help (checked 30min+ more than once). The only solution in this case I found so far was Fn-Esc (aka "Off") until the device is powered off and reboot from scratch.
Reading the post over at xda-developers, I checked the device is still reachable via network (wifi): yes, and that I can connect via ssh: true (did not tried this before, because the WLAN I use is normally fully isolated from LAN and isolates the clients also, but I took the effort...;-). So the device and debian are basically still running fine. I can't see anything special from the logs (syslog, daemon.log, repowerd.log, debug, auth.log).

Anyone any idea how to go further?

(*) Esc, typing pwd, Enter, Ctrl+Esc, three times cursor up, one time right, four times down and two times Enter ;-)

Edit:
After having ssh available I found out that
   sudo service sddm restart
works around the issue by going to the initial login screen. But unfortunately that's not an option on the go...
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Adam Boardman
post Mar 22 2019, 12:54 AM
Post #2





Group: Members
Posts: 173
Joined: 29-December 17
Member No.: 815,489



Yes, but its still based upon the same upstream version number, you can now install 'gemian-modular-kernel' to get the new (built yesterday) kernel.

Note that you still need to 'dd'/flash the generated boot image to your choice of boot partition depending upon which boot time button combination you press to launch Gemian. A suggested 'sudo dd ...' line should be printed to remind you of this.

This kernel now includes Mithrandir's work to make the kernel support modules, including building out of tree modules (with the matching -headers package). As well as all previous fixes which have improved some of the crashes, though there are still plenty to fix, I'm getting sleep reboots every week or two, Nikita is working on a fix for a race condition that may help this.

Although the build date has no fixed link to what kernel code was built, its what we are using for now to check for kernel versions (uname -a), it certainly works for build server built kernels as they just pull direct from github.

Possibly also of interest the android system.img (the one used by hybris in a LXC container) is now also updatable (gemian-system), and we have a choice of three meta-packages you can install to pull in useful packages, your choice of (gemian-desktop, gemian-desktop-wifi or gemian-desktop-minimal)
Go to the top of the page
 
+Quote Post

Posts in this topic
klf!   Lockscreen Freeze [Partial workaround found]   Sep 19 2018, 02:15 AM
klampfenfreak   nothing more about that very bad black screen bug?...   Nov 2 2018, 07:08 PM
Adam Boardman   I also get this occasionally, and I've twice h...   Nov 3 2018, 03:52 AM
Kiriririn   I've got this 99% fixed on my Gemini, will dig...   Nov 4 2018, 03:13 PM
Kiriririn   I believe the change that fixed it for me was eith...   Nov 5 2018, 08:32 AM
Adam Boardman   Possibly I've not looked in the right diff, bu...   Nov 5 2018, 11:17 AM
Kiriririn   QUOTE(Adam Boardman @ Nov 5 2018, 08:17 P...   Nov 8 2018, 12:13 PM
klampfenfreak   Hi together, I still have this bug. When I close ...   Mar 21 2019, 11:25 AM
Kiriririn   QUOTE(klampfenfreak @ Mar 21 2019, 07:25 ...   Mar 21 2019, 03:10 PM
klampfenfreak   QUOTE(Kiriririn @ Mar 21 2019, 03:10 PM) ...   Mar 21 2019, 04:56 PM
Adam Boardman   Yes, but its still based upon the same upstream ve...   Mar 22 2019, 12:54 AM
Eric BF   QUOTE(Adam Boardman @ Mar 22 2019, 08:54 ...   Mar 28 2019, 03:54 AM
klampfenfreak   Thank you for helping how to flash the kernel. Now...   Mar 22 2019, 04:08 PM
mithrandir   QUOTE(klampfenfreak @ Mar 22 2019, 04:08 ...   Mar 23 2019, 04:05 AM
Adam Boardman   Sounds like you've got a new one, least someth...   Mar 22 2019, 11:42 PM
klampfenfreak   Hi, thank you very much. Yesterday I reflashed th...   Mar 25 2019, 10:47 AM
Adam Boardman   TP2 is Technical Preview 2, it was just following ...   Mar 25 2019, 02:24 PM
mithrandir   Tried cifs myself with the modular kernel and it w...   Mar 25 2019, 03:14 PM
klampfenfreak   Hi, ok, I reinstalled the modular kernel and flas...   Mar 28 2019, 05:50 AM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th October 2019 - 04:35 PM