OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> Cosmo Communicator running on Google Fi, per title
post Nov 10 2019, 09:20 AM
Post #1

Group: Members
Posts: 110
Joined: 9-January 18
Member No.: 816,120

Alright. I have about 48 hours now of getting acquainted with my new Cosmo and sorting out the ends and bits of using it as an unsupported device on Google Fi.

Top line? Works - so long as you DO NOT INSTALL THE GOOGLE FI APP. Doing so means that if you ever want to receive an SMS message again you're looking at a factory reset AND getting stuck in a never ending loop of failed device registration.

I shut down my old Google Fi phone, pulled the SIM, put it and a 400GB Sandisk card into the Cosmo, powered on and it worked. Then I installed the Google Fi app, merrily went about installing dozens of other things - then figured out that my SMS sends were not making it through.

Trouble shooting on a long road... I went through four factory resets, trying different methods and twists of installing the Google Fi app. Voice, data, SMS work before installing the Google Fi app. After, Voice and Data still work, SMS receive works, but SMS send dies and the app fails to register the device properly - which throws it into a never ending fail to register loop - which eats battery..

Other than not being able to run the Google Fi application itself, it seems to be working quite well. Every time I restart, the device prompts me to install the Google Fi application so that it is fully registered. So, I have to select 'later' every time.

When I log into the Google Fi application via web browser, it has the Planet Cosmo Communicator listed as one of my devices and with my proper phone number assigned to it.

Will this device ever be fully supported by Google Fi and it's application? Well, I doubt Google Fi is going to even blink unless they have a few thousand of these showing up on their network.

Is anyone else trying to use the Cosmo on Google Fi? Have you had any better/worse/different results than I have?
Go to the top of the page
+Quote Post
Tom D
post Nov 16 2019, 07:52 AM
Post #2

Group: Members
Posts: 34
Joined: 5-January 18
Member No.: 815,874

QUOTE(Grench @ Nov 10 2019, 11:20 AM) *
Is anyone else trying to use the Cosmo on Google Fi? Have you had any better/worse/different results than I have?

I do. I always use Google Hangouts for SMS, so I have had no issue with SMS. I did have trouble activating with the Fi app. It was weird, Data and Voice worked, but Fi would not activate. Tech support basically said my phone was unsupported. I finally figured it out. I had a Pixel 3 with an eSIM. I had to erase the eSIM in the PIxel 3 first. I didn't try the eSIM in the Cosmo - I had order a SIM from Google Fi, and it finally activated. Hopefully this might help someone else.

I don't think Google Voice is supported with Fi anymore, you have to use Hangouts.
Go to the top of the page
+Quote Post
Jesse from Ohio
post Dec 11 2019, 02:28 PM
Post #3

Group: Members
Posts: 6
Joined: 21-November 19
Member No.: 859,956

Just got my Cosmo yesterday, super excited to upgrade from my old, failing original Pixel.

Had a few things set up in my Cosmo last night, then finally shut it down and installed the SIM from my Pixel. When it booted up, it told me I needed to install the FI app, so I agreed and went through the activation process. Seemed like it got most of the way done, but got to a point where there was an error ID:080. Called tech support, got same story, the Cosmo is just not supported. Retried the Fi registration several times, but it never succeeded.

After that I did a factory reset, rebooted, but this time did not agree to install the FI app. Shortly after I got a Cosmo notification that I needed to configure the SIM card. I only have the one, so SIM 1 for voice, SIM 1 for data. It seemed to be hit or miss after that, sent a couple texts, received a couple texts (although one had some weird gibberish at the end). Made a couple test calls, but 2/4 inbound calls went straight to voicemail (one of them may have been when I was rebooting, but one was definitely when I was sitting there waiting for the incoming call).

After the above test where I had used the Cosmo settings to configure the SIM card, I installed the Fi app again, and this time it registered with no an errors. Now the Fi app is installed, I got the two voicemails form the missed calls. I still have some testing to do, have to make sure both inbound and outbound texts and calls will still work, but I'm hopefull.

Also, if the pre-installed "Messaging" app (green icon) doesn't work with Fi, I will try installing the "Messages" app from Google LLC (blue icon) that I've been using on my Pixel. Seems like it may have better compatibility with Fi. @Grench did you happen to try this method for sending texts with the Fi app installed?
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 26th January 2020 - 02:11 PM