OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
defunked doesn't have a personal statement currently.
Personal Info
defunked
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 21-July 18
Profile Views: 667*
Last Seen: Today, 11:29 AM
Local Time: Apr 23 2019, 07:52 PM
23 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

defunked

Members


Topics
Posts
Comments
Friends
My Content
7 Nov 2018
I have heard that others have been able to get wifi tethering to work on the Gemini community edition (PC flash image) of sailfish via the terminal/shell. I have been trying to use "connmanctl tether wifi on <ap-name> <ap-password>" under the su-devel root-ish account. But no luck. I always get back:

Error enabling wifi tethering: In Progresses

After which the GUI continues to show WiFi operating as a client.

Yes I have 4G data service. But I noticed that "connmanctl scan wifi" yields no results. Is connman broken in the community edition? If so, how is networking handled by the GUI in the first place? Maybe there is a "special" version of connmanctl tucked away some place?

I am about to do some traveling and will be needing to do a WiFi tether from time to time. So any help would be appreciated.

Thanks!
1 Sep 2018
I am trying to use a USB Ethernet adapter on my Gemini. I installed the usbutils package to get access to the lsusb command. This shows the ethernet USB device when plugged into the Gemini's left USB port. However, the interface doesn't show up in the ifconfig -a command result. I have no idea how sailfish detects and changes the network interface list. Since sailfish has no /etc/network directory, I assume networking setup involves the systemd beast. Has any one been able to get a USB Ethernet adapter to working?
27 Jul 2018
As I continue on my Sailfish/Gemini journey, I finally got LTE data working in the USA on the Verizon network.
With that now working, I discovered a new Sailfish bug: When the device switched the network default route between LTE to WiFi, the default route disappears from the routing table,
as observed via shell executed netstat -r. I need to reboot to get the network stack working again, or manually add a default route back in as su-devel:

route add default gw 192.168.11.1 wlan0

for example to get things working again with my inhouse WiFi.

Also, I can receive phone calls while registered on LTE, but after the call, Sailfish compains that no SIM is inserted until I reboot.

I am still learning my way around this OS, so I don't think I can be much help yet.
23 Jul 2018
I have come across two audio related problems with Sailfish CE on the Gemini. First, when headphones are plugged in to the device, the speakers continue to produce audio along with the headphone. It is my understanding that the Gemini has a single stereo audio DAC, but I expected the OS/driver to switch the output path from the speakers/amplifier to the headphones, when the headphones are inserted. In addition, the headphone are mono, along with the speakers.. That is certainly not right. I know the speakers are mono (and apparently phase inverted), but my understanding was that this hardware bug did not apply to the headphone jack. Has any one else noticed this behavior?

Bluetooth audio sending works fine.

Last Visitors


22 Jul 2018 - 23:46

Comments
Other users have left no comments for defunked.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 23rd April 2019 - 06:52 PM