OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
TimW doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
London, UK
Birthday Unknown
No Information
Joined: 8-December 03
Profile Views: 2,787*
Last Seen: 16th March 2020 - 05:14 AM
Local Time: Mar 31 2020, 03:34 AM
296 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
1 Feb 2020
I connect to several VPNs. Two are L2TP PSK and one is OpenVPN. All 3 work perfectly on my Gemini , laptop and other android devices but the Cosmo will not connect to either of the L2TP ones. OpenVPN works but not L2TP.
Has anyone had success with VPNs other than OpenVPN?
29 Jun 2007
I think opie-reader development may be stalled for a while since I no longer have a Zaurus. I took it along with me to an athletics meet to support my daughter (it was a long time between her races so I needed something to read) and someone stepped on it.

Whoops, no more screen sad.gif

I've managed to get hold of an old iPaq. If I can get Opie running on that I'll be okay but ATM it won't even turn on. If I can't get anything going on that I won't be able to justify the cost of a new Zaurus so...

Mind you, I need a new phone, I wonder if I can persuade my wife that a Greenphone would be a good idea? biggrin.gif
8 Mar 2006
I've been using keypebble but was getting frustrated at the lack of support for the newer encodings - so I went ahead and added them. I can't build for opie devices ATM so this release is for Sharp based ROMs only. Some features are a little experimental so this is not yet a full release.

You can get it here:

The name-change (to teakettle) is temporary so you can keep keypebble installed alongside it just in case you have problems. Once I get it stable it'll become just a mod to keypebble. It appears as VNC Viewer2 on your Applications tab. If you do run keypebble alongside it, remember to turn off the new encodings in teakettle before opening up keypebble as the configuration file is shared and I believe keypebble will actually request some of the encodings it can't handle if they are enabled from teakettle.

If you could let me know how you get on and if there are any other features you want added, I'd be grateful.

From the README:

Additions to keypebble by Tim Wentford

1) Added ZRLE, zlib, hextile, CoRRE and RRE encoding support.

2) Added a "Fit remote desktop to local screen" scale method (set the
scale factor to 0 to see it in action).

3) Modified the way that the refresh rate is used to more closely
match the use documented in the rfb standard.

4) Added a "Request Refresh Now" and "Set Refresh Rate Slower/Faster"
items to the corner menu (I like to slow the refresh rate down when
I'm monitoring stuff, but to speed it back up when I'm controlling

5) Modified the scaling mechanism to avoid missing pixels when
rectangles which aren't a multiple of the scale factor arrive (the
screen still gets "fuzzy" when this happens but it looks better
than the missing lines to me).

6) Added an experimental "Auto" mode to choose the preferred encoding
automatically based on an approximate measure of how long a screen
refresh would take.

7) Tried to improve the interactivity during a long refresh (I'm not
sure if I've succeeded in this so I haven't done it throughout - if
you want to experiment replace the call to start the timer in
endRect with a direct call to doOneRect: if it works, let me know
and I'll extend it to work better with hextile and ZRLE encodings
(by using the timer between tiles as well as between rectangles)).

8) Added local cursor encoding. This is supposed to save on bandwidth
by allowing the server to send updates to the cursor shape so that
the remote machine can draw the cursor itself. A server can then
take advantage of this by not sending updates every time the cursor
moves. I haven't found much advantage in using this yet, and I
don't really handle it properly since I choose not to draw the
cursor at all - which is probably appropriate for a touch screen

9) Added resize encoding so that the remote device can handle screen
size changes properly.

10) Some attempts at optimisation - though currently I've probably
added more overhead than I've saved.

11) Added the SHARPROM #define so that it can be built more easily for
standard Qtopia devices.


1) Occasional floating point exception at connection.

I'm not sure if that is something I've added or not. If you get this persistently from a particular server try checking the "Request 8-bit session" box.

2) I can't currently build for opie based machines.

Even the original code freshly checked out of the CVS segfaults for me
when I build it for an Opie target so I have only tested this on a
Sharp ROM based Zaurus.

3) I'm not sure that I can get much of a sample to estimate bandwidth
in hextile encoding...

...so you may get stuck in hextile encoding when using auto mode.

4) I haven't tested auto mode in a wide enough set of networks, yet.

Which is why I'm making this release.
31 Aug 2005
I think I know why previous versions of opie-reader didn't work on the archos. There is a bug in Qtopia 1.5 (which the Sharp ROM is based on) which I work around. The Archos is based on a later version of Qtopia so doesn't need the work around. I have now built a version of opie-reader using gcc2.x with the work around removed. I any one wants to try it you can get it here.

If you have tried older versions of opie-reader make sure to delete ~/Setting/uqtreader.conf first.
31 Aug 2005
I've managed to get access to my webpage at last so I quickly pushed the current versions of opie-reader up there while it lasted.

There are four versions:

Sharp ROM
Sharp ROM (statically linked) - use this if the above won't work for you.
OE builds using GCC 3.x - e.g. OpenZaurus/Opie
Qtopia versions 1.6 or greater builds with gcc 2.x - this should work with the Archos, qtopia 2.x ROM or the Cacko Qtopia 1.6 ROM (all untested)

I've discovered that some problems with the builds which are dynamically linked may be due to me not refreshing the library cache in the ipk. If you find that your install doesn't work try a reboot or soft reset. Anyone who knows how to refresh the dynamic library cache from an ipk let me know 8^).

Because I had a relatively small window in which to post them I haven't tested the ipks quite as much as I usually do so let me know of any problems in this thread.
Last Visitors

1 Feb 2020 - 8:47

21 Sep 2018 - 13:10

10 Mar 2018 - 6:32

5 Oct 2008 - 6:38

6 Nov 2007 - 12:04

Other users have left no comments for TimW.

There are no friends to display.
RSS Lo-Fi Version Time is now: 30th March 2020 - 06:34 PM