OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
zenyatta doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Birthday Unknown
No Information
Joined: 4-November 03
Profile Views: 3,423*
Last Seen: 1st March 2009 - 07:07 AM
Local Time: Dec 14 2019, 12:15 AM
366 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
19 Feb 2009
Hi all,

I've been trying to bring my trusty SL-5500 back to life. I have successfully set up OpenEmbedded, built and flashed kexecboot. I'm currently stuck on a few issues:

1. SD card isn't really working. An Angstrom image unpacked onto an ext2 SD partition is recognized by kexecboot but booting ends with a flurry of error messages like this:

Buffer I/O error on device mmcblk0p1, logical block 8
mmcblk0: retrying using single block read
mmcblk0: error -22 sending status comand<3>mmcblk0: error -22 sending read/write command, response 0x4, card status 0xff04
end_request: I/O error, dev mmcblk0, sector 104

The same error messages turn up if I boot from ROM or a CF card and then insert an SD card. The most recent kernel I've tried this with is from this morning (19 February 2009) and it's a 2.6.28. I have seen this with two different cards from two different manufacturers. I have tested the cards for errors on a different machine and they seem to be OK.

2. An Opie image on a CF card boots up to the "Tap anywhere..." screen where it freezes.

3. Battery charging doesn't work. When the charger is connected the LED doesn't light up and the battery stays discharged even after several hours. I've established that this isn't a hardware problem - when I flash a Sharp ROM (from http://www.myzaurus.com/ROMupdate5.asp) everything works as it's supposed to.

Any help with any of these issues will be appreciated. A few particular questions:

- regarding issue 3: I've read about a "service menu" accessible by pressing some key or key combination while connecting the charger. Supposedly one can set various voltage thresholds in the menu but I've never been able to get to it in the first place. Anyone know any details?

- regarding issue 1: I have a vague impression that the first OE images I built a couple weeks ago didn't have the SD card problem. Is there a particular node in the git tree that's been verified to have working SD support on collie? Also, would anyone be willing to check SD access on a current OE image on their own collie?

The device is otherwise pretty functional - I can even ssh to the collie over a USB cable. I think I'll make the thing useful again eventually.


14 Apr 2005
Hi all,

I lost my treasured 5500 a few weeks ago. I need a replacement quite badly but my budget is limited. I am looking to spend about US$150 plus shipping, not more than US$180 all together (I live in the EU).

As I'm looking for a replacement, I really don't care much about accessories (I already have what I need). All I need is the unit itself, although I wouldn't mind a CF memory card (lost mine with the Z). Ideally, I would like to buy from someone who is upgrading, or has just upgraded, to a clamshell.

C'mon folks, don't let me down!

20 Mar 2005
Hi all,

I started working on a Zaurus port of the fine TreeLine outliner early last year but later got distracted. I haven't touched it in about 7 months now and it isn't really ready for a release but I do use it daily and absolutely can't do without it, despite the bugs. As I have trouble finding the time to finish it, I have decided to release it in its crude present state. Either someone will pick it up or enough users will find it promising enough to nag me into activity rolleyes.gif Or maybe it won't interest anyone, which is fine. In any case, it is there, on my homepage.

30 Oct 2004
Hi all,

today I tried to "oemake opie-image" from a fresh snapshot (2004/10/30 05:00) and libopie2 complained during linking about missing -lsqlite. Can anyone suggest a work-around or point me to the most recent snapshot that is known to build? Thanks.


P.S. I think it would be nice to have a thread where you could mention OE build problems, listing the snapshot you are using and the point where it breaks. This may be such a thread for the future if anyone picks up on the idea. And for people who have absolutely no idea what this post is about, there's an explanation.
22 Oct 2004
Hi all,

if anyone of you tried the sound recorder app that comes with 3.5.1, you probably produced samples of length 0.00 seconds - at least that's what happened to me. Turns out it can be fixed quite easily: edit /root/Settings/OpieRec.conf and in the [Hardware] section, add or modify these two lines:

Audio = /dev/dsp1
Mixer = /dev/mixer1

You should now be able to record audio with these caveats:
  • It seems that opie-recorder severely miscalculates maximum allowable sample duration (there must be a multiplication error somewhere). The upshot is that if you leave Limit Size (under Options) at Unlimited, recording will automatically stop after as little as a second (with 10MB of free storage left). The solution is to set Limit Size to the highest possible numerical value, i.e. 60.
  • If you change sample rate or bit depth, it is a smart move to shut down and re-start opie-recorder. Otherwise you will get .wav files with incorrect sample rate specifications - to great comic effect I must say.
  • You will not be able to play back what you record, because while /dev/dsp1 is the correct device for recording, /dev/dsp is the one for playback. opie-recorder currently does not support specifying one device for recording and another one for playback. Workaround: use xmms-embedded to play back your wav files. Alternatively, you can keep two versions of OpieRec.conf and set up scripts which will run opie-recorder with the proper version depending on whether you want to record or play back.
  • As for mixers, both /dev/mixer and /dev/mixer1 seem to work fine for playback although I once got an infinite loop with one of them, forcing a soft-reboot (can't remember which device it was, though). For recording, /dev/mixer1 seems logical (although I haven't actually tried altering input volume).
Hope this helps.

Last Visitors

7 Jul 2009 - 13:16

Other users have left no comments for zenyatta.

There are no friends to display.
RSS Lo-Fi Version Time is now: 13th December 2019 - 02:15 PM