Printable Version of Topic

Click here to view this topic in its original format

OESF Portables Forum _ Gemini PDA - Linux _ Problems latest firmware

Posted by: cam1965 May 28 2019, 10:31 AM

Hi.
I've installed the latest firmwares ( debian and root OREO ) from planet site.
After this, I've noticed that my saved wireless connections are lost after boot.( in debian ).
They worked fine, but when I reboot the gemini PDA, I have to select my network and fill again the password.
Tried Connman, network-manager and the error persists. When botting again, I have to select again my wireless SSID and fill the password.
Looked inside /var/lib/connman and my network is saved there.
Also another problem : I' ve compiled a modular kernel and when flashing my gemini PDA with this kernel, it not boots under debian. Also tried another old kernels from planet that was saved in the past and the same occurs ( not booting into debian ). Only works with the suplied latest kernel.
So, what is the .config file in this kernel or another configuration is needed ? what is wrong ?
Thank you so much !

[Thread moved from the New Members validation forum. Varti]

Posted by: cam1965 May 29 2019, 01:11 AM

QUOTE(cam1965 @ May 28 2019, 10:31 AM) *
Hi.
I've installed the latest firmwares ( debian and root OREO ) from planet site.
After this, I've noticed that my saved wireless connections are lost after boot.( in debian ).
They worked fine, but when I reboot the gemini PDA, I have to select my network and fill again the password.
Tried Connman, network-manager and the error persists. When botting again, I have to select again my wireless SSID and fill the password.
Looked inside /var/lib/connman and my network is saved there.
Also another problem : I' ve compiled a modular kernel and when flashing my gemini PDA with this kernel, it not boots under debian. Also tried another old kernels from planet that was saved in the past and the same occurs ( not booting into debian ). Only works with the suplied latest kernel.
So, what is the .config file in this kernel or another configuration is needed ? what is wrong ?
Thank you so much !

[Thread moved from the New Members validation forum. Varti]


deleted linux. I am only with android OREO now. Thank you all.

Posted by: mithrandir May 29 2019, 08:21 AM

QUOTE(cam1965 @ May 29 2019, 01:11 AM) *
QUOTE(cam1965 @ May 28 2019, 10:31 AM) *
Hi.
I've installed the latest firmwares ( debian and root OREO ) from planet site.
After this, I've noticed that my saved wireless connections are lost after boot.( in debian ).
They worked fine, but when I reboot the gemini PDA, I have to select my network and fill again the password.
Tried Connman, network-manager and the error persists. When botting again, I have to select again my wireless SSID and fill the password.
Looked inside /var/lib/connman and my network is saved there.
Also another problem : I' ve compiled a modular kernel and when flashing my gemini PDA with this kernel, it not boots under debian. Also tried another old kernels from planet that was saved in the past and the same occurs ( not booting into debian ). Only works with the suplied latest kernel.
So, what is the .config file in this kernel or another configuration is needed ? what is wrong ?
Thank you so much !

[Thread moved from the New Members validation forum. Varti]


deleted linux. I am only with android OREO now. Thank you all.


Giving up a bit fast...
A
sudo apt install gemian-modular-kernel; apt install gemian-modular-kernel-headers
and following the instructions would have done...
Wifi works for me...

Posted by: cam1965 May 30 2019, 04:02 AM

QUOTE(mithrandir @ May 29 2019, 08:21 AM) *
QUOTE(cam1965 @ May 29 2019, 01:11 AM) *
QUOTE(cam1965 @ May 28 2019, 10:31 AM) *
Hi.
I've installed the latest firmwares ( debian and root OREO ) from planet site.
After this, I've noticed that my saved wireless connections are lost after boot.( in debian ).
They worked fine, but when I reboot the gemini PDA, I have to select my network and fill again the password.
Tried Connman, network-manager and the error persists. When botting again, I have to select again my wireless SSID and fill the password.
Looked inside /var/lib/connman and my network is saved there.
Also another problem : I' ve compiled a modular kernel and when flashing my gemini PDA with this kernel, it not boots under debian. Also tried another old kernels from planet that was saved in the past and the same occurs ( not booting into debian ). Only works with the suplied latest kernel.
So, what is the .config file in this kernel or another configuration is needed ? what is wrong ?
Thank you so much !

[Thread moved from the New Members validation forum. Varti]


deleted linux. I am only with android OREO now. Thank you all.


Giving up a bit fast...
A
sudo apt install gemian-modular-kernel; apt install gemian-modular-kernel-headers
and following the instructions would have done...
Wifi works for me...

OK.

Installed again linux.
Installed ( already installed the modular kernel ).
Changed the 3.41.18 to 3.41.18+ in /lib/modules to reflect the name of kernel. LDCONFIG. But when I try to insert any module ( modprobe for example usbserial ) a message appears that this funtcion is not implemented. Git hub on the source kernel and compiled only the modules for the latest kernel . Again the same message appears. Compiled another kernel, but when flashed this kernel, gemini won' t boot. Only with supplied kernel . So this is a problem.
About wifi it is working and saving connections. Maybe some files I have installed to compile solve this.
If someone can help,please let me know.
A modular kernel that I can't load any module doesn't help.
Thank you alll

Posted by: mithrandir May 30 2019, 07:23 AM

QUOTE(cam1965 @ May 30 2019, 04:02 AM) *
QUOTE(mithrandir @ May 29 2019, 08:21 AM) *
QUOTE(cam1965 @ May 29 2019, 01:11 AM) *
QUOTE(cam1965 @ May 28 2019, 10:31 AM) *
Hi.
I've installed the latest firmwares ( debian and root OREO ) from planet site.
After this, I've noticed that my saved wireless connections are lost after boot.( in debian ).
They worked fine, but when I reboot the gemini PDA, I have to select my network and fill again the password.
Tried Connman, network-manager and the error persists. When botting again, I have to select again my wireless SSID and fill the password.
Looked inside /var/lib/connman and my network is saved there.
Also another problem : I' ve compiled a modular kernel and when flashing my gemini PDA with this kernel, it not boots under debian. Also tried another old kernels from planet that was saved in the past and the same occurs ( not booting into debian ). Only works with the suplied latest kernel.
So, what is the .config file in this kernel or another configuration is needed ? what is wrong ?
Thank you so much !

[Thread moved from the New Members validation forum. Varti]


deleted linux. I am only with android OREO now. Thank you all.


Giving up a bit fast...
A
sudo apt install gemian-modular-kernel; apt install gemian-modular-kernel-headers
and following the instructions would have done...
Wifi works for me...

OK.

Installed again linux.
Installed ( already installed the modular kernel ).
Changed the 3.41.18 to 3.41.18+ in /lib/modules to reflect the name of kernel. LDCONFIG. But when I try to insert any module ( modprobe for example usbserial ) a message appears that this funtcion is not implemented. Git hub on the source kernel and compiled only the modules for the latest kernel . Again the same message appears. Compiled another kernel, but when flashed this kernel, gemini won' t boot. Only with supplied kernel . So this is a problem.
About wifi it is working and saving connections. Maybe some files I have installed to compile solve this.
If someone can help,please let me know.
A modular kernel that I can't load any module doesn't help.
Thank you alll


Config for the kernel is https://github.com/gemian/gemini-linux-kernel-3.18/blob/native/arch/arm64/configs/gemini_modular_defconfig

Function not implemented looks like you have flashed a kernel without module support. The "+" reflects changes with respect to the git repo. This also affects module version magic. So a kernel without + cannot load a module with +. You can git rid of the + by editing include/generated/utsrelease.h @see: https://stackoverflow.com/questions/33839191/kernel-version-change-causes-error .

Pleas go more into detail. Have you installed the modular kernel package? Afterwards have you dd'd the kernel to the right partition (depending on your scatter file)? I.e.:
dd if=/usr/share/kernel/linux-boot.img of=/dev/disk/by-partlabel/boot
Important: Depending on your setup output can be boot, boot1, boot2 or boot3.

What are you trying to accomplish? Do you really want to build an own kernel or do you just want to have a module? If it is the latter see the post at: https://www.mygnu.de/2019/04/modular-kernel-for-the-gemini-pda-available-from-the-gemian-repository/

Mith

Posted by: cam1965 May 30 2019, 07:42 AM

QUOTE(mithrandir @ May 30 2019, 07:23 AM) *
QUOTE(cam1965 @ May 30 2019, 04:02 AM) *
QUOTE(mithrandir @ May 29 2019, 08:21 AM) *
QUOTE(cam1965 @ May 29 2019, 01:11 AM) *
QUOTE(cam1965 @ May 28 2019, 10:31 AM) *
Hi.
I've installed the latest firmwares ( debian and root OREO ) from planet site.
After this, I've noticed that my saved wireless connections are lost after boot.( in debian ).
They worked fine, but when I reboot the gemini PDA, I have to select my network and fill again the password.
Tried Connman, network-manager and the error persists. When botting again, I have to select again my wireless SSID and fill the password.
Looked inside /var/lib/connman and my network is saved there.
Also another problem : I' ve compiled a modular kernel and when flashing my gemini PDA with this kernel, it not boots under debian. Also tried another old kernels from planet that was saved in the past and the same occurs ( not booting into debian ). Only works with the suplied latest kernel.
So, what is the .config file in this kernel or another configuration is needed ? what is wrong ?
Thank you so much !

[Thread moved from the New Members validation forum. Varti]


deleted linux. I am only with android OREO now. Thank you all.


Giving up a bit fast...
A
sudo apt install gemian-modular-kernel; apt install gemian-modular-kernel-headers
and following the instructions would have done...
Wifi works for me...

OK.

Installed again linux.
Installed ( already installed the modular kernel ).
Changed the 3.41.18 to 3.41.18+ in /lib/modules to reflect the name of kernel. LDCONFIG. But when I try to insert any module ( modprobe for example usbserial ) a message appears that this funtcion is not implemented. Git hub on the source kernel and compiled only the modules for the latest kernel . Again the same message appears. Compiled another kernel, but when flashed this kernel, gemini won' t boot. Only with supplied kernel . So this is a problem.
About wifi it is working and saving connections. Maybe some files I have installed to compile solve this.
If someone can help,please let me know.
A modular kernel that I can't load any module doesn't help.
Thank you alll


Config for the kernel is https://github.com/gemian/gemini-linux-kernel-3.18/blob/native/arch/arm64/configs/gemini_modular_defconfig

Function not implemented looks like you have flashed a kernel without module support. The "+" reflects changes with respect to the git repo. This also affects module version magic. So a kernel without + cannot load a module with +. You can git rid of the + by editing include/generated/utsrelease.h @see: https://stackoverflow.com/questions/33839191/kernel-version-change-causes-error .

Pleas go more into detail. Have you installed the modular kernel package? Afterwards have you dd'd the kernel to the right partition (depending on your scatter file)? I.e.:
dd if=/usr/share/kernel/linux-boot.img of=/dev/disk/by-partlabel/boot
Important: Depending on your setup output can be boot, boot1, boot2 or boot3.

What are you trying to accomplish? Do you really want to build an own kernel or do you just want to have a module? If it is the latter see the post at: https://www.mygnu.de/2019/04/modular-kernel-for-the-gemini-pda-available-from-the-gemian-repository/

Mith


I've installed the modular kernel ( it is the default install when flashing the latest image of debian ).
I've installed the kernel-headers also.
The modules are not loadable since in /lib/modules there is a folder 3.18.41 ( withoout + ). So I've changed it to 3.41.18+ and depmod - a . But when loading a module the message mentioned that this function is not implemented appears.
So, I decided to compile the modules from github. Now the folder inside /lib/modules is 3.18.41+. But when loading the modules ( modprobe ) the same message appears.
So, I've decided to compile my onwn version of kernel, but the kernel doesn't boot as explained.
My partition is correct ( boot2 ) . the debian boot image is placed in the correct partition.
When I had the older android ( 7) with my own kernel and my own modules compiled and a scatter file ( old ) everything was working.
These problems are with the latest oreo firmware and the latest firmware debian and the latest scatter file from gemini site .
Remind that the kernel is with + sign ( 3.18.41+ ) and in the /lib/modules the folder is 3.18.41 ( without + ). ( this is the default installation without any modifications ). Both would have to reflect the same number.
Thank you again

Posted by: mithrandir May 30 2019, 09:17 AM

QUOTE(cam1965 @ May 30 2019, 07:42 AM) *
I've installed the modular kernel ( it is the default install when flashing the latest image of debian ).
I've installed the kernel-headers also.
The modules are not loadable since in /lib/modules there is a folder 3.18.41 ( withoout + ). So I've changed it to 3.41.18+ and depmod - a . But when loading a module the message mentioned that this function is not implemented appears.
So, I decided to compile the modules from github. Now the folder inside /lib/modules is 3.18.41+. But when loading the modules ( modprobe ) the same message appears.
So, I've decided to compile my onwn version of kernel, but the kernel doesn't boot as explained.
My partition is correct ( boot2 ) . the debian boot image is placed in the correct partition.
When I had the older android ( 7) with my own kernel and my own modules compiled and a scatter file ( old ) everything was working.
These problems are with the latest oreo firmware and the latest firmware debian and the latest scatter file from gemini site .
Remind that the kernel is with + sign ( 3.18.41+ ) and in the /lib/modules the folder is 3.18.41 ( without + ). ( this is the default installation without any modifications ). Both would have to reflect the same number.
Thank you again

It is really strange that your kernel has the + appended. The latest kernel from the repository should not have it. What is the output of uname -a ?
Build date should be Fri May 24 19:53:00.
Mith

Posted by: cam1965 May 30 2019, 09:28 AM

QUOTE(mithrandir @ May 30 2019, 09:17 AM) *
QUOTE(cam1965 @ May 30 2019, 07:42 AM) *
I've installed the modular kernel ( it is the default install when flashing the latest image of debian ).
I've installed the kernel-headers also.
The modules are not loadable since in /lib/modules there is a folder 3.18.41 ( withoout + ). So I've changed it to 3.41.18+ and depmod - a . But when loading a module the message mentioned that this function is not implemented appears.
So, I decided to compile the modules from github. Now the folder inside /lib/modules is 3.18.41+. But when loading the modules ( modprobe ) the same message appears.
So, I've decided to compile my onwn version of kernel, but the kernel doesn't boot as explained.
My partition is correct ( boot2 ) . the debian boot image is placed in the correct partition.
When I had the older android ( 7) with my own kernel and my own modules compiled and a scatter file ( old ) everything was working.
These problems are with the latest oreo firmware and the latest firmware debian and the latest scatter file from gemini site .
Remind that the kernel is with + sign ( 3.18.41+ ) and in the /lib/modules the folder is 3.18.41 ( without + ). ( this is the default installation without any modifications ). Both would have to reflect the same number.
Thank you again

It is really strange that your kernel has the + appended. The latest kernel from the repository should not have it. What is the output of uname -a ?
Build date should be Fri May 24 19:53:00.
Mith


Hi, I am at work without my gemini.
Later at night ( more 6 hours when I arrive at home ) I will put here the results, but I am pretty sure that the output has a + signal at the end. ( when I initially posted here I did this command ).
I will confim this later.
latest firmware are here : http://support.planetcom.co.uk/download/LinuxFirmware8/LinuxFirmware.html ( debian.zip date -- 2019 - may 16 )
But I did all updates after the first flash.

Thank you.

Posted by: mithrandir May 30 2019, 11:47 AM

QUOTE(cam1965 @ May 30 2019, 09:28 AM) *
Hi, I am at work without my gemini.
Later at night ( more 6 hours when I arrive at home ) I will put here the results, but I am pretty sure that the output has a + signal at the end. ( when I initially posted here I did this command ).
I will confim this later.
latest firmware are here : http://support.planetcom.co.uk/download/LinuxFirmware8/LinuxFirmware.html ( debian.zip date -- 2019 - may 16 )
But I did all updates after the first flash.

Thank you.

Please also give the output of:
dpkg -l|grep "\-kernel"

Posted by: cam1965 May 30 2019, 12:45 PM

QUOTE(mithrandir @ May 30 2019, 11:47 AM) *
QUOTE(cam1965 @ May 30 2019, 09:28 AM) *
Hi, I am at work without my gemini.
Later at night ( more 6 hours when I arrive at home ) I will put here the results, but I am pretty sure that the output has a + signal at the end. ( when I initially posted here I did this command ).
I will confim this later.
latest firmware are here : http://support.planetcom.co.uk/download/LinuxFirmware8/LinuxFirmware.html ( debian.zip date -- 2019 - may 16 )
But I did all updates after the first flash.

Thank you.

Please also give the output of:
dpkg -l|grep "\-kernel"


Ok.
later I will provide this also ( when I arrive at home ).
Thank you again.

Posted by: cam1965 May 30 2019, 02:51 PM

QUOTE(cam1965 @ May 30 2019, 12:45 PM) *
QUOTE(mithrandir @ May 30 2019, 11:47 AM) *
QUOTE(cam1965 @ May 30 2019, 09:28 AM) *
Hi, I am at work without my gemini.
Later at night ( more 6 hours when I arrive at home ) I will put here the results, but I am pretty sure that the output has a + signal at the end. ( when I initially posted here I did this command ).
I will confim this later.
latest firmware are here : http://support.planetcom.co.uk/download/LinuxFirmware8/LinuxFirmware.html ( debian.zip date -- 2019 - may 16 )
But I did all updates after the first flash.

Thank you.

Please also give the output of:
dpkg -l|grep "\-kernel"


Ok.
later I will provide this also ( when I arrive at home ).
Thank you again.


print screen attached with informations.
Thank you.


 

Posted by: Adam Boardman May 30 2019, 10:12 PM

Just to point out that the new image from planet might not have come with the kernel built from the build server (hence the '+' confusion?). The dates on the attached screen shots indicate you might not booting a modular kernel at all. Because the scatter file based image distribution has the boot image separate and the apt based kernel distribution leaves the final step of 'dd' flashing to the user its entirely possible to have them come from different places.

Given that when you switch to a build server built or locally built kernel it fails to boot it could be worth unpacking the planet supplied ones contents to see if Nikita/Davide* have changed the contents of the initramfs https://github.com/gemian/initramfs-tools-halium/blob/native/scripts/geminipda script, or the kernel. We might need to tweak its contents to make it compatible with whatever they have changed.

I never got around to upgrading to 8.1 as I don't use android and flashing stopped working so it requires me to 'need to get it working' before I'll get round to fixing that. I'm away this week so won't be able to properly investigate this myself just now.

* - or just email and ask them

Posted by: mithrandir May 31 2019, 12:05 AM

Since the build date is wrong, there are three possibilities:
1. Planet has changed something we are not aware of with the new image, as Adam told
2. You have flashed the kernel to the wrong partition
3. You have left out the manual dd step (if necessary with your setup) after installing the modular kernel package. (more details on this in the mygnu link above)

To see if the kernel should have been flashed automatically, please provide the output of:

cat /proc/cmdline

Mith

Posted by: cam1965 May 31 2019, 01:32 AM

QUOTE(Adam Boardman @ May 30 2019, 10:12 PM) *
Just to point out that the new image from planet might not have come with the kernel built from the build server (hence the '+' confusion?). The dates on the attached screen shots indicate you might not booting a modular kernel at all. Because the scatter file based image distribution has the boot image separate and the apt based kernel distribution leaves the final step of 'dd' flashing to the user its entirely possible to have them come from different places.

Given that when you switch to a build server built or locally built kernel it fails to boot it could be worth unpacking the planet supplied ones contents to see if Nikita/Davide* have changed the contents of the initramfs https://github.com/gemian/initramfs-tools-halium/blob/native/scripts/geminipda script, or the kernel. We might need to tweak its contents to make it compatible with whatever they have changed.

I never got around to upgrading to 8.1 as I don't use android and flashing stopped working so it requires me to 'need to get it working' before I'll get round to fixing that. I'm away this week so won't be able to properly investigate this myself just now.

* - or just email and ask them


I think Planet has changed , because every another kernel that I flashed didn't boot on gemini . The last was compiled perfectly, but for some reasons it didn't boot. Only the kernel provided inside the debian image can boot gemini.
Thank you again

Posted by: cam1965 May 31 2019, 01:46 AM

QUOTE(mithrandir @ May 31 2019, 12:05 AM) *
Since the build date is wrong, there are three possibilities:
1. Planet has changed something we are not aware of with the new image, as Adam told
2. You have flashed the kernel to the wrong partition
3. You have left out the manual dd step (if necessary with your setup) after installing the modular kernel package. (more details on this in the mygnu link above)

To see if the kernel should have been flashed automatically, please provide the output of:

cat /proc/cmdline

Mith

As I said , I think Planet has changed , because every another kernel that I flashed didn't boot on gemini . The last was compiled perfectly, but for some reasons it didn't boot. Only the kernel provided inside the debian image can boot gemini. Also I've tested the kernel from the repository ( not the modular ) and it installs perfectly . No need to dd, because it automatically detects the correct partition. Reinstalled again the modular kernel . The partition is correct. ( boot2 ) . I've checked this. But I've also did a test with the manual dd at the correct partition and only the kernel provided from planet boots gemini.

follow the results of /cat/cmdline attached.
Please, contact planet and tell me how are the steps to compile his kernel. Because I've compiled the kernel modules from the source kernel ( they are also with + sign ) , but I can' t load any module as I said before .Also when I do lsmod ( with my modules compiled ) an error appears saying libkmod error , etc ... and could not open /proc/modules.
Thank you again

 

Posted by: flotsam May 31 2019, 02:52 AM

I can't say that I've followed this whole thread, but any chance that this is related to https://www.oesf.org/forum/index.php?showtopic=35795? Does your MAC address change with reboots?

Posted by: cam1965 May 31 2019, 04:35 AM

QUOTE(flotsam @ May 31 2019, 02:52 AM) *
I can't say that I've followed this whole thread, but any chance that this is related to https://www.oesf.org/forum/index.php?showtopic=35795? Does your MAC address change with reboots?


In android, my wifi saved connections are OK.
In debian I've checked and at every boot I have to choose my SSID network and re-enter my password again.
I've checked the mac address in debian and it really changes at every boot.
Will check later in google if there is a solution for this.
Thank you again.

Posted by: mithrandir May 31 2019, 04:46 AM

QUOTE(cam1965 @ May 31 2019, 01:46 AM) *
As I said , I think Planet has changed , because every another kernel that I flashed didn't boot on gemini . The last was compiled perfectly, but for some reasons it didn't boot. Only the kernel provided inside the debian image can boot gemini. Also I've tested the kernel from the repository ( not the modular ) and it installs perfectly . No need to dd, because it automatically detects the correct partition. Reinstalled again the modular kernel . The partition is correct. ( boot2 ) . I've checked this. But I've also did a test with the manual dd at the correct partition and only the kernel provided from planet boots gemini.

follow the results of /cat/cmdline attached.
Please, contact planet and tell me how are the steps to compile his kernel. Because I've compiled the kernel modules from the source kernel ( they are also with + sign ) , but I can' t load any module as I said before .Also when I do lsmod ( with my modules compiled ) an error appears saying libkmod error , etc ... and could not open /proc/modules.
Thank you again


From your cmdline you appear to have an unmodified bootloader, so there is no way the kernel package could detect the right boot partition. Otherwise there would be a bootpartition entry in the cmdline. Unless the method of partition detection has changed (@Adam: Has it?), manual flashing with dd is necessary.

Posted by: cam1965 May 31 2019, 05:37 AM

QUOTE(mithrandir @ May 31 2019, 04:46 AM) *
QUOTE(cam1965 @ May 31 2019, 01:46 AM) *
As I said , I think Planet has changed , because every another kernel that I flashed didn't boot on gemini . The last was compiled perfectly, but for some reasons it didn't boot. Only the kernel provided inside the debian image can boot gemini. Also I've tested the kernel from the repository ( not the modular ) and it installs perfectly . No need to dd, because it automatically detects the correct partition. Reinstalled again the modular kernel . The partition is correct. ( boot2 ) . I've checked this. But I've also did a test with the manual dd at the correct partition and only the kernel provided from planet boots gemini.

follow the results of /cat/cmdline attached.
Please, contact planet and tell me how are the steps to compile his kernel. Because I've compiled the kernel modules from the source kernel ( they are also with + sign ) , but I can' t load any module as I said before .Also when I do lsmod ( with my modules compiled ) an error appears saying libkmod error , etc ... and could not open /proc/modules.
Thank you again


From your cmdline you appear to have an unmodified bootloader, so there is no way the kernel package could detect the right boot partition. Otherwise there would be a bootpartition entry in the cmdline. Unless the method of partition detection has changed (@Adam: Has it?), manual flashing with dd is necessary.


Thank you .
As I said I am using the default installation from Planet. ( debian and android oreo images ). Fresh install ( flashed ).
I think something has changed. I also did manual flashing with dd ( kernel ) and only the kernel from debian image boots gemini.
Thank you again.

Posted by: mibry May 31 2019, 06:20 AM

QUOTE(cam1965 @ May 31 2019, 02:37 PM) *
QUOTE(mithrandir @ May 31 2019, 04:46 AM) *
QUOTE(cam1965 @ May 31 2019, 01:46 AM) *
As I said , I think Planet has changed , because every another kernel that I flashed didn't boot on gemini . The last was compiled perfectly, but for some reasons it didn't boot. Only the kernel provided inside the debian image can boot gemini. Also I've tested the kernel from the repository ( not the modular ) and it installs perfectly . No need to dd, because it automatically detects the correct partition. Reinstalled again the modular kernel . The partition is correct. ( boot2 ) . I've checked this. But I've also did a test with the manual dd at the correct partition and only the kernel provided from planet boots gemini.

follow the results of /cat/cmdline attached.
Please, contact planet and tell me how are the steps to compile his kernel. Because I've compiled the kernel modules from the source kernel ( they are also with + sign ) , but I can' t load any module as I said before .Also when I do lsmod ( with my modules compiled ) an error appears saying libkmod error , etc ... and could not open /proc/modules.
Thank you again


From your cmdline you appear to have an unmodified bootloader, so there is no way the kernel package could detect the right boot partition. Otherwise there would be a bootpartition entry in the cmdline. Unless the method of partition detection has changed (@Adam: Has it?), manual flashing with dd is necessary.


Thank you .
As I said I am using the default installation from Planet. ( debian and android oreo images ). Fresh install ( flashed ).
I think something has changed. I also did manual flashing with dd ( kernel ) and only the kernel from debian image boots gemini.
Thank you again.


I also reflashed my gemini with the new debian image from planet support website and had the same kernel as cam1965. I did a dd of the linux-boot.img kernel image in /usr/share/kernel and was able to boot into debian. I also notice before I flashed the image I had the same kernel version as cam1965. The kernel version has now changed to 3.18.41 without the + at the end.

Posted by: flotsam May 31 2019, 06:30 AM

QUOTE(cam1965 @ May 31 2019, 02:35 PM) *
QUOTE(flotsam @ May 31 2019, 02:52 AM) *
I can't say that I've followed this whole thread, but any chance that this is related to https://www.oesf.org/forum/index.php?showtopic=35795? Does your MAC address change with reboots?


In android, my wifi saved connections are OK.
In debian I've checked and at every boot I have to choose my SSID network and re-enter my password again.
I've checked the mac address in debian and it really changes at every boot.
Will check later in google if there is a solution for this.
Thank you again.


Sounds like the same problem. Nice to know I'm not the only one suffering from it. So multi-boot is broken, at least for some of us. Anyone from Planet Computers want to chip in?

Posted by: cam1965 May 31 2019, 07:33 AM

QUOTE(mibry @ May 31 2019, 06:20 AM) *
QUOTE(cam1965 @ May 31 2019, 02:37 PM) *
QUOTE(mithrandir @ May 31 2019, 04:46 AM) *
QUOTE(cam1965 @ May 31 2019, 01:46 AM) *
As I said , I think Planet has changed , because every another kernel that I flashed didn't boot on gemini . The last was compiled perfectly, but for some reasons it didn't boot. Only the kernel provided inside the debian image can boot gemini. Also I've tested the kernel from the repository ( not the modular ) and it installs perfectly . No need to dd, because it automatically detects the correct partition. Reinstalled again the modular kernel . The partition is correct. ( boot2 ) . I've checked this. But I've also did a test with the manual dd at the correct partition and only the kernel provided from planet boots gemini.

follow the results of /cat/cmdline attached.
Please, contact planet and tell me how are the steps to compile his kernel. Because I've compiled the kernel modules from the source kernel ( they are also with + sign ) , but I can' t load any module as I said before .Also when I do lsmod ( with my modules compiled ) an error appears saying libkmod error , etc ... and could not open /proc/modules.
Thank you again


From your cmdline you appear to have an unmodified bootloader, so there is no way the kernel package could detect the right boot partition. Otherwise there would be a bootpartition entry in the cmdline. Unless the method of partition detection has changed (@Adam: Has it?), manual flashing with dd is necessary.


Thank you .
As I said I am using the default installation from Planet. ( debian and android oreo images ). Fresh install ( flashed ).
I think something has changed. I also did manual flashing with dd ( kernel ) and only the kernel from debian image boots gemini.
Thank you again.


I also reflashed my gemini with the new debian image from planet support website and had the same kernel as cam1965. I did a dd of the linux-boot.img kernel image in /usr/share/kernel and was able to boot into debian. I also notice before I flashed the image I had the same kernel version as cam1965. The kernel version has now changed to 3.18.41 without the + at the end.


PERFECT.
Problem solved.
Thank you so much.
Now almost everything is fine.
Only the problem of mac address changing after every boot. ( in debian )

Thank you again.


Posted by: cam1965 May 31 2019, 07:35 AM

QUOTE(flotsam @ May 31 2019, 06:30 AM) *
QUOTE(cam1965 @ May 31 2019, 02:35 PM) *
QUOTE(flotsam @ May 31 2019, 02:52 AM) *
I can't say that I've followed this whole thread, but any chance that this is related to https://www.oesf.org/forum/index.php?showtopic=35795? Does your MAC address change with reboots?


In android, my wifi saved connections are OK.
In debian I've checked and at every boot I have to choose my SSID network and re-enter my password again.
I've checked the mac address in debian and it really changes at every boot.
Will check later in google if there is a solution for this.
Thank you again.


Sounds like the same problem. Nice to know I'm not the only one suffering from it. So multi-boot is broken, at least for some of us. Anyone from Planet Computers want to chip in?

In android I've did a reset in networlk settings . Because my mac address was 02:00:00:00:00:00. After this, it has changed .
But in debian the problem persists.
I will test with the new kernel ( please see above ) if the problem persists. But I think it is not related to the kernel.
I will search again on the google . If I found a solution I will return here. Now I am at work and I will check this problem only at night ( about more 8 hours ).

Thank you again.

Posted by: mithrandir May 31 2019, 08:03 AM

QUOTE
In android I've did a reset in networlk settings . Because my mac address was 02:00:00:00:00:00. After this, it has changed .
But in debian the problem persists.
I will test with the new kernel ( please see above ) if the problem persists. But I think it is not related to the kernel.
I will search again on the google . If I found a solution I will return here. Now I am at work and I will check this problem only at night ( about more 8 hours ).

Thank you again.

Maybe restoring the NVRAM from backup fixes the mac address issue.

Posted by: cam1965 May 31 2019, 08:40 AM

QUOTE(mithrandir @ May 31 2019, 08:03 AM) *
QUOTE
In android I've did a reset in networlk settings . Because my mac address was 02:00:00:00:00:00. After this, it has changed .
But in debian the problem persists.
I will test with the new kernel ( please see above ) if the problem persists. But I think it is not related to the kernel.
I will search again on the google . If I found a solution I will return here. Now I am at work and I will check this problem only at night ( about more 8 hours ).

Thank you again.

Maybe restoring the NVRAM from backup fixes the mac address issue.

Unfortunately I did not make a backup of NVRAM.
But I saw this :

https://wiki.archlinux.org/index.php/MAC_address_spoofing

Later I will did a test ( when I arrive at home ).

Only to know what service connman uses : systemd ?

Thank you again.

Posted by: mithrandir May 31 2019, 10:59 AM

QUOTE(cam1965 @ May 31 2019, 08:40 AM) *
Unfortunately I did not make a backup of NVRAM.
But I saw this :

https://wiki.archlinux.org/index.php/MAC_address_spoofing

Later I will did a test ( when I arrive at home ).

Only to know what service connman uses : systemd ?

Thank you again.


The Gemini uses systemd. If you provide your mac/imei/etc. Planet might be able generate a NVRAM "backup" for you. At least there have been rumors... Writing a mail is free...

Posted by: cam1965 May 31 2019, 11:04 AM

QUOTE(mithrandir @ May 31 2019, 10:59 AM) *
QUOTE(cam1965 @ May 31 2019, 08:40 AM) *
Unfortunately I did not make a backup of NVRAM.
But I saw this :

https://wiki.archlinux.org/index.php/MAC_address_spoofing

Later I will did a test ( when I arrive at home ).

Only to know what service connman uses : systemd ?

Thank you again.


The Gemini uses systemd. If you provide your mac/imei/etc. Planet might be able generate a NVRAM "backup" for you. At least there have been rumors... Writing a mail is free...


Ok.
Thank you so much again.

Posted by: flotsam May 31 2019, 02:03 PM

QUOTE(mithrandir @ May 31 2019, 06:03 PM) *
Maybe restoring the NVRAM from backup fixes the mac address issue.


Unfortunately, I don't think the problem is quite so simple. At least mine isn't.

I did make an NVRAM backup. And while I didn't restore it, I did another backup after the problem appeared, and compared the two. They were identical. So I don't think that restoring it would make a difference.

Also, when I reflash using "firmware upgrade" mode (but no restore of the original NVRAM backup), I do get my original MAC address back. (I didn't really pay attention to the IMEI; don't know about that). So the MAC address does seem to be uncorrupted in the NVRAM. It just isn't getting set on the interface after the first android boot.

But the problem does seem to be related to the early-boot NVRAM settings. I don't really understand the process well enough to say what is going on. Informed speculation is welcome.

Posted by: mithrandir May 31 2019, 05:00 PM

QUOTE(flotsam @ May 31 2019, 02:03 PM) *
QUOTE(mithrandir @ May 31 2019, 06:03 PM) *
Maybe restoring the NVRAM from backup fixes the mac address issue.


Unfortunately, I don't think the problem is quite so simple. At least mine isn't.

I did make an NVRAM backup. And while I didn't restore it, I did another backup after the problem appeared, and compared the two. They were identical. So I don't think that restoring it would make a difference.

Also, when I reflash using "firmware upgrade" mode (but no restore of the original NVRAM backup), I do get my original MAC address back. (I didn't really pay attention to the IMEI; don't know about that). So the MAC address does seem to be uncorrupted in the NVRAM. It just isn't getting set on the interface after the first android boot.

But the problem does seem to be related to the early-boot NVRAM settings. I don't really understand the process well enough to say what is going on. Informed speculation is welcome.


The NVRAM backup of course is just the first thing to try. Once had a similar problem with unknown baseband: https://www.oesf.org/forum/index.php?showtopic=35233&hl=
Tried quite some stuff before I got it working again. Probably erasing the contents of /nvdata or /data/nvram has been part of the solution. Afterwards the directory got refilled from NVRAM (on reboot , if I remember correctly), I think. No guarantees on that, since I have tried too many things to recall the complete fix. You might try out if this helps (KEEP A BACKUP) to solve your problem. This is highly speculative, but you have asked for wink.gif

Posted by: Adam Boardman May 31 2019, 10:01 PM

I'm still away but the fix Davide gave me for Gemian and Re4son for Kali had different values: https://github.com/gemian/gemini-linux-kernel-3.18/commit/59e00a9144d782e148332009a835b99c43382467 vs https://github.com/Re4son/gemini-kali-linux-kernel-3.18/commit/45d6d3fd4b27027684b490c030179f1ad303c60b

Its possible that even though the value of 32 was enough with the early Android 8 bootloader we now need a higher value 40 with the release version?

If that fails it would be interesting to know the partition/LVM layout on the planet supplied image for TP3?

Posted by: mithrandir Jun 1 2019, 06:04 AM

QUOTE(cam1965 @ May 31 2019, 07:33 AM) *
PERFECT.
Problem solved.
Thank you so much.
Now almost everything is fine.
Only the problem of mac address changing after every boot. ( in debian )

Thank you again.

Out of interest and for other readers with the same problem, what has been the fix?

Posted by: cam1965 Jun 1 2019, 06:22 AM

QUOTE(mithrandir @ Jun 1 2019, 06:04 AM) *
QUOTE(cam1965 @ May 31 2019, 07:33 AM) *
PERFECT.
Problem solved.
Thank you so much.
Now almost everything is fine.
Only the problem of mac address changing after every boot. ( in debian )

Thank you again.

Out of interest and for other readers with the same problem, what has been the fix?


The fix was posted here by Mibry ( page 2 ). I also replied his post and I thanked him.See below what Mibry said :

"I also reflashed my gemini with the new debian image from planet support website and had the same kernel as cam1965. I did a dd of the linux-boot.img kernel image in /usr/share/kernel and was able to boot into debian. I also notice before I flashed the image I had the same kernel version as cam1965. The kernel version has now changed to 3.18.41 without the + at the end."

Posted by: cam1965 Jun 1 2019, 06:44 AM

QUOTE(mithrandir @ May 31 2019, 05:00 PM) *
QUOTE(flotsam @ May 31 2019, 02:03 PM) *
QUOTE(mithrandir @ May 31 2019, 06:03 PM) *
Maybe restoring the NVRAM from backup fixes the mac address issue.


Unfortunately, I don't think the problem is quite so simple. At least mine isn't.

I did make an NVRAM backup. And while I didn't restore it, I did another backup after the problem appeared, and compared the two. They were identical. So I don't think that restoring it would make a difference.

Also, when I reflash using "firmware upgrade" mode (but no restore of the original NVRAM backup), I do get my original MAC address back. (I didn't really pay attention to the IMEI; don't know about that). So the MAC address does seem to be uncorrupted in the NVRAM. It just isn't getting set on the interface after the first android boot.

But the problem does seem to be related to the early-boot NVRAM settings. I don't really understand the process well enough to say what is going on. Informed speculation is welcome.


The NVRAM backup of course is just the first thing to try. Once had a similar problem with unknown baseband: https://www.oesf.org/forum/index.php?showtopic=35233&hl=
Tried quite some stuff before I got it working again. Probably erasing the contents of /nvdata or /data/nvram has been part of the solution. Afterwards the directory got refilled from NVRAM (on reboot , if I remember correctly), I think. No guarantees on that, since I have tried too many things to recall the complete fix. You might try out if this helps (KEEP A BACKUP) to solve your problem. This is highly speculative, but you have asked for wink.gif


Hi,

Problem solved .
First, I 've erased my previous wifi saved connections from /var/lib/connman. Did a reboot.
So, I've erased the contents of /nvdata and after this I rebootet gemini again. Checked and /nvdata was refilled again . So, In connman I Filled again my wifi SSID ( name and password ). Wifi worked . Did a reboot.
Now connman has saved my wifi connections even after reboot.
Thank you so much .

Posted by: cam1965 Jun 1 2019, 07:26 AM

QUOTE(cam1965 @ Jun 1 2019, 06:44 AM) *
QUOTE(mithrandir @ May 31 2019, 05:00 PM) *
QUOTE(flotsam @ May 31 2019, 02:03 PM) *
QUOTE(mithrandir @ May 31 2019, 06:03 PM) *
Maybe restoring the NVRAM from backup fixes the mac address issue.


Unfortunately, I don't think the problem is quite so simple. At least mine isn't.

I did make an NVRAM backup. And while I didn't restore it, I did another backup after the problem appeared, and compared the two. They were identical. So I don't think that restoring it would make a difference.

Also, when I reflash using "firmware upgrade" mode (but no restore of the original NVRAM backup), I do get my original MAC address back. (I didn't really pay attention to the IMEI; don't know about that). So the MAC address does seem to be uncorrupted in the NVRAM. It just isn't getting set on the interface after the first android boot.

But the problem does seem to be related to the early-boot NVRAM settings. I don't really understand the process well enough to say what is going on. Informed speculation is welcome.


The NVRAM backup of course is just the first thing to try. Once had a similar problem with unknown baseband: https://www.oesf.org/forum/index.php?showtopic=35233&hl=
Tried quite some stuff before I got it working again. Probably erasing the contents of /nvdata or /data/nvram has been part of the solution. Afterwards the directory got refilled from NVRAM (on reboot , if I remember correctly), I think. No guarantees on that, since I have tried too many things to recall the complete fix. You might try out if this helps (KEEP A BACKUP) to solve your problem. This is highly speculative, but you have asked for wink.gif


Hi,

Problem solved .
First, I 've erased my previous wifi saved connections from /var/lib/connman. Did a reboot.
So, I've erased the contents of /nvdata and after this I rebootet gemini again. Checked and /nvdata was refilled again . So, In connman I Filled again my wifi SSID ( name and password ). Wifi worked . Did a reboot.
Now connman has saved my wifi connections even after reboot.
Thank you so much .


NOW ANOTHER PROBLEM AFTER THIS :
When I booted in android, sim card was not working !....

Posted by: mithrandir Jun 1 2019, 07:37 AM

QUOTE(cam1965 @ Jun 1 2019, 07:26 AM) *
NOW ANOTHER PROBLEM AFTER THIS :
When I booted in android, sim card was not working !....


Is the baseband still being shown in android settings?

Posted by: cam1965 Jun 1 2019, 09:30 AM

QUOTE(mithrandir @ Jun 1 2019, 07:37 AM) *
QUOTE(cam1965 @ Jun 1 2019, 07:26 AM) *
NOW ANOTHER PROBLEM AFTER THIS :
When I booted in android, sim card was not working !....


Is the baseband still being shown in android settings?


no baseband.
Empty slot sim card in settings ( both 2 sim cards ).
I will try to flash again everything .
I didn't make a backup of NVRAM0 recently. Only in a old computer that was erased some folders. I will try to recover this file and flash it again .
I also did a reflash of android without success.
Thank you.

Posted by: mithrandir Jun 1 2019, 09:43 AM

QUOTE(cam1965 @ Jun 1 2019, 09:30 AM) *
no baseband.
Empty slot sim card in settings ( both 2 sim cards ).
I will try to flash again everything .
I didn't make a backup of NVRAM0 recently. Only in a old computer that was erased some folders. I will try to recover this file and flash it again .
I also did a reflash of android without success.
Thank you.


For this problem yo might try the fix I have described in post #6 in https://www.oesf.org/forum/index.php?showtopic=35233&hl= . There baseband version in android settings showed "unknown baseband", which seems to be the same problem you are experiencing.

Posted by: cam1965 Jun 1 2019, 09:59 AM

QUOTE(mithrandir @ Jun 1 2019, 09:43 AM) *
QUOTE(cam1965 @ Jun 1 2019, 09:30 AM) *
no baseband.
Empty slot sim card in settings ( both 2 sim cards ).
I will try to flash again everything .
I didn't make a backup of NVRAM0 recently. Only in a old computer that was erased some folders. I will try to recover this file and flash it again .
I also did a reflash of android without success.
Thank you.


For this problem yo might try the fix I have described in post #6 in https://www.oesf.org/forum/index.php?showtopic=35233&hl= . There baseband version in android settings showed "unknown baseband", which seems to be the same problem you are experiencing.


I don't know how, but Thanks GOD I've recovered my nvram0 backup from my old pc. So I reflashed nvram 0 in gemini but the problem persists.
Now I will reflash everything ( debian + Oreo ).
Will post results here later.

Posted by: cam1965 Jun 1 2019, 10:11 AM

QUOTE(cam1965 @ Jun 1 2019, 09:59 AM) *
QUOTE(mithrandir @ Jun 1 2019, 09:43 AM) *
QUOTE(cam1965 @ Jun 1 2019, 09:30 AM) *
no baseband.
Empty slot sim card in settings ( both 2 sim cards ).
I will try to flash again everything .
I didn't make a backup of NVRAM0 recently. Only in a old computer that was erased some folders. I will try to recover this file and flash it again .
I also did a reflash of android without success.
Thank you.


For this problem yo might try the fix I have described in post #6 in https://www.oesf.org/forum/index.php?showtopic=35233&hl= . There baseband version in android settings showed "unknown baseband", which seems to be the same problem you are experiencing.


I don't know how, but Thanks GOD I've recovered my nvram0 backup from my old pc. So I reflashed nvram 0 in gemini but the problem persists.
Now I will reflash everything ( debian + Oreo ).
Will post results here later.


Thanks God ! After reflashing from planet images ( debian + OREO ) everything is working ( sim cards are recognized ).
Now, a long work for reconfigure linux and android with all my applications.
Maybe connman will still not save my connections. But it is not a big problem.
This time I booted android first instead of linux. Maybe this will do a difference and who knows ( maybe connman will save my wifi network ).
I will post here the results ( only tomorrow ) cause I am leaving home now .
Thank you all.


Thank you all.

Posted by: cam1965 Jun 1 2019, 03:05 PM

QUOTE(cam1965 @ Jun 1 2019, 10:11 AM) *
QUOTE(cam1965 @ Jun 1 2019, 09:59 AM) *
QUOTE(mithrandir @ Jun 1 2019, 09:43 AM) *
QUOTE(cam1965 @ Jun 1 2019, 09:30 AM) *
no baseband.
Empty slot sim card in settings ( both 2 sim cards ).
I will try to flash again everything .
I didn't make a backup of NVRAM0 recently. Only in a old computer that was erased some folders. I will try to recover this file and flash it again .
I also did a reflash of android without success.
Thank you.


For this problem yo might try the fix I have described in post #6 in https://www.oesf.org/forum/index.php?showtopic=35233&hl= . There baseband version in android settings showed "unknown baseband", which seems to be the same problem you are experiencing.


I don't know how, but Thanks GOD I've recovered my nvram0 backup from my old pc. So I reflashed nvram 0 in gemini but the problem persists.
Now I will reflash everything ( debian + Oreo ).
Will post results here later.


Thanks God ! After reflashing from planet images ( debian + OREO ) everything is working ( sim cards are recognized ).
Now, a long work for reconfigure linux and android with all my applications.
Maybe connman will still not save my connections. But it is not a big problem.
This time I booted android first instead of linux. Maybe this will do a difference and who knows ( maybe connman will save my wifi network ).
I will post here the results ( only tomorrow ) cause I am leaving home now .
Thank you all.


Thank you all.


Already installed almost everything in OREO and partially in debian.
Everything is working great, except the problem mentioned before : wifi networks are not saved after reboot in connman. Because after each reboot mac address is changed. Interesting is that in android after each reboot mac address is also changed, but my wifi connection is saved . No need to select the SSID and fill my password again.
In connman it creates in /var/lib/connman a folder wifi_MACADDRESS_xxxxxxxxxxxxxxxxxx_managed_psk. If mac address are changed after the boot it creates another folder as mentioned. Inside this folder there is a file named settings with some configurations like password, etc, etc.
I'd like to mention that mac address changes are only in the last 3 bytes. For example 00:01:02: XX:YY:ZZ. Where XX, YY and ZZ are the numbers that changes after each reboot .

Posted by: mithrandir Jun 2 2019, 05:16 AM

QUOTE(cam1965 @ Jun 1 2019, 03:05 PM) *
Already installed almost everything in OREO and partially in debian.
Everything is working great, except the problem mentioned before : wifi networks are not saved after reboot in connman. Because after each reboot mac address is changed. Interesting is that in android after each reboot mac address is also changed, but my wifi connection is saved . No need to select the SSID and fill my password again.
In connman it creates in /var/lib/connman a folder wifi_MACADDRESS_xxxxxxxxxxxxxxxxxx_managed_psk. If mac address are changed after the boot it creates another folder as mentioned. Inside this folder there is a file named settings with some configurations like password, etc, etc.
I'd like to mention that mac address changes are only in the last 3 bytes. For example 00:01:02: XX:YY:ZZ. Where XX, YY and ZZ are the numbers that changes after each reboot .


The MAC address issue seems to be a problem with the new firmware: https://www.oesf.org/forum/index.php?showtopic=35795&st=0&#entry291973
At least you are not the only one with this problem. Does anyone have stable MAC ids after the upgrade? (Not willing to upgrade my Gemini now...)
For Debian you might fix this by setting a stable MAC id somewhere in /etc/network/if-pre-up. Maybe this is of some help: https://unix.stackexchange.com/questions/366533/change-mac-address-permanently-inside-etc-network-interfaces
The answer rated with "1" with directly editing /etc/network/interfaces looks good...

Posted by: cam1965 Jun 2 2019, 06:55 AM

QUOTE(mithrandir @ Jun 2 2019, 05:16 AM) *
QUOTE(cam1965 @ Jun 1 2019, 03:05 PM) *
Already installed almost everything in OREO and partially in debian.
Everything is working great, except the problem mentioned before : wifi networks are not saved after reboot in connman. Because after each reboot mac address is changed. Interesting is that in android after each reboot mac address is also changed, but my wifi connection is saved . No need to select the SSID and fill my password again.
In connman it creates in /var/lib/connman a folder wifi_MACADDRESS_xxxxxxxxxxxxxxxxxx_managed_psk. If mac address are changed after the boot it creates another folder as mentioned. Inside this folder there is a file named settings with some configurations like password, etc, etc.
I'd like to mention that mac address changes are only in the last 3 bytes. For example 00:01:02: XX:YY:ZZ. Where XX, YY and ZZ are the numbers that changes after each reboot .


The MAC address issue seems to be a problem with the new firmware: https://www.oesf.org/forum/index.php?showtopic=35795&st=0&#entry291973
At least you are not the only one with this problem. Does anyone have stable MAC ids after the upgrade? (Not willing to upgrade my Gemini now...)
For Debian you might fix this by setting a stable MAC id somewhere in /etc/network/if-pre-up. Maybe this is of some help: https://unix.stackexchange.com/questions/366533/change-mac-address-permanently-inside-etc-network-interfaces
The answer rated with "1" with directly editing /etc/network/interfaces looks good...


Changes of mac address is good for security reasons. Problem is that connman can't save my wifi connections, because it generates a new profile according to mac address as explained before . In android it saves , even if mac address is changed . In /etc/network/, the file interfaces is empty.
Thank you again.

Posted by: cam1965 Jun 2 2019, 08:54 AM

QUOTE(cam1965 @ Jun 2 2019, 06:55 AM) *
QUOTE(mithrandir @ Jun 2 2019, 05:16 AM) *
QUOTE(cam1965 @ Jun 1 2019, 03:05 PM) *
Already installed almost everything in OREO and partially in debian.
Everything is working great, except the problem mentioned before : wifi networks are not saved after reboot in connman. Because after each reboot mac address is changed. Interesting is that in android after each reboot mac address is also changed, but my wifi connection is saved . No need to select the SSID and fill my password again.
In connman it creates in /var/lib/connman a folder wifi_MACADDRESS_xxxxxxxxxxxxxxxxxx_managed_psk. If mac address are changed after the boot it creates another folder as mentioned. Inside this folder there is a file named settings with some configurations like password, etc, etc.
I'd like to mention that mac address changes are only in the last 3 bytes. For example 00:01:02: XX:YY:ZZ. Where XX, YY and ZZ are the numbers that changes after each reboot .


The MAC address issue seems to be a problem with the new firmware: https://www.oesf.org/forum/index.php?showtopic=35795&st=0&#entry291973
At least you are not the only one with this problem. Does anyone have stable MAC ids after the upgrade? (Not willing to upgrade my Gemini now...)
For Debian you might fix this by setting a stable MAC id somewhere in /etc/network/if-pre-up. Maybe this is of some help: https://unix.stackexchange.com/questions/366533/change-mac-address-permanently-inside-etc-network-interfaces
The answer rated with "1" with directly editing /etc/network/interfaces looks good...


Changes of mac address is good for security reasons. Problem is that connman can't save my wifi connections, because it generates a new profile according to mac address as explained before . In android it saves , even if mac address is changed . In /etc/network/, the file interfaces is empty.
Thank you again.


Changed the file "interfaces" as you said, but no success. The mac address does not reflect that one in /etc/network/interfaces. ( after reboot ). Tried macchanger without success also.

Posted by: mithrandir Jun 2 2019, 09:49 AM

QUOTE(cam1965 @ Jun 2 2019, 08:54 AM) *
Changed the file "interfaces" as you said, but no success. The mac address does not reflect that one in /etc/network/interfaces. ( after reboot ). Tried macchanger without success also.

Please show the content of your file.

Posted by: cam1965 Jun 2 2019, 11:33 AM

QUOTE(mithrandir @ Jun 2 2019, 09:49 AM) *
QUOTE(cam1965 @ Jun 2 2019, 08:54 AM) *
Changed the file "interfaces" as you said, but no success. The mac address does not reflect that one in /etc/network/interfaces. ( after reboot ). Tried macchanger without success also.

Please show the content of your file.


The original file interfaces ( without modifications that didn't work )
----------------------------------------------------------
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
----------------------------------------------------------

And inside /etc/network/interfaces.d there isn't any file.

I also saw this :

https://stackoverflow.com/questions/23421899/does-mac-address-changes-over-time-in-android

The contents of answer 1 is :
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
"Not entirely true Raptor. Android WILL generate a MAC address every time WiFi is activated if it doesn't have one. Here's how to tell (and how I fixed it on my Chinese tablet)

Root the device.
Open file "/data/nvram/APCFG/APRDEB/WIFI" with a hex editor.
if bytes 4 thru 9 are 0 then Android will generate a MAC address on-the-fly.

To FIX (hard-code) a MAC address, edit the "WIFI" file above and type a (any) MAC address into those byte locations (in hex notation, as you see it). Save the file. Reboot / restart WIFI and see setting. You should see your new address. And Android will now recognise your new address and won't generate a new one every time.

I did then to persist MAC filtering in my router, else the kids keep abusing my bandwidth by adding new i-devices.

Hope this helps"

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

I've tried this in both linux and android without success.

In linux, it regenerates a file "WIFI" identical to the original file when rebooting ( overwriting all the changes I've made. )
In android it regenerates a file different from my changes ( I've did a diff ), but with zeros in bytes 4 thru 9 as explained above.

Thank you.

Posted by: cam1965 Jun 2 2019, 12:19 PM

QUOTE(cam1965 @ Jun 2 2019, 11:33 AM) *
QUOTE(mithrandir @ Jun 2 2019, 09:49 AM) *
QUOTE(cam1965 @ Jun 2 2019, 08:54 AM) *
Changed the file "interfaces" as you said, but no success. The mac address does not reflect that one in /etc/network/interfaces. ( after reboot ). Tried macchanger without success also.

Please show the content of your file.


The original file interfaces ( without modifications that didn't work )
----------------------------------------------------------
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
----------------------------------------------------------

And inside /etc/network/interfaces.d there isn't any file.

I also saw this :

https://stackoverflow.com/questions/23421899/does-mac-address-changes-over-time-in-android

The contents of answer 1 is :
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
"Not entirely true Raptor. Android WILL generate a MAC address every time WiFi is activated if it doesn't have one. Here's how to tell (and how I fixed it on my Chinese tablet)

Root the device.
Open file "/data/nvram/APCFG/APRDEB/WIFI" with a hex editor.
if bytes 4 thru 9 are 0 then Android will generate a MAC address on-the-fly.

To FIX (hard-code) a MAC address, edit the "WIFI" file above and type a (any) MAC address into those byte locations (in hex notation, as you see it). Save the file. Reboot / restart WIFI and see setting. You should see your new address. And Android will now recognise your new address and won't generate a new one every time.

I did then to persist MAC filtering in my router, else the kids keep abusing my bandwidth by adding new i-devices.

Hope this helps"

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

I've tried this in both linux and android without success.

In linux, it regenerates a file "WIFI" identical to the original file when rebooting ( overwriting all the changes I've made. )
In android it regenerates a file different from my changes ( I've did a diff ), but with zeros in bytes 4 thru 9 as explained above.

Thank you.



Posted by: flotsam Jun 2 2019, 07:33 PM

See https://www.oesf.org/forum/index.php?showtopic=35795&view=findpost&p=292024 in the other thread for a workaround to the changing MAC address problem. It should apply to any linux (not just sailfish).

Posted by: cam1965 Jun 3 2019, 03:49 AM

QUOTE(flotsam @ Jun 2 2019, 07:33 PM) *
See https://www.oesf.org/forum/index.php?showtopic=35795&view=findpost&p=292024 in the other thread for a workaround to the changing MAC address problem. It should apply to any linux (not just sailfish).



Thank you so much for the tip.
My problem was solved after your tip. My mac address is the same in android and in debian. (and not changed anymore ).
First I've installed from planet images a fresh install ( firmware upgrade ).
Then booted in debian and set the internet ( SSID and password ).
Did a backup of the contents of nvdata.
So, I've removed the contents of nvdata. ( never remove this contents if you already booted first in android , because your sim card will not be detected : see my previous post here).
Then booted again in debian. The network is saved. ( mac address is like 00:09:34:XX:XX:XX )
After this I've booted the first time in android. Checked the mac address . It is the same of debian.
But when I boot again in debian it has changed the mac address. ( 00:08:22:XX:XX:XX )
Copied the contents of the backup I did ( nvdata ) to the correct location of nvdata.
Booted again in debian. Network was saved with the same mac address.( 00:09:34:XX:XX:XX ).
Did what you said : chattr +i /nvdata/APCFG/APRDEB/WIFI
Booted again in debian : everything is fine.
Booted in android : everything is fine.
Booted in debian : everything is fine.

Both mac address in android and in debian are the same -- 00:09:34:XX:XX:XX.

Interesting is that mac address 00:09:34 and 00:08:22 are from different manufaturers.

well, that is it.

Posted by: cam1965 Jun 3 2019, 04:33 AM

Another problem with latest firmware:

Phone is not working inside linux.
Messaging and cellular data are fine.

In previous version, Phone are working. ( mic and sound ).
I've also changed input and also profile ( settings ) in pulseaudio volume control without success.
Thank you all.

Posted by: cam1965 Jun 3 2019, 04:53 AM

QUOTE(cam1965 @ Jun 3 2019, 04:33 AM) *
Another problem with latest firmware:

Phone is not working inside linux.
Messaging and cellular data are fine.

In previous version, Phone are working. ( mic and sound ).
I've also changed input and also profile ( settings ) in pulseaudio volume control without success.
Thank you all.


Also I can receive a call with gemini closed ( it rings ) and answer and hang up with the silver side button. ( gemini closed ) But no sound in gemini and also in the other people's phone.
Thank you all.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)