Printable Version of Topic

Click here to view this topic in its original format

OESF Portables Forum _ Gemini PDA - Sailfish OS _ Sailfish 3.03 has been released

Posted by: depscribe May 7 2019, 05:59 AM

Release notes say it is available for both flavors of Gemini, x25 and x27.

Posted by: speculatrix May 10 2019, 05:19 AM

Posted by: vader May 17 2019, 02:47 AM

Just updated from the early beta ( to Painless, but quite long upgrade. No problems so far. Browser seems much better. You dont have to resize the oesf page to click on links any more. Seems far better. I'll check the audio to see if there are any improvements, as pulseaudio has been updated. Seems a bit quicker (less lag), but only just started playing. I'll fo a full review later.

For those interested, you can update from the command prompt with:

ssu release
version --dup

Thats it. Takes a long time to download/install, however no issues. I am using an x25 in case anyone wanted to know.

Posted by: andrewl May 17 2019, 04:06 AM

I did the update from the settings app, chose the download / install from the pull-down.

Yes, it did take a while.

Posted by: vader May 17 2019, 02:39 PM

QUOTE(andrewl @ May 17 2019, 10:06 PM) *
I did the update from the settings app, chose the download / install from the pull-down.

Yes, it did take a while.

I tried, however It said I was up to date - probably because I installed a beta of when it first came out. For anyone having problems with the proper way of doing it (ie the settings), you can do it from the command line too using the commands in the previous posts smile.gif

There are some good things - the browser is definitely improved. It is so much easier to use without having to zoom in and out to get hyperlinks to line up. One reversion however is that webgl no longer works for me. It did the first time I started the browser, however it stopped after that. Hopefully it is just a settings/libs thing that I can track down.

Audio is still broken (no headphone jack functionality, etc). That one is a bit dissapointing I must admit.

Posted by: vader May 17 2019, 05:00 PM

Ok, webgl problem solved. It seems the prefs can be updated by some sites - eg trying to update plugins etc. This can modify your config, which in turn can break webgl. Simple fix is to copy the default (or a backed up good version) to ~/.mozzila/mozembed/prefs.js and you are good to go.

Phew, the browser is back to being awesome now smile.gif

Powered by Invision Power Board (
© Invision Power Services (