OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
raybert doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Boston, MA
Birthday Unknown
No Information
Joined: 2-December 03
Profile Views: 2,465*
Last Seen: 8th January 2008 - 02:00 PM
Local Time: Dec 8 2019, 02:28 PM
233 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
29 Nov 2005

I recently discovered that Linux Kernel 2.6.14 breaks usbnet transfers from the Zaurus.

Specifically, I was using 2.6.14-1 from the Fedora Core 4 update server with a C860.

The first problem I noticed was that my connection hung when trying to enter a certain directory using samba (while browsing from my PC). Some directories worked fine and some hung.

I next noticed that certain file transfers would hang, regardless of the protocol (I tried scp, ftp, and samba). Some files transferred just fine, others hung.

I eventually determined that any file with a size >= 1458 bytes would hang. Any file with a size smaller than this transferred just fine.

Additionally, I'm assuming that the directory browsing issue is related to the number of entries in the directory and, therefore, the size of the directory contents transfer.

When I rebooted into kernel 2.6.12, everything worked fine again.

I later determined that kernel 2.6.13 is also fine.

I tried google'ing some kernel activity to try and find the cause and found some interesting stuff but nothing conclusive. I noticed that the kernel guys are still mucking around with usbnet: they've been engaged in a massive refactoring of that module since at least 2.6.11 (which I earlier discovered completely broke connectivity with the C860). I noticed one comment regarding the implementation of some sort of "hard mtu" feature which sounded somewhat suspicious to me. I haven't researched this any further though so it may be a red herring.

The latest stable kernel release is 2.6.14-3 (Fedora's latest is 2.6.14-1) so it's possible it's been fixed in -2 or -3 but I haven't been able to try them and I haven't seen any patch that addresses this issue (but I haven't looked really well yet either). The ChangeLogs for -2 and -3 don't mention anything that sounds related.

So, if you're a Linux & Zaurus user, I would recommend that you avoid 2.6.14 and try later versions with caution.

30 Aug 2005
I just updated my linux box to Fedora Core 4 and found that my C860 wouldn't connect anymore (over USB). After some googling around I found the reason why and the fix. I thought I'd post what I found here in case anyone else gets hung up on this as well...

FC4 ships with kernel 2.6.11. Apparently, at some point before 2.6.11, some "refactoring" was done on the usbnet module, which entailed moving non-standard stuff (such as the Z's non-standard USB net functionality) into external modules. In the process of doing this, support for the C860 (specifically) was broken.

This occurred because apparently the C860 is actually broken is TWO ways: it's USB net support is non-standard, like the other Z's, and it apparently also falsely advertises support for a cell phone modem interface called "CDC MDLM". The author of the usbnet module's changes wasn't aware of this and inadvertently broke the C860 support. A patch was submitted to fix this and that patch appears starting with kernel 2.6.12. The fedora repository has 2.6.12 posted and you can upgrade to it using yum: "sudo yum update kernel". I just installed it last night and my C860 is now happily connecting again.

If you want more details google with "MDLM C-860" or go here: http://lwn.net/Articles/130476/ and search for "usbnet fix for Zaurus C-860".

8 Jun 2005
Does anyone know if there's a graphical SFTP client for the Sharp ROM?

I've been using tkcFTP for regular FTP and it works reasonably well for me. I'm trying to close all my FTP and TELNET ports on all my systems though (better late than never, right?) and a Z GUI SFTP is the one hole in my coverage right now...


7 Mar 2005
Title says it all. An online friend in the Rockbox forum asked me if such exists for the Z. He likes one called Speakup, but it seems to require a hardware-based speech synthesizer. I did find a software-based speech synthesizer for the Z but I'm not sure if Speakup would support it. The other obvious problem is Qtopia (versus X), but there's always pdaXrom, I suppose. Any thoughts?


Last Visitors

6 Apr 2008 - 3:42

Other users have left no comments for raybert.

There are no friends to display.
RSS Lo-Fi Version Time is now: 8th December 2019 - 11:28 AM