OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> SailfishOS 3.0.1.11 released by Jolla, SailfishOS 3.0.1.11 released by Jolla
gabs5807
post Jan 12 2019, 04:35 AM
Post #1





Group: Members
Posts: 14
Joined: 10-November 18
From: Germany
Member No.: 836,392



Hallo,
today i read at https://together.jolla.com/question/186471/...anet-computers/ that the SailfishOS Version 3.0.1.11 is released by Jolla (older versions came from Community).

At the link above there is a detailed description howto install it.
Third party licensed Software is not included, but landscape mode should work out of the box rolleyes.gif .

I installed it per ssh and after having a short look on it everything worked fine laugh.gif .
Go to the top of the page
 
+Quote Post
FrankS
post Jan 12 2019, 08:12 AM
Post #2





Group: Members
Posts: 23
Joined: 28-September 18
Member No.: 832,753



I wrote a shot message in the pinned "tips and tricks" thread 2 days before you can find here.
It is the version 3.0.1 Jolla is working on atm, still beta. Not released!
Go to the top of the page
 
+Quote Post
vader
post Jan 13 2019, 02:15 AM
Post #3





Group: Members
Posts: 253
Joined: 21-January 18
Member No.: 816,775



I can confirm that the instructions FrankS created work a treat. AFter playing with 3.0.1.11 for a bit, I can say it is a big improvement on 2.1.14.whatever . There are still some problems (headphones, hotspot) but there are some great improvements. The best ones are that landscape properly works now (no patch required), the camera focuses properly (although it is still pretty bad quality wise), and the web browser now supports webgl. This means I can now use the gemini to do my 3d printing on octopi as well a play a few webgl games smile.gif

The new drop down menu is actually useful and grows on you. It takes a little while to swap gestures (close the app by dragging down at the edge of the screen), but once you get the hang of it, it works well. The app gesture (up from the bottom) is also much improved. I used to get about 1 in 4 attempts bringing up the events window. Haven"t had a single one yet.

A lot of apps now work, even if they rotate strangely. The barcode reader now works for example. If the headphone issue - the speakers stay on when you plug in headphones - and the phone microphone (uses the one on the same side as the speaker and wont rotate) was fixed, it would be near perfect. Add in a working hotspot and we would be there.....

I have checked and my dosbox app still works on 3.x, so nothing needed there smile.gif Same with ffmpeg/ffplay.

One more thing - the performance seems faster. By that I mean the time to open apps, and general scrolling etc.
Go to the top of the page
 
+Quote Post
epninety
post Jan 13 2019, 02:32 AM
Post #4





Group: Members
Posts: 17
Joined: 21-July 18
Member No.: 826,550



I broke my 3.0.0.8 install trying to upgrade last week, before these instructions were available. So I can confirm the instructions work just as well if applied to the 'standard' SFOS image from the Gemini website.

I note that from the 'desktop', the escape key works as a on-off as some others had wanted - I previously had to type Fn-Esc to switch off (which still seems more natural to me, but no complaints).
From inside apps like ToeTerm it doesn't switch off, so no loss of function there.
Also the silver button appears to work as on-off as well, so possibly/probably now works to answer calls as well?
Go to the top of the page
 
+Quote Post
vader
post Jan 13 2019, 10:28 PM
Post #5





Group: Members
Posts: 253
Joined: 21-January 18
Member No.: 816,775



It also appears that the reauth wifi bug for X25 (X27 was fixed a while back) has been fixed. I get much better battery life on wifi, and don't suffer stutters when ssh'ed in when the gemini screen is locked. Liking 3.0.1.11 more every day.
Go to the top of the page
 
+Quote Post
vader
post Jan 15 2019, 01:44 AM
Post #6





Group: Members
Posts: 253
Joined: 21-January 18
Member No.: 816,775



OK, I don"t believe I am going to say this, but the camera is almost usable now in 3.0.1.11!!! It still has pretty awful optics, but the focusing is much improved. Videos also work now. Videos (only 720p) are actually quite usable. I don"t know what they did, but the camera is basically usable now. Also works well as a barcode scanner.
Go to the top of the page
 
+Quote Post
yoram
post Jan 15 2019, 12:46 PM
Post #7





Group: Members
Posts: 20
Joined: 10-August 18
Member No.: 827,976



If that is permitted (AFAIK it should be) can someone please share here the rpm files from the adaptation repositories ? I have problem accessing them with my jolla account
Go to the top of the page
 
+Quote Post
rasva
post Jan 16 2019, 10:20 AM
Post #8





Group: Members
Posts: 39
Joined: 12-October 07
From: Czech republic
Member No.: 20,815



Wow, seems that 4G calling works now. Surely was not in 3.0.0.8 in my case. Apart that I see some weird behaviour of the SD card. Sometimes disappears and is not readable. May be just coincidence and the card is dying after two months.

yoram: if you write me, where these rpm files are stored in the decice, I can share these.
Go to the top of the page
 
+Quote Post
yoram
post Jan 16 2019, 02:52 PM
Post #9





Group: Members
Posts: 20
Joined: 10-August 18
Member No.: 827,976



QUOTE(rasva @ Jan 16 2019, 10:20 AM) *
Wow, seems that 4G calling works now. Surely was not in 3.0.0.8 in my case. Apart that I see some weird behaviour of the SD card. Sometimes disappears and is not readable. May be just coincidence and the card is dying after two months.

yoram: if you write me, where these rpm files are stored in the decice, I can share these.


first of all, thanks for trying to help
the rpm files are deleted after install so they are not founf on the device
they can, howeve, be downloaded by
pkcon download <package>

the names of repository packages can be achived by command like
zypper pa | grep adaptation0

if downloading and sharing all of them is to much work I will understand....
Go to the top of the page
 
+Quote Post
easypda
post Jan 17 2019, 07:55 AM
Post #10





Group: Members
Posts: 1
Joined: 16-January 19
Member No.: 839,997



Hi,

Thanks a lot for the tjc tutorial [Wiki] dealing with how to upgrade Sailfish from stock 2.1.4.14 to 3.0.1.11 EA edited on 2019-01-09. Very good job!
https://together.jolla.com/question/186471/...anet-computers/

However, I need your help, because the ?Device adaptation that's results after the upgrade is rev. 0.0.2.10 instead of 0.0.3.10 : so the landscape mode is not working, the keyboard is incorrectly mapped (some keys are not correctly affected), ...

I run the upgrade as described in the tutorial (3.0.0.8 -> 3.0.1.11), but :
- the two repos added with the command ssu ar adaptation-0 and -1 are located in the (user) Enabled repositories... instead of the (global) one
- the resulting adaptation1 URL? ended with armv7hl (witch seems to be correct)
- no need to delete the old repos (were well disabled and with their full URL)

To be complete, I upgraded from rev. 2.1.4.14 to 3.0.0.8 using the /devel:/ branch and not the /testing:/ one and the directories were fixed to sailfish_latest_%(arch) instead of sailfishos_(%release).
I did that in order the upgrade to run well (and the files are more fresh : 19/01/14 in the common directory) : because, using the /testing:/ and sailfishos_(%release) in the URL made, my GeminiPDA was unable to boot after the 2.1.4.14 to 3.0.0.8 upgrade.
The ?GeminiPDA is running well with the 3.0.0.8 upgrade ... but it’s 3.0.0.8!

I don't remember when, but the ssu command sometimes add the a < [D] unknown:0 - “No carrier” > line in his results : I don't know if it is a problem ?

When upgrading, I am not connected to any Jolla account on the device (also, no web page opened with a Jolla login) : I don't know if it's necessary (it's seems no, regarding some posts).

I hope someone could help me, as I tried to do the upgrade many times without success (using the tar archive to restore helpfully, from debian) and I am stuck to the 3.0.0.8 community version.

Thanks a lot!
Go to the top of the page
 
+Quote Post
yoram
post Jan 17 2019, 09:02 AM
Post #11





Group: Members
Posts: 20
Joined: 10-August 18
Member No.: 827,976



QUOTE(easypda @ Jan 17 2019, 07:55 AM) *
Hi,

Thanks a lot for the tjc tutorial [Wiki] dealing with how to upgrade Sailfish from stock 2.1.4.14 to 3.0.1.11 EA edited on 2019-01-09. Very good job!
https://together.jolla.com/question/186471/...anet-computers/

However, I need your help, because the ?Device adaptation that's results after the upgrade is rev. 0.0.2.10 instead of 0.0.3.10 : so the landscape mode is not working, the keyboard is incorrectly mapped (some keys are not correctly affected), ...

I run the upgrade as described in the tutorial (3.0.0.8 -> 3.0.1.11), but :
- the two repos added with the command ssu ar adaptation-0 and -1 are located in the (user) Enabled repositories... instead of the (global) one
- the resulting adaptation1 URL? ended with armv7hl (witch seems to be correct)
- no need to delete the old repos (were well disabled and with their full URL)

To be complete, I upgraded from rev. 2.1.4.14 to 3.0.0.8 using the /devel:/ branch and not the /testing:/ one and the directories were fixed to sailfish_latest_%(arch) instead of sailfishos_(%release).
I did that in order the upgrade to run well (and the files are more fresh : 19/01/14 in the common directory) : because, using the /testing:/ and sailfishos_(%release) in the URL made, my GeminiPDA was unable to boot after the 2.1.4.14 to 3.0.0.8 upgrade.
The ?GeminiPDA is running well with the 3.0.0.8 upgrade ... but it’s 3.0.0.8!

I don't remember when, but the ssu command sometimes add the a < [D] unknown:0 - “No carrier” > line in his results : I don't know if it is a problem ?

When upgrading, I am not connected to any Jolla account on the device (also, no web page opened with a Jolla login) : I don't know if it's necessary (it's seems no, regarding some posts).

I hope someone could help me, as I tried to do the upgrade many times without success (using the tar archive to restore helpfully, from debian) and I am stuck to the 3.0.0.8 community version.

Thanks a lot!


I have very similar problem, including the odd message from ssu
on my device, store-repository is.not accessible by any method.
yesterday, the problem as seemed to "magically" fixed and I was able to complete the upgrade. however, after reboot the problem started again.....
also, I tried to do factory reset but it only reboots on gemini pda
Go to the top of the page
 
+Quote Post
rasva
post Jan 17 2019, 11:24 AM
Post #12





Group: Members
Posts: 39
Joined: 12-October 07
From: Czech republic
Member No.: 20,815



yoram: I have the rpms, will edit this post a bit later....

Edit: OK, as OESF does not allow more than 20MB per file, here is full archive of adaptation0
Go to the top of the page
 
+Quote Post
yoram
post Jan 17 2019, 03:03 PM
Post #13





Group: Members
Posts: 20
Joined: 10-August 18
Member No.: 827,976



QUOTE(rasva @ Jan 17 2019, 11:24 AM) *
yoram: I have the rpms, will edit this post a bit later....

Edit: OK, as OESF does not allow more than 20MB per file, here is full archive of adaptation0


many many thanks
Go to the top of the page
 
+Quote Post
FrankS
post Jan 29 2019, 07:44 AM
Post #14





Group: Members
Posts: 23
Joined: 28-September 18
Member No.: 832,753



Maybe this question on tjc has something to do with your problems since 15th of January.

The answer of Jolla admin tells something about 'configuration change'. Hopefuly its not because of my hack. ;-) Remember: it's a hack to go from the community version to the Jolla beta (maybe early release) and maybe not everybody likes it.
Go to the top of the page
 
+Quote Post
yoram
post Jan 29 2019, 10:23 AM
Post #15





Group: Members
Posts: 20
Joined: 10-August 18
Member No.: 827,976



QUOTE(FrankS @ Jan 29 2019, 07:44 AM) *
Maybe this question on tjc has something to do with your problems since 15th of January.

The answer of Jolla admin tells something about 'configuration change'. Hopefuly its not because of my hack. ;-) Remember: it's a hack to go from the community version to the Jolla beta (maybe early release) and maybe not everybody likes it.


thanks, that was my question....
interestingly, at the time, the problem seemed to be solved and I was able to upgrade, after that the problem returned and is still exist...
unfortunatly, factory reset does not reset anything on my geminipda
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2019 - 05:06 PM