OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> sleep on close not working
galodoido
post May 27 2018, 11:32 AM
Post #1





Group: Members
Posts: 156
Joined: 13-May 18
Member No.: 822,555



Hi,
sleep on close in my gemini is not working.
I did exactly as described below, but whem I close my gemini, nothing happens.
Thank you all for any help.

Sleep on close
sudo apt-get install repowerd xss-lock gemian-lock saytime
Then you need to add to your x-login session (lxqt configuration center -> session settings -> autostart -> add):

Name: Screen Lock
Command: xss-lock gemian-lock
So that it will get installed as your session screensaver. As a bonus the external silver button now tells you the time without having to open the device first.

Note: You really do need repowerd and gemian-lock working together for sleep to work at all, also WiFi being on is known to reduce sleep efficiency significantly more than it does on Android. This needs setting for the logged in user and means that sleep only works after you've logged in.
Go to the top of the page
 
+Quote Post
Adam Boardman
post May 28 2018, 10:05 AM
Post #2





Group: Members
Posts: 173
Joined: 29-December 17
Member No.: 815,489



If you really have nothing happening on close then this would indicate that the new kernel + repowered + gemian-lock are not working together, so double check all those parts, if your are trying to pick-n-mix the DebianTP suggestions then you might have missed the kernel part (needed for the lid-close part of the sleep on close concept).
Go to the top of the page
 
+Quote Post
galodoido
post May 28 2018, 02:57 PM
Post #3





Group: Members
Posts: 156
Joined: 13-May 18
Member No.: 822,555



QUOTE(Adam Boardman @ May 28 2018, 03:05 PM) *
If you really have nothing happening on close then this would indicate that the new kernel + repowered + gemian-lock are not working together, so double check all those parts, if your are trying to pick-n-mix the DebianTP suggestions then you might have missed the kernel part (needed for the lid-close part of the sleep on close concept).


Hi, reflashed the kernel as you said and it is working now.
Thank you so much !
Go to the top of the page
 
+Quote Post
Wormhole
post Jun 5 2018, 08:12 AM
Post #4





Group: Members
Posts: 20
Joined: 4-June 18
Member No.: 823,785



QUOTE(galodoido @ May 28 2018, 02:57 PM) *
QUOTE(Adam Boardman @ May 28 2018, 03:05 PM) *
If you really have nothing happening on close then this would indicate that the new kernel + repowered + gemian-lock are not working together, so double check all those parts, if your are trying to pick-n-mix the DebianTP suggestions then you might have missed the kernel part (needed for the lid-close part of the sleep on close concept).


Hi, reflashed the kernel as you said and it is working now.
Thank you so much !


I have exactly the same. You reflashed the kernel. You mean with the flash tool? Can uou describe it in more details. Thanks!
Go to the top of the page
 
+Quote Post
galodoido
post Jun 5 2018, 08:46 AM
Post #5





Group: Members
Posts: 156
Joined: 13-May 18
Member No.: 822,555



QUOTE(Wormhole @ Jun 5 2018, 01:12 PM) *
QUOTE(galodoido @ May 28 2018, 02:57 PM) *
QUOTE(Adam Boardman @ May 28 2018, 03:05 PM) *
If you really have nothing happening on close then this would indicate that the new kernel + repowered + gemian-lock are not working together, so double check all those parts, if your are trying to pick-n-mix the DebianTP suggestions then you might have missed the kernel part (needed for the lid-close part of the sleep on close concept).


Hi, reflashed the kernel as you said and it is working now.
Thank you so much !


I have exactly the same. You reflashed the kernel. You mean with the flash tool? Can uou describe it in more details. Thanks!


You can download the kernel in the instructions, save it , rename with the same name in the full download folder (i.e linux_boot ). Make a backup of the older file and overwrite it with new file. ( linux_boot )
And flash only this file ( linux_boot ). Make sure in the flashtool to use the same scatter file you used before and mark only this file ( linux_boot ) . Also use only the download button option ( not firmware upgrade.)
Go to the top of the page
 
+Quote Post
Wormhole
post Jun 5 2018, 01:35 PM
Post #6





Group: Members
Posts: 20
Joined: 4-June 18
Member No.: 823,785



QUOTE(galodoido @ Jun 5 2018, 08:46 AM) *
QUOTE(Wormhole @ Jun 5 2018, 01:12 PM) *
QUOTE(galodoido @ May 28 2018, 02:57 PM) *
QUOTE(Adam Boardman @ May 28 2018, 03:05 PM) *
If you really have nothing happening on close then this would indicate that the new kernel + repowered + gemian-lock are not working together, so double check all those parts, if your are trying to pick-n-mix the DebianTP suggestions then you might have missed the kernel part (needed for the lid-close part of the sleep on close concept).


Hi, reflashed the kernel as you said and it is working now.
Thank you so much !


I have exactly the same. You reflashed the kernel. You mean with the flash tool? Can uou describe it in more details. Thanks!


You can download the kernel in the instructions, save it , rename with the same name in the full download folder (i.e linux_boot ). Make a backup of the older file and overwrite it with new file. ( linux_boot )
And flash only this file ( linux_boot ). Make sure in the flashtool to use the same scatter file you used before and mark only this file ( linux_boot ) . Also use only the download button option ( not firmware upgrade.)


Thanks it works!
Go to the top of the page
 
+Quote Post
johndude
post Jun 18 2018, 09:22 AM
Post #7





Group: Members
Posts: 3
Joined: 18-June 18
Member No.: 824,674



It seems to be almost working for me except I get an error when I open my devices (after the globe lock screen):

an error occurred starting screensaver. Action 'activate' failed. Ensure you have xscreensaver installed and running.

I did install xscreensaver but it didn't work too well and button didn't speak, after I removed xscreensaver, it almost works except with this error.

if I run 'css-lock gemian-lock' from the command line it says 'Failed to set screensaver attributes; is another one running?'

any ideas how to fix this?

Go to the top of the page
 
+Quote Post
galodoido
post Jun 18 2018, 10:00 AM
Post #8





Group: Members
Posts: 156
Joined: 13-May 18
Member No.: 822,555



QUOTE(johndude @ Jun 18 2018, 02:22 PM) *
It seems to be almost working for me except I get an error when I open my devices (after the globe lock screen):

an error occurred starting screensaver. Action 'activate' failed. Ensure you have xscreensaver installed and running.

I did install xscreensaver but it didn't work too well and button didn't speak, after I removed xscreensaver, it almost works except with this error.

if I run 'css-lock gemian-lock' from the command line it says 'Failed to set screensaver attributes; is another one running?'

any ideas how to fix this?


Did you install the new kernel in the intructions ? It works only with new kernel. If not updated , it will not work. See the instructions below how to flash only linux_boot :

You can download the kernel in the instructions, save it , rename with the same name in the full download folder (i.e linux_boot ). Make a backup of the older file and overwrite it with new file. ( linux_boot )
And flash only this file ( linux_boot ). Make sure in the flashtool to use the same scatter file you used before and mark only this file ( linux_boot ) . Also use only the download button option ( not firmware upgrade.)
Go to the top of the page
 
+Quote Post
johndude
post Jun 18 2018, 11:44 AM
Post #9





Group: Members
Posts: 3
Joined: 18-June 18
Member No.: 824,674



QUOTE(galodoido @ Jun 18 2018, 07:00 PM) *
You can download the kernel in the instructions, save it , rename with the same name in the full download folder (i.e linux_boot ). Make a backup of the older file and overwrite it with new file. ( linux_boot )
And flash only this file ( linux_boot ). Make sure in the flashtool to use the same scatter file you used before and mark only this file ( linux_boot ) . Also use only the download button option ( not firmware upgrade.)


Hi,

Thanks for the reply.

Yes I installed the new firmware, and also checked the MD5 as per the instructions, everything else works

John
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2019 - 06:43 PM