OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Stray CAPSLOCK after Fn and TAB
Radovan Garabík
post Feb 8 2019, 02:32 AM
Post #1





Group: Members
Posts: 10
Joined: 20-January 19
Member No.: 840,229



I observed strange behaviour with my Gemini: if I press Fn and then TAB (i.e. standalone Fn keypress and release followed by standalone TAB) toggles CAPSLOCK. This seems to be 100% reproducible. Since I am using TAB a lot, invariably from time to time I turn inadvertently CAPSLOCK on and that's quite annoying.

Anyone observed similar behaviour? I hope it was not intended by the designers. I am using latest firmware, Gemini US physical keyboard layout. I tried to use Button Remapped to disable CAPSLOCK, but although I can remap the key to a different event (and it is honoured by the system), in addition to this the CAPSLOCK is still turned on after Fn.
Go to the top of the page
 
+Quote Post
Varti
post Feb 8 2019, 04:48 AM
Post #2





Group: Admin
Posts: 931
Joined: 30-April 08
From: Italy
Member No.: 21,713



I can confirm it's the same on my Gemini with a Croatian keyboard, this happens everytime, strange that I haven't observed this before. This might be related to the ghosting issue, for which there was a fix a while ago, but it seems that there's no fix for the latest Android version:

https://www.oesf.org/forum/index.php?showtopic=35014

Varti
Go to the top of the page
 
+Quote Post
Daniel W
post Feb 8 2019, 06:04 AM
Post #3





Group: Members
Posts: 118
Joined: 22-May 18
From: Sweden
Member No.: 823,019



Same here, with a Swedish/Finnish keyboard layout, though I don't think the layout actually matters.

I'd say this is not ghosting, because ghosting is when you are, by simultaneously pressing certain keys, making the keyboard think you also pressed one (or more) other key(s). To reproduce this issue, however, there's no need to simultaneously press anything. Instead, one can press and release Fn, then wait, use the touchscreen, switch to another app or whatever. When then pressing tab, Caps Lock will turn on (or off, if it was on).

Another thing making this "not ghosting" is that no tab char is produced. This can be easily verified by using a text editor that support tab stops. Instead the only result of Fn followed by Tab is Caps Lock, so rather than a certain key combination causing an extra result, this key sequence only causes a different result from what it reasonably should.

In my book, that's a bug.

Edit: Possibly, it could be a designed behavior, intended to allow people using one finger only to type caps. That would, however, seem a bit nonsensical for a physical keyboard, since Fn followed by a letter, does not produce a symbol, nor does Shift followed by a number. Thus it wouldn't really facilitate single-finger use in any meaningful way. I rather think this is an unintended carry-over from typical default touch screen behavior, where various modifier keys, such as Shift, typically are supposed to be "sticky" by default. Probably Planet Computers had to remove this "stickyness", when coding their keyboard driver and, for some reason, Fn followed by Tab invokes a different code path, from which the default "stickyness" hasn't been properly removed.
Go to the top of the page
 
+Quote Post
Radovan Garabík
post Feb 8 2019, 07:24 AM
Post #4





Group: Members
Posts: 10
Joined: 20-January 19
Member No.: 840,229



I wonder if Fn is handled in hardware, or in software - i.e., does it send its own scancode? It would be trivial to find out under Linux, or rooted Android but I have not gotten around to installing any of them.

And since it works as a sticky key only with TAB, I do not think it's really intentional, though for thumb typing sticky keys work better (but not for touch typing). Anyway, together with ghosting it's really annoying.
Go to the top of the page
 
+Quote Post
jakfish
post Feb 8 2019, 02:17 PM
Post #5





Group: Members
Posts: 261
Joined: 12-September 10
Member No.: 91,772



I have a US keyboard and my caps is officially tied to fn-tab, the Tab key has "Caps" written underneath.

Perhaps the US keyboard was the template and other keyboards followed and someone forgot to remap that keystroke for subsequent countries.

I made an apk that remapped some unfortunate default keystrokes on the US keyboard (namely the single and double quote), so I know that fn-Tab can be remapped, but it's tricky.

Jake
Go to the top of the page
 
+Quote Post
Radovan Garabík
post Feb 8 2019, 11:21 PM
Post #6





Group: Members
Posts: 10
Joined: 20-January 19
Member No.: 840,229



QUOTE(jakfish @ Feb 8 2019, 11:17 PM) *
I have a US keyboard and my caps is officially tied to fn-tab, the Tab key has "Caps" written underneath.

Perhaps the US keyboard was the template and other keyboards followed and someone forgot to remap that keystroke for subsequent countries.


It's not about layout - I am quite sure most if not all layouts have the same placement of the Caps key, but about the sticky behaviour of Fn followed by standalone Tab (this and only this combination), which is probably not intended.
Dual role modifiers keys can be damn useful on reduced layouts (I am using xcape on my notebook), if designed properly, but this one is not.

And yes, non-U{S,K} input on the Gemini sucks. What it really needs is a user configurable input method, something that is doable on Linux but damn difficult on Android. But that's a different topic.
Go to the top of the page
 
+Quote Post
novaldex
post Feb 11 2019, 02:38 AM
Post #7





Group: Members
Posts: 34
Joined: 8-January 18
Member No.: 816,032



And I thought it was just how I was typing.. But I see the exact same behaviour on a UK keyboard layout.
Go to the top of the page
 
+Quote Post
Dixit
post Mar 3 2019, 03:01 AM
Post #8





Group: Members
Posts: 111
Joined: 19-June 18
Member No.: 824,751



I like to add a similar problem.

The combination GeminiLogo+Tab should work as in Windows Alt+Tab, i.e. it switches to another App.
Sometimes this works, sometimes this combination activates Caps Lock. I push it a second time and then it works. But then I need to switch off Caps Lock, which is to be done with Fn+Tab.

I have a US keyboard.
Go to the top of the page
 
+Quote Post
spook
post Mar 6 2019, 02:51 PM
Post #9





Group: Members
Posts: 17
Joined: 24-June 18
Member No.: 824,977



Even stranger - for me at least. If I use the fn key in combination with another key to produce a symbol, then hit the tab key, it still turns the caps key on. So if I want to do a colon, followed by a tab, caps is automatically turned on for the following letters.
Go to the top of the page
 
+Quote Post
Daniel W
post Mar 7 2019, 06:19 AM
Post #10





Group: Members
Posts: 118
Joined: 22-May 18
From: Sweden
Member No.: 823,019



QUOTE(spook @ Mar 6 2019, 11:51 PM) *
Even stranger - for me at least. If I use the fn key in combination with another key to produce a symbol, then hit the tab key, it still turns the caps key on. So if I want to do a colon, followed by a tab, caps is automatically turned on for the following letters.

Confirmed.

I need to use, for example, Fn + P to type the Swedish vowel Å. If I press Tab directly afterwards, instead of getting a Tab character, the Gemini toggles the Caps Lock state. This seems to happen for all combinations of Fn + Key followed by Tab. For example, Fn + Screenshot followed by Tab or Fn + Z (which, on my Swedish layout, has no Fn symbol), also toggles Caps Lock.

One (further) strangeness I've observed is that whenever Caps Lock is on, the keyboard shortcuts for showing or hiding emoji or extra symbols doesn't work. So, if I'd for example show the emoji soft keyboard and (for some reason) press Tab directly afterwards, not only will Caps Lock turn on, but I am now also unable to hide the emoji soft keyboard, until I've first turned off Caps Lock again. Weird.

Edit, March 10: One more: If I hold Fn down and press Tab, Caps Lock, as expected, turns on, but if I keep Fn down and press Tab again, Caps Lock does not turn off. To turn Caps Lock off (or on, if it was off), I first need to let go of both keys. Only then can I press Fn + Tab to toggle Caps Lock. The expected behavior would be that holding Fn down and pressing Tab multiple times, would toggle Caps Lock equally many times.

Together, these oddities can cause some counter-intuitive combinations. Let's say, I have my Gemini just within reach and I need to type an uppercase Å only, perhaps because I assigned it as a deliberately-hard-to-press-by-mistake shortcut in some app. For this, I would normally (on a Swedish keyboard layout) press Shift + Fn + P, but for this contrived example, let's say three fingers is one too many. I could instead press Fn+Tab to turn on Caps Lock. Still holding Fn, I could then press P, to get my uppercase Å. Were I then to, still holding Fn, press Tab again, Caps Lock would not turn off, but were I instead to release Fn after typing Å, and thereafter press Tab only, Caps Lock would turn off.

Edit #2, April 9: And one more: Sometimes, when I open my Gemini to type something, Caps Lock is just randomly on, but the Caps Lock LED isn't lit. This can be quite confusing when I'm trying to enter a password and, thus, all I'll see, is a row of dots, rather than actual characters. In those cases pressing Fn and (then) Tab, does indeed turn off Caps Lock, but since the LED was already off, nothing appears to happen, except that, thereafter, Caps Lock is off, for real.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2019 - 04:45 PM