Printable Version of Topic

Click here to view this topic in its original format

OESF Portables Forum _ Zaurus - Void Linux support _ Void Linux Packages

Posted by: greguu Jun 26 2018, 10:52 PM

Note: This repo is in a testing phase and will currently allow you to upgrade from a build5 rootfs or older to build6. Additional packages will be announced here for testing.

Many Thanks go to Varti & ibiblio for hosting this repository!


01. Enable the repo:

CODE
echo 'repository=https://www.oesf.org/repository/feeds/voidlinux/testing/build6' > /etc/xbps.d/00-repository-main.conf


02. Sync and Upgrade (Example):


CODE
~ # xbps-install -Syu
[*] Updating `https://www.oesf.org/repository/feeds/voidlinux/testing/build6/armv5tel-musl-repodata' ...
armv5tel-musl-repodata: 33KB [avg rate: 2342KB/s]
`https://www.oesf.org/repository/feeds/voidlinux/testing/build6' repository has been RSA signed by "greguu"
Fingerprint: 13:09:b2:e3:ba:9b:7f:99:01:a5:45:a3:3b:79:c3:ed
Do you want to import this public key? [Y/n] y

Name        Action    Version           New version            Download size
libcrypto43 install   -                 2.7.4_1                -
libssl45    install   -                 2.7.4_1                79KB
libxbps     update    0.51_20           0.52_6                 76KB
xbps        update    0.51_20           0.52_6                 74KB

Size to download:              230KB
Size required on disk:        1805KB
Free space on disk:           1877MB


[*] Downloading binary packages
libcrypto43-2.7.4_1.armv5tel-musl.xbps.sig: 256B [avg rate: 749KB/s]
libssl45-2.7.4_1.armv5tel-musl.xbps: 79KB [avg rate: 170KB/s]
libssl45-2.7.4_1.armv5tel-musl.xbps.sig: 256B [avg rate: 746KB/s]
libxbps-0.52_6.armv5tel-musl.xbps: 76KB [avg rate: 335KB/s]
libxbps-0.52_6.armv5tel-musl.xbps.sig: 256B [avg rate: 706KB/s]
xbps-0.52_6.armv5tel-musl.xbps: 74KB [avg rate: 108KB/s]
xbps-0.52_6.armv5tel-musl.xbps.sig: 256B [avg rate: 708KB/s]

[*] Verifying package integrity
libcrypto43-2.7.4_1: verifying RSA signature...
libssl45-2.7.4_1: verifying RSA signature...
libxbps-0.52_6: verifying RSA signature...
xbps-0.52_6: verifying RSA signature...

[*] Running transaction tasks
libcrypto43-2.7.4_1: unpacking ...
libssl45-2.7.4_1: unpacking ...
libxbps-0.51_20: updating to 0.52_6 ...
libxbps-0.52_6: unpacking ...
xbps-0.51_20: updating to 0.52_6 ...
xbps-0.52_6: unpacking ...

[*] Configuring unpacked packages
libcrypto43-2.7.4_1: configuring ...
libcrypto43-2.7.4_1: installed successfully.
libssl45-2.7.4_1: configuring ...
libssl45-2.7.4_1: installed successfully.
libxbps-0.52_6: configuring ...
libxbps-0.52_6: updated successfully.
xbps-0.52_6: configuring ...
xbps-0.52_6: updated successfully.

3 downloaded, 2 installed, 2 updated, 2 configured, 0 removed.



03. Once xbps has been upgraded, sync once more to fetch the remaining packages:


CODE
~ # xbps-install -Syu
[*] Updating `https://www.oesf.org/repository/feeds/voidlinux/testing/build6/armv5tel-musl-repodata' ...

......


21 downloaded, 1 installed, 31 updated, 1 configured, 0 removed.



04. The kernel was also upgraded, so reboot to have the change take effect.

Posted by: Varti Jun 27 2018, 02:36 AM

Nice to see that the repository is working, and thanks for maintaining it! Basically, everytime you run the xpbs client you need to check if the xbps' package is listed in the Binary packages download list; if so, it means it has been updated and you need to run the client again for the remaining packages? Also, how do you tell the kernel has been updated, and so a reboot is required?

Varti

Posted by: greguu Jun 27 2018, 02:59 AM

QUOTE(Varti @ Jun 27 2018, 10:36 PM) *
Nice to see that the repository is working, and thanks for maintaining it! Basically, everytime you run the xpbs client you need to check if the xbps' package is listed in the Binary packages download list; if so, it means it has been updated and you need to run the client again for the remaining packages? Also, how do you tell the kernel has been updated, and so a reboot is required?

Varti


Yes, same as with pacman (Arch) and other package managers, if there is an update for the package manager, the package manager will need to update first. There is no need to check, you will notice the first sync will only list xbps and xbps dependencies if an update is available. On Arch however, pacman resumes the remaining update automatically, whereas with void you need to trigger it manually.

The kernel update was listed as part of the packages that would receive an update.

CODE
linux4.14-zaurus update    4.14.47_1         4.14.50_1              9639KB

Posted by: Varti Jun 27 2018, 04:03 AM

QUOTE(greguu @ Jun 27 2018, 12:59 PM) *
The kernel update was listed as part of the packages that would receive an update.

CODE
linux4.14-zaurus update    4.14.47_1         4.14.50_1              9639KB

Ok, missed the name of the package containing the kernel, thanks for the explanation.

Varti

Posted by: greguu Sep 6 2018, 01:13 AM

Hi!
There is a new testing repository available (build7).

You can switch to the new repo and upgrade from previous builds via:

CODE
echo   'repository=https://www.oesf.org/repository/feeds/voidlinux/testing/build7'   >   /etc/xbps.d/00-repository-main.conf

then you will need to run the following twice and wait for the update to take place.
CODE
xbps-install -Su


A reboot is necessary to have the kernel update take effect.

Note: To see the available packages run:
CODE
xbps-query -Rs "" | more


Alternatively see the attached txt file for a list of packages available in the build7 repository.



 build7_packages_list.txt ( 18.89K ) : 134
 

Posted by: greguu Sep 6 2018, 01:19 AM

Feel free to request packages to be included in the next upcoming build. Cheers!

Posted by: greguu Oct 15 2018, 11:14 PM

The voidz build7 repo was updated.Following packages have been added:
kernel-libc-headers,git,xtools,lighttpd

Note: For a complete list of available binary packages see the attached txt file.

 build7_pkg.txt ( 20.22K ) : 122
 

Posted by: greguu Feb 18 2019, 02:17 AM

The voidz repo has been updated to build8.
Feel free to test:

QUOTE
echo 'repository=https://www.oesf.org/repository/feeds/voidlinux/testing/build8' > /etc/xbps.d/00-repository-main.confxbps-install -Su
xbps-install -Su




Posted by: Varti Feb 18 2019, 06:58 AM

QUOTE(greguu @ Feb 18 2019, 11:17 AM) *
The voidz repo has been updated to build8.
Feel free to test:
QUOTE
echo 'repository=https://www.oesf.org/repository/feeds/voidlinux/testing/build8' > /etc/xbps.d/00-repository-main.confxbps-install -Su
xbps-install -Su


Thanks, I'll test it and report back.

Varti

Posted by: greguu Apr 17 2019, 09:48 PM

Last month I did build an experimental Linux 5.0.0 kernel for Sharp Zaurus C3x00. After some patching it seems to work fine. The new kernel is also available in the build8 repository and will make it eventually in the next voidz rootfs build. If you want to install and test it, use xbps-install or download the file attached and install manually and update your boot.cfg accordingly. This kernel should also work fine with ArchLinuxARM for those interested.

Patches applied to this kernel can be found in the xbps-src template on github:

https://github.com/greguu/voidz-packages/tree/voidz-packages-v03-(build8)/srcpkgs/linux5.0-zaurus

 linux_5.0.0_c3x00.tar.gz ( 13.13MB ) : 36
 

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)