OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
teh.sean doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
No Information
Joined: 23-April 08
Profile Views: 8,378*
Last Seen: 15th December 2019 - 07:59 PM
Local Time: Jan 19 2020, 08:21 AM
84 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
11 Oct 2018
When charging with the provided charger, the Gemini gets very warm. Is this normal for others? I know the charger negotiates a higher current / voltage (beyond 5V / .5A), but I would figure the heat will damage the battery and reduce its life over time.
25 Sep 2018
Does anybody have automatic headphone audio switching working under the Planet Computers provided Debian TP2 environment?

I can switch audio manually using the 'PulseAudio Volume Control' application (pavucontrol?), but I've yet to find a way to set PulseAudio to automatically switch output from the built in speakers to headphones when I plug into the 3.5mm audio jack.

5 May 2014
TronDD and I have noticed an issue running X on 5.5 release. From my experience before, Zaurus' X server 'just worked' without any necessary configuration.
Running startx results in black screen for a few seconds, and then a return to the console. Anyone else noticing the same behavior?

[ 872.326] (--) Using wscons driver on /dev/ttyC1 in pcvt compatibility mode (version 3.32)
[ 872.811]
X.Org X Server 1.14.5
Release Date: 2013-12-12
[ 872.953] X Protocol Version 11, Revision 0
[ 873.025] Build Operating System: OpenBSD 5.5 zaurus
[ 873.099] Current Operating System: OpenBSD zaurus.questforless.com 5.5 GENERIC#4 zaurus
[ 873.179] Build Date: 12 March 2014 04:22:05AM
[ 873.250]
[ 873.323] Current version of pixman: 0.32.4
[ 873.394] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 873.394] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 873.728] (==) Log file: "/var/log/Xorg.0.log", Time: Sun May 4 21:52:41 2014
[ 873.888] (==) Using config file: "/etc/X11/xorg.conf"
[ 873.916] (==) No Layout section. Using the first Screen section.
[ 873.917] (==) No screen section available. Using defaults.
[ 873.918] (**) |-->Screen "Default Screen Section" (0)
[ 873.919] (**) | |-->Monitor "<default monitor>"
[ 874.001] (==) No device specified for screen "Default Screen Section".
Using the first device section listed.
[ 874.002] (**) | |-->Device "Wsdisplay0"
[ 874.003] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 874.005] (==) Disabling SIGIO handlers for input devices
[ 874.006] (==) Automatically adding devices
[ 874.007] (==) Automatically enabling devices
[ 874.007] (==) Not automatically adding GPU devices
[ 874.584] (==) FontPath set to:
[ 874.584] (==) ModulePath set to "/usr/X11R6/lib/modules"
[ 874.584] (II) The server relies on wscons to provide the list of input devices.
If no devices become available, reconfigure wscons or disable AutoAddDevices.
[ 874.585] (II) Loader magic: 0x1ebc74
[ 874.586] (II) Module ABI versions:
[ 874.586] X.Org ANSI C Emulation: 0.4
[ 874.586] X.Org Video Driver: 14.1
[ 874.587] X.Org XInput driver : 19.1
[ 874.587] X.Org Server Extension : 7.0
[ 874.715] Initializing built-in extension Generic Event Extension
[ 874.787] Initializing built-in extension SHAPE
[ 874.859] Initializing built-in extension MIT-SHM
[ 874.931] Initializing built-in extension XInputExtension
[ 875.003] Initializing built-in extension XTEST
[ 875.075] Initializing built-in extension BIG-REQUESTS
[ 875.147] Initializing built-in extension SYNC
[ 875.219] Initializing built-in extension XKEYBOARD
[ 875.291] Initializing built-in extension XC-MISC
[ 875.363] Initializing built-in extension SECURITY
[ 875.436] Initializing built-in extension XINERAMA
[ 875.508] Initializing built-in extension XFIXES
[ 875.580] Initializing built-in extension RENDER
[ 875.652] Initializing built-in extension RANDR
[ 875.724] Initializing built-in extension COMPOSITE
[ 875.796] Initializing built-in extension DAMAGE
[ 875.868] Initializing built-in extension MIT-SCREEN-SAVER
[ 875.941] Initializing built-in extension DOUBLE-BUFFER
[ 876.013] Initializing built-in extension RECORD
[ 876.085] Initializing built-in extension DPMS
[ 876.158] Initializing built-in extension X-Resource
[ 876.230] Initializing built-in extension XVideo
[ 876.303] Initializing built-in extension XVideo-MotionCompensation
[ 876.375] Initializing built-in extension XFree86-VidModeExtension
[ 876.447] Initializing built-in extension XFree86-DGA
[ 876.520] Initializing built-in extension XFree86-DRI
[ 876.592] Initializing built-in extension DRI2
[ 876.593] (II) LoadModule: "glx"
[ 876.680] (II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
[ 876.829] (II) Module glx: vendor="X.Org Foundation"
[ 876.830] compiled for 1.14.5, module version = 1.0.0
[ 876.830] ABI class: X.Org Server Extension, version 7.0
[ 876.831] (==) AIGLX enabled
[ 876.920] Loading extension GLX
[ 876.921] (II) LoadModule: "wsfb"
[ 876.926] (II) Loading /usr/X11R6/lib/modules/drivers/wsfb_drv.so
[ 876.961] (II) Module wsfb: vendor="X.Org Foundation"
[ 876.962] compiled for 1.14.5, module version = 0.4.1
[ 876.962] ABI class: X.Org Video Driver, version 14.1
[ 876.964] (II) wsfb: driver for wsdisplay framebuffer: wsfb
[ 876.965] (WW) Falling back to old probe method for wsfb
[ 877.000] (II) wsfb(0): using /dev/ttyC1
[ 877.004] (EE) Segmentation fault at address 0x10
[ 877.078] (EE)
Fatal server error:
[ 877.148] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 877.221] (EE)
[ 877.293] (EE)

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 877.361] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 877.432] (EE)
[ 877.582] (EE) Server terminated with error (1). Closing log file.

# $OpenBSD: xorg.conf,v 1.5 2012/01/29 11:20:33 matthieu Exp $

Section "Device"
Identifier "Wsdisplay0"
Driver "wsfb"
Option "device" "/dev/ttyC1"
# Comment out to use the screen in vertical mode
Option "rotate" "CW"

OpenBSD 5.5 (GENERIC) #4: Thu Mar 6 04:13:47 MST 2014
real mem = 67108864 (64MB)
avail mem = 58281984 (55MB)
warning: no entropy supplied by boot loader
mainbus0 at root
cpu0 at mainbus0: PXA27x step C-5 (XScale core)
cpu0: DC enabled IC enabled WB enabled LABT branch prediction enabled
cpu0: 32KB(32b/l,32way) I-cache, 32KB(32b/l,32way) wr-back-lock D-cache
pxaip0 at mainbus0: CPU clock = 416.000 MHz
pxaintc0 at pxaip0 addr 0x40d00000: Interrupt Controller
pxagpio0 at pxaip0 addr 0x40e00000: GPIO Controller
pxadmac0 at pxaip0 addr 0x40000000 intr 25: DMA Controller
pxaost0 at pxaip0 addr 0x40a00000
com0 at pxaip0 addr 0x40100000 intr 22: pxa2x0, 32 byte fifo
com1 at pxaip0 addr 0x40200000 intr 21: pxa2x0, 32 byte fifo
com2 at pxaip0 addr 0x40700000 intr 20: pxa2x0, 32 byte fifo (SIR)
ohci0 at pxaip0, version 1.0
usb0 at ohci0: USB revision 1.0
uhub0 at usb0 "PXA27x OHCI root hub" rev 1.00/1.00 addr 1
lcd0 at pxaip0
wsdisplay0 at lcd0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1 added (std, vt100 emulation)
zkbd0 at pxaip0
wskbd0 at zkbd0: console keyboard, using wsdisplay0
scoop0 at pxaip0: PCMCIA/GPIO controller
scoop1 at pxaip0: PCMCIA/GPIO controller
pxapcic0 at pxaip0: 2 slots
pcmcia0 at pxapcic0
pcmcia1 at pxapcic0
pxammc0 at pxaip0: MMC/SD/SDIO controller
sdmmc0 at pxammc0
zssp0 at pxaip0
apm0 at pxaip0
zts0 at pxaip0
wsmouse0 at zts0 mux 0
zaudio0 at pxaip0: I2C, I2S, WM8750 Audio
audio0 at zaudio0
zrc0 at pxaip0: CE-RH2 remote control
wskbd1 at zrc0 mux 1
wskbd1: connecting to wsdisplay0
flash0 at pxaip0: Samsung K9F1G08U0A 128Mx8 3.3V
pxaudc0 at pxaip0: USB Device Controller
usbf0 at pxaudc0: USB revision 1.1
cdcef0 at usbf0: address 2a:cb:00:00:00:00
wdc0 at pcmcia0 function 0 "HITACHI, microdrive" port 0x0/16: irq 138
wd0 at wdc0 channel 0 drive 0: <HMS360604D5CF00>
wd0: 32-sector PIO, LBA, 3906MB, 7999488 sectors
wd0(wdc0:0:0): using BIOS timings
scsibus0 at sdmmc0: 2 targets, initiator 0
sd0 at scsibus0 targ 1 lun 0: <SD/MMC, Drive #01, > SCSI2 0/direct fixed
sd0: 982MB, 512 bytes/sector, 2012160 sectors
vscsi0 at root
scsibus1 at vscsi0: 256 targets
softraid0 at root
scsibus2 at softraid0: 256 targets
boot device: wd0
root on wd0a (22a8adc198419c00.a) swap on wd0b dump on wd0b
WARNING: using filesystem date -- CHECK AND RESET THE DATE!
22 Apr 2014
I noticed that there's some activity on the forum around OpenBSD, and wanted to see if others had experienced the same thing I have.

I've got a SL-C3100.

Trying to play audio causes a kernel panic:
- I noticed that none of the typical /dev/audio or /dev/audioctl handles were created by default, so I ran

- Installed vorbis-tools from packages and attempted
ogg123 -d sndio -o dev:rsnd/1 (ogg file)

which took me to a ddb prompt.

Has anyone else had success playing sound with the Z?

Suspend / Hibernate are not working properly:
- Suspend causes LCD 'white out', but does not appear to power off. LCD backlight does not turn off automatically, or when the lid is closed. Also, the SD slot is detached at suspend and reattached at resume.
- Hibernate does nothing other than output
Hibernating system...

Has anyone else seen issues with suspend / hibernate on their SL-Cxx00?

Other than those issues, the Z runs OpenBSD just fine. The wifi card I had worked without issue and the SD driver works better than the native Cacko one did!
8 Jan 2010
Well, I'm cleaning out the gadgetry and trying to get rid of some of the stuff that I just don't have time for anymore.

That being said, I've got one SL5500 and three SL5600 PDAs that need a new home. Of the SL5600s, there are two PXA255s and one PXA250. I picked these up from a bulk purchase, so they are all well used, but in working condition. They come with battery, but nothing else. I think I restored them to factory default a while back, but honestly I would recommend giving them a fresh start when you get them. Battery life is probably going to be weak, and it doesn't come with a stylus, but you can't beat free. All that I'm asking for is the cost of shipping. I would prefer to ship in the CONUS, but I don't mind shipping internationally if people are willing to pay for it.
Last Visitors

29 May 2019 - 0:06

9 Nov 2015 - 23:56

19 Mar 2010 - 6:21

16 Mar 2010 - 2:01

26 Feb 2010 - 15:14

Other users have left no comments for teh.sean.

There are no friends to display.
RSS Lo-Fi Version Time is now: 19th January 2020 - 05:21 AM