OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Mplayer Problems On C3000, Trouble with /dev/rtc a.o.
bustersnyvel
post Mar 24 2005, 05:00 AM
Post #1





Group: Members
Posts: 16
Joined: 10-February 04
From: Amsterdam, The Netherlands
Member No.: 1,796



Hi folks,

I've just got my Zaurus SL-C3000, and I want to play movies on it! I've installed mplayer version dev-CVS--3,4,2 - the one that's linked from the Kino2 website. Unfortunately, it won't work sad.gif I've tried it with the following commands:

mplayer somefile.mpeg -vo bvdd -f scale=640:480,rotate=1

It gives me the following output:

CODE
Failed to open /dev/rtc: Device or resource busy (it should be readable by the user)


I tried to fix this by killing atd (which uses /dev/rtc), which gave me:

CODE
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.


Besides the above message, MPlayer gives me:

CODE
Encrypted VOB file! Read DOCS/HTML/en/dvd.html
MPEG-PS file format detected
VIDEO: MPEG1 352x240 (aspect 12) 29.970 fps 1100.0 kbps (137.5 kbytes/s)


The file can be played by the stock Media Player pre-installed on the C3000.

I get a black rectangle on my monitor (presumably where the video is supposed to be), and the audio plays for about half a second. The only way to quit mplayer then is to hit ctrl+C in the terminal.

I'm running QTopia 1.5.4 and kernel 2.4.20 on the stock Sharp C3000 ROM version 1.01 JP, translated into English. Hopefully, someone can help me get this thing to work!
Go to the top of the page
 
+Quote Post
bustersnyvel
post Apr 27 2005, 04:57 AM
Post #2





Group: Members
Posts: 16
Joined: 10-February 04
From: Amsterdam, The Netherlands
Member No.: 1,796



I hate bumping my post, but doesn't anyone have any idea on how to get this issue resolved?
Go to the top of the page
 
+Quote Post
Jinidog
post Apr 27 2005, 05:16 AM
Post #3





Group: Members
Posts: 76
Joined: 25-April 05
From: Berlin, Germany
Member No.: 6,985



Why not checking, what it's complaining about?

Failed to open /dev/rtc: Device or resource busy (it should be readable by the user)

So, check, whether /dev/rtc is readable by all users.
ls -l /dev/rtc
Go to the top of the page
 
+Quote Post
bustersnyvel
post Apr 27 2005, 05:24 AM
Post #4





Group: Members
Posts: 16
Joined: 10-February 04
From: Amsterdam, The Netherlands
Member No.: 1,796



QUOTE(Jinidog @ Apr 27 2005, 01:16 PM)
Why not checking, what it's complaining about?


I did. It wasn't readable because it was in use by atd. I killed it, as I described in the initial post. File permissions on /dev/rtc are correct.
Go to the top of the page
 
+Quote Post
iamasmith
post Apr 27 2005, 05:25 AM
Post #5





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



There's a note on the original page (atty.jp) that says the mplayer package SHOULD chmod a+s root mplayer, however, this doesn't seem to work properly in the postinst script.

Change to root and try..

chmod a+s `which mplayer`

Then give it a go from the zaurus user account.

- Andy
Go to the top of the page
 
+Quote Post
ThirtyOne
post Apr 27 2005, 06:36 AM
Post #6





Group: Members
Posts: 86
Joined: 10-May 04
Member No.: 3,227



I have seen several posts where people have problem with rtc and mplayer.

I always use the -nortc flag when playing files with mplayer on my Z.

Also, I doubt you are going to get 640:480 to work. You should try 320:240.
Go to the top of the page
 
+Quote Post
iamasmith
post Apr 27 2005, 06:46 AM
Post #7





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(ThirtyOne @ Apr 27 2005, 02:36 PM)
I have seen several posts where people have problem with rtc and mplayer.

I always use the -nortc flag when playing files with mplayer on my Z.

Also, I doubt you are going to get 640:480 to work.  You should try 320:240.
*


The bvdd driver doesn't support 320:240 at the moment.... at least not last time I checked. It results in a spectacularly ugly crash if you try it. To test it I had to set up a dummy version of QKconsole to launch in Zoomed mode and run it from there.

If you are going for 320:240 then you would need to use the ATI version of mplayer and the workaround to use fbdev. Although the ATI driver isn't supported this version has fbdev compiled in and the necessary stuff to select fbdev modes - the bvdd version doesn't seem to do this as reliably.

Can't remember the posting but search the 3K part of the forum and it has a link telling you how to set up the fbmodes with Kino2.

- Andy
Go to the top of the page
 
+Quote Post
Miami_Bob
post Apr 27 2005, 11:45 PM
Post #8





Group: Members
Posts: 483
Joined: 10-April 04
From: Miami FL
Member No.: 2,781



My C860 also gets the

"Failed to open /dev/rtc: Device or resource busy (it should be readable by the user)"

error (among several others) but Kino2 & Mplayer run despite the warnings. Are you sure tht /dev/rtc is what is aborting your exec?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2019 - 12:33 PM