OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> No audio after accepting new config during update
ZimbiX
post Feb 17 2019, 06:46 PM
Post #1





Group: Members
Posts: 4
Joined: 22-December 18
From: Melbourne, Australia
Member No.: 838,517



Hey guys,

I did an `apt upgrade` yesterday for the first time in about six weeks. In the process, I was prompted whether to replace the existing config for I think PulseAudio. Thinking it'd be fine (and maybe help with the lack of automatic output switching), I accepted the replacement, but after rebooting, sound has not worked at all. Nothing comes out of the speakers or headphone jack. Adjusting the volume from alsamixer doesn't help. I still get the interference noise through the headphone jack when not playing music, which goes away when music is (silently) playing, so it feels like it's almost working.

Do you know of a way to recover this config file?

Is there a logfile which would tell me what file it was? I should have made a note of it!

I'm guessing I'll need to pull it out of the Debian installation image. Maybe mount it somehow in order to do that.

Cheers!
Go to the top of the page
 
+Quote Post
Adam Boardman
post Feb 18 2019, 12:40 AM
Post #2





Group: Members
Posts: 168
Joined: 29-December 17
Member No.: 815,489



The new config should work, and you should find that the old config is saved with a dpkg old extension or similar, you could then experiment with the changes.

Before you resort to that, could you try running the volume control whilst audio is being output and then change the output from 'fast' to 'normal'.

The changes to pulseaudio are related to getting in-call audio to work and automatically switch about based upon audio-jack, open/closed state and orientation (still pending a fix for this last to work properly). If there is anyone who still has the old audio setup I would be interested to know if they had the 'fast' version working or was the auto picking just picking normal? I didn't make any changes in that area so have no idea why that changed if it did.

Logging can be viewed with the journalctl command, see: Debugging

If you do figure anything out then let us know.
Go to the top of the page
 
+Quote Post
Eric BF
post Feb 18 2019, 09:05 AM
Post #3





Group: Members
Posts: 77
Joined: 25-June 18
Member No.: 824,997



Back in January, I upgraded (bringing in the late November kernel, I believe) and I lost sound. When I upgraded recently, as advised to by Adam for other reasons, sound came back. ZimbiX: what kernel are you running?
Go to the top of the page
 
+Quote Post
mithrandir
post Feb 18 2019, 11:09 AM
Post #4





Group: Members
Posts: 116
Joined: 7-January 18
Member No.: 815,997



Just guessing. You might try two things:

1. apt-get -o Dpkg::Options::="--force-confmiss" install --reinstall pulseaudio
(in case some part of your config is borked, afterwards pulseaudio -k or reboot)
2. pactl set-default-sink sink.primary
(Under circumstances it seems sink.fast is default, resulting in no audio)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th August 2019 - 02:20 AM