OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Problem #2 -- Remote Display With Ssh, can't display X programs from Z onto desktop.
dlj0
post Nov 18 2007, 08:24 PM
Post #1





Group: Members
Posts: 218
Joined: 3-March 06
Member No.: 9,282



I used to do this all the time, and with my upgrade to debian armel/sid, it no longer works. I ssh into the Z from my (debian) desktop, and run an x program on the Z, such as xclock. Used to be, ssh and sshd were set up so that it would display on the desktop. It did that with titchy, angstrom, etc. I have poured over the /etc/ssh/ssh_config and /set/ssh/sshd_config files, and as far as I can tell they are identical on the two computers, and identical to my old config files from titchy. I can display programs on the Z that are running from the desktop just fine, but not the other way around. It seems that the DISPLAY environment variable does not get set, even though the sshd_config file says:

X11Forwarding yes
X11DisplayOffset 10

it is listening on port 22, protocol 2.

Anyone else? Any clues? It's more annoyance than anything else, but I would like to fix it.

SOLVED!

I had not bothered to configure /etc/network/interfaces, since dhclient brought up the link without it. All I needed to do was configure the loopback X interface (lo) and it now works. This makes sense because ssh pipes from the loopback interface to the remote server.
Go to the top of the page
 
+Quote Post
jpmatrix
post Nov 18 2007, 10:28 PM
Post #2





Group: Members
Posts: 1,014
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(dlj0 @ Nov 19 2007, 05:24 AM) *
I used to do this all the time, and with my upgrade to debian armel/sid, it no longer works. I ssh into the Z from my (debian) desktop, and run an x program on the Z, such as xclock. Used to be, ssh and sshd were set up so that it would display on the desktop. It did that with titchy, angstrom, etc. I have poured over the /etc/ssh/ssh_config and /set/ssh/sshd_config files, and as far as I can tell they are identical on the two computers, and identical to my old config files from titchy. I can display programs on the Z that are running from the desktop just fine, but not the other way around. It seems that the DISPLAY environment variable does not get set, even though the sshd_config file says:

X11Forwarding yes
X11DisplayOffset 10

it is listening on port 22, protocol 2.

Anyone else? Any clues? It's more annoyance than anything else, but I would like to fix it.


are you using only root or your normal user ?
Go to the top of the page
 
+Quote Post
dlj0
post Nov 19 2007, 10:29 AM
Post #3





Group: Members
Posts: 218
Joined: 3-March 06
Member No.: 9,282



QUOTE(jpmatrix @ Nov 19 2007, 01:28 AM) *
QUOTE(dlj0 @ Nov 19 2007, 05:24 AM) *
I used to do this all the time, and with my upgrade to debian armel/sid, it no longer works. I ssh into the Z from my (debian) desktop, and run an x program on the Z, such as xclock. Used to be, ssh and sshd were set up so that it would display on the desktop. It did that with titchy, angstrom, etc. I have poured over the /etc/ssh/ssh_config and /set/ssh/sshd_config files, and as far as I can tell they are identical on the two computers, and identical to my old config files from titchy. I can display programs on the Z that are running from the desktop just fine, but not the other way around. It seems that the DISPLAY environment variable does not get set, even though the sshd_config file says:

X11Forwarding yes
X11DisplayOffset 10

it is listening on port 22, protocol 2.

Anyone else? Any clues? It's more annoyance than anything else, but I would like to fix it.


are you using only root or your normal user ?


Normal user, on both systems.
Go to the top of the page
 
+Quote Post
speculatrix
post Nov 19 2007, 01:55 PM
Post #4





Group: Admin
Posts: 3,693
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



ensure when you login to your Z that you're not overriding the env variable DISPLAY

not all ssh_config files (on the client PC) have X forwarding enabled by default, some have been known to have changed, as it's a security risk, so ensure you try "ssh -X myzaurus"

check that the zaurus's sshd_config has X forwarding enabled too.
Go to the top of the page
 
+Quote Post
dlj0
post Nov 19 2007, 09:04 PM
Post #5





Group: Members
Posts: 218
Joined: 3-March 06
Member No.: 9,282



QUOTE(speculatrix @ Nov 19 2007, 04:55 PM) *
ensure when you login to your Z that you're not overriding the env variable DISPLAY

not all ssh_config files (on the client PC) have X forwarding enabled by default, some have been known to have changed, as it's a security risk, so ensure you try "ssh -X myzaurus"

check that the zaurus's sshd_config has X forwarding enabled too.


It does seem to be overriding the DISPLAY variable, since when I run env in the ssh shell, nothing about DISPLAY shows up. This is with or without the -X option set. And if I do

export DISPLAY=localhost:10.0

in the shell, it still doesn't work. It doesn't complain about not being able to open the display, but nothing shows up, either. Reversing the process does work, though.

Yes, the Z's sshd_config file has:

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
Go to the top of the page
 
+Quote Post
Meanie
post Nov 19 2007, 10:48 PM
Post #6





Group: Members
Posts: 2,803
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



xhosts +?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st November 2019 - 07:16 AM