OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> where is update-gemian-boot-image?
Eric BF
post Jun 14 2019, 07:51 AM
Post #1





Group: Members
Posts: 77
Joined: 25-June 18
Member No.: 824,997



Following the thread on the camera (internal) and trying to get mine working, I decided to install gemian-desktop-minimal. This led to needing to install gemian-modular-kernel. However, this installation fails with the following error:

CODE
/var/lib/dpkg/info/gemian-modular-kernel:arm64.postinst: line 12: update-gemian-boot-image: command not found

I cannot seem to find any package that has the update-gemian-boot-image. I have just done an apt update but do not want to do an apt upgrade as I prefer updating as minimally as possible. I use my system every day and don't wan to break it.

Any suggestions?

Oh, I should add that I have stretch-backports enabled in apt as well, but only for one or two packages that I needed for work.
Go to the top of the page
 
+Quote Post
mithrandir
post Jun 15 2019, 06:24 AM
Post #2





Group: Members
Posts: 123
Joined: 7-January 18
Member No.: 815,997



QUOTE(Eric BF @ Jun 14 2019, 07:51 AM) *
Following the thread on the camera (internal) and trying to get mine working, I decided to install gemian-desktop-minimal. This led to needing to install gemian-modular-kernel. However, this installation fails with the following error:

CODE
/var/lib/dpkg/info/gemian-modular-kernel:arm64.postinst: line 12: update-gemian-boot-image: command not found

I cannot seem to find any package that has the update-gemian-boot-image. I have just done an apt update but do not want to do an apt upgrade as I prefer updating as minimally as possible. I use my system every day and don't wan to break it.

Any suggestions?

Oh, I should add that I have stretch-backports enabled in apt as well, but only for one or two packages that I needed for work.


It is in initramfs-tools-halium. I think I have not installed it manually.

sudo apt install initramfs-tools-halium
should help.

From checking the source initramfs-tools-halium is a dependency of gemian-modular-kernel, so I wonder why it did not get installed automatically.
Go to the top of the page
 
+Quote Post
Eric BF
post Jun 15 2019, 08:48 AM
Post #3





Group: Members
Posts: 77
Joined: 25-June 18
Member No.: 824,997



Thank you. I did have that package installed already but it was a version a month older than what is current. Updating that package made update-gemian-boot-image available now. I guess the gemian-modular-kernel package should have a more specific version dependency for initramfs-tools-halium.

Now to reboot the gemini. Fingers crossed! unsure.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd November 2019 - 06:05 AM