OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Picsel Browser in 2017, Speaking Web Browsing only
HoloVector
post May 29 2017, 08:48 PM
Post #1





Group: Members
Posts: 533
Joined: 22-March 06
From: Winnipeg, Canada
Member No.: 9,420



I finally got the firmware upgraded on my Buffalo WiFi card so it supports WPA.

Varti asked me a few weeks ago how the web browsing was using Picsel Browser. The results so far are a mixed bag when I use on a low ram required website with no ads like this site it works perfectly. I can also tweak the view by changing the browser id from Picsel 1.0 to MSIE 5.5 or 6 or Mozilla 5.

I also got it to work on the Reuters site until an ugly ram hog ad came in the page refresh. CNN is not usable at all because it loads a barebones text only site asking me to choose version which I can't select so I can't see any headlines or content. ARSTechnica causes Picsel browser to run out of RAM immediately



When it works the website display renders as well as my iPad.



PS: this post was submitted through Picsel Browser. wink.gif
Go to the top of the page
 
+Quote Post
Varti
post May 30 2017, 06:19 AM
Post #2





Group: Admin
Posts: 938
Joined: 30-April 08
From: Italy
Member No.: 21,713



Thanks for the test.

As it stands, it works better than I thought. Have you run it on Sharp ROM/Cacko, or have you used another ROM/distro? I don't remember if Cacko supports swap partitions, if so, setting one might help with all the memory-hungry sites, and it might make this browser still usable nowadays. The problem with the swap partition might be *where* to set it up: the SD slot is already used by the Picsel card, the CF slot is in your case probably already used by the Wifi card, and I would avoid setting it on the NAND. The remaining options are the internal Microdrive on an 3x00, or an external USB stick.

Varti
Go to the top of the page
 
+Quote Post
HoloVector
post May 30 2017, 07:34 PM
Post #3





Group: Members
Posts: 533
Joined: 22-March 06
From: Winnipeg, Canada
Member No.: 9,420



I run it in Cacko with the swapfile turned off on both my C1000 and C860. A swapfile would help but as you pointed out where would I put it. USB would be ungainly for such portable unit like the Zaurus. CF card slot is in use. I keep the Picsel SD card on read only to prevent anymore wear on the card. My next Picsel project is to try to get it running under pdaXii13 on my C3200 since the Picsel software doesn't appear to be using any Qt libraries but, that will have to wait until I fix WPA on the C3200. It looks like the pdaXii13 update to 5.4.9 must have failed when I ran it way back when. Because the Z is reporting that it is now running 5.4.8 which had wonky hostap drivers so Wifi Radar and manual wpa_supplicant are failing to connect.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th December 2019 - 03:15 PM