OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
danr doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
No Information
Joined: 12-February 04
Profile Views: 3,793*
Last Seen: 25th July 2011 - 04:46 AM
Local Time: Oct 21 2019, 02:43 PM
138 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
24 Mar 2010
I thought I'd have a go at compiling the kernel for my C860, so I took the Corgi configuration file and used that as a starting point using the 'make menuconfig' command.

Well everything seemed to compile fine, but when I tried booting the kernel I found the keyboard no longer works.

I did get some warnings when compiling, including this one:

In file included from drivers/input/keyboard/corgikbd.c:24:
arch/arm/mach-pxa/include/mach/pxa2xx-gpio.h:4:2: warning: #warning Please use mfp-pxa2[57]x.h instead of pxa2xx-gpio.h
CC drivers/input/keyboard/spitzkbd.o

Has anyone tried doing this? Anyone know where it's going wrong?

8 Aug 2008
I've used the USB link to connect an SL-860 to a Windows PC for a number of years now, and the quality of the connection has never been great. From time to time, especially during large file transfers, the link freezes and I have to disconnect the Zaurus to re-start the network.

Yesterday I booted Ubuntu on a laptop which I normally run Windows XP on, and set up a USB connection to the Zaurus. And the amazing thing was, there were no dropouts or anything, just a rock-steady connection, unlike when running Windows. The same PC when running XP gives the usual unreliability. So this is a software issue.

My work PC is Windows-based, so I can't install Linux there, but I would really like to have the same stability as under Linux. Does anyone have any advice on improving the link quality? I've messed around with all sorts of things, including MTU values, and disabling Windows services, but the link remains unreliable.
21 Jan 2008
Hi all,

For some time I've tried to get the Angstrom 2.6.23 kernel to work with Debian on my C860, but I've been bitten by the altboot bug (see http://bugs.openembedded.org/show_bug.cgi?id=1718 for example), where the system freezes a few seconds after booting.

I think I've found a solution to this issue. After doing some experimenting, it looks like the system hang can be prevented by executing /etc/init.d/sysklogd script early on during initialisation. I don't know why this should stop the hanging, but it does. So to ensure this is run early in initialisation,


cd /etc/rcS.d
ln -sf ../init.d/sysklogd S01sysklogd

Note that you still have to be fast at selecting option 1 (boot from flash) or 3 (boot from SD card) in the altboot menu, and that you usually have to make the selection twice. I also commented out line 474 of /etc/altboot.func, so that it says


#$FSCK $1 || sleep 2

otherwise when booting from SD card, it always checks the filesystem, which takes forever, and may lead to the system freezing because the syslog daemon is not executed in time.

My current setup is as follows:

Latest Angstrom kernel and console image including altboot installed on flash.
Debian tarball unzipped to SD card (in /debian directory).
Angstrom filesystem unzipped to SD card (in /angstrom directory).

The failsafe mode is to boot Angstrom from flash. To experiment with the minimum requirements needed for booting, I


cd /media/card
ln -sf angstrom/* .

Then I play around with which scripts I keep inside /etc/rcS.d and /etc/rc5.d, run altboot, select option 3, and see if the system boots. If it doesn't, I remove the power, select altboot option 1, boot from flash, and make further changes.

To boot Debian, I


cd /media/card
ln -sf debian/* .

and then boot from the SD card.

At the moment I haven't got the CF card working, so maybe this functionality has been removed from the kernel so that I need to load a module or something.

In theory this technique could also be used for other distros, such as Android.

I might have missed other dependencies, such as one or two binaries from Angstrom /sbin, but if other people try this method for determining what the boot requirements are, then we would get a definitive answer. If anyone gets this to work, please add further comments to this thread.


9 Mar 2007
I used to run pdaXrom rc12 on my C860, and the USB link to Windows was a bit flaky, and would drop out from time to time when doing large downloads. Now that I've installed r121, the quality has got worse, and drops out more frequently than before. Has anyone else seen this sort of behaviour? Are there any settings I can change to limit the maximum bandwidth? I've tried changing settings such as

ifconfig usb0 txqueuelen <small value>

ifconfig usb0 mtu <small value>

but neither of these seemed to help.

17 Jul 2006
Has anyone else had any problems executing 'apm -s' from X? I have found that when I do this, upon wakeup X runs really slowly, and I get a load of errors about timeouts with read and write pointers. If I use the suspend button, I have no problems. Similarly, running 'apm -s' from the console wakes up with no problems.

So it appears that pressing the suspend button does something more than just call apm.x, and this extra behaviour prevents the X problem from occurring. Does anyone know anything about this? Does it do something with the framebuffer?

I'd like to get this working so that I can control automatic suspends if I wakeup the Z in the night to do some night-time processing!

I'm running RC12 on an SL-860.

Last Visitors

9 Aug 2008 - 8:01

3 Mar 2008 - 7:50

27 Feb 2008 - 9:18

Other users have left no comments for danr.

There are no friends to display.
RSS Lo-Fi Version Time is now: 21st October 2019 - 05:43 AM