OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> camera on linux ?
cam1965
post Jun 3 2019, 08:10 AM
Post #1





Group: Members
Posts: 56
Joined: 28-May 19
Member No.: 848,911



I saw in this post that camera is working . ( Psionlover comments )

https://www.oesf.org/forum/index.php?showtopic=35750

But mine doesn't work.

Any ideas ?
Thank you all.

Go to the top of the page
 
+Quote Post
mithrandir
post Jun 3 2019, 11:53 AM
Post #2





Group: Members
Posts: 120
Joined: 7-January 18
Member No.: 815,997



QUOTE(cam1965 @ Jun 3 2019, 08:10 AM) *
I saw in this post that camera is working . ( Psionlover comments )

https://www.oesf.org/forum/index.php?showtopic=35750

But mine doesn't work.

Any ideas ?
Thank you all.

The camera works using camera-app.
sudo apt install camera app

Afaik this is the only way of using the camera. Hoping to be wrong, but there is no video device that could be used by standard Linux applications.
Go to the top of the page
 
+Quote Post
cam1965
post Jun 3 2019, 12:07 PM
Post #3





Group: Members
Posts: 56
Joined: 28-May 19
Member No.: 848,911



QUOTE(mithrandir @ Jun 3 2019, 11:53 AM) *
QUOTE(cam1965 @ Jun 3 2019, 08:10 AM) *
I saw in this post that camera is working . ( Psionlover comments )

https://www.oesf.org/forum/index.php?showtopic=35750

But mine doesn't work.

Any ideas ?
Thank you all.

The camera works using camera-app.
sudo apt install camera app

Afaik this is the only way of using the camera. Hoping to be wrong, but there is no video device that could be used by standard Linux applications.


Mine doesn't work . When I arrive at home I will post the results.
Thank you
Go to the top of the page
 
+Quote Post
cam1965
post Jun 3 2019, 02:47 PM
Post #4





Group: Members
Posts: 56
Joined: 28-May 19
Member No.: 848,911



QUOTE(cam1965 @ Jun 3 2019, 12:07 PM) *
QUOTE(mithrandir @ Jun 3 2019, 11:53 AM) *

The camera works using camera-app.
sudo apt install camera app

Afaik this is the only way of using the camera. Hoping to be wrong, but there is no video device that could be used by standard Linux applications.


Mine doesn't work . When I arrive at home I will post the results.
Camera_app already installed with firmware image.
If someone has the latest firmware, please , post results here.
Thank you

follow the error ( print screen )
translating from my language ( portuguese )

It is not possible to access the camera
The app camera does not have permission to access camera hardware or another error occurred.
If conceding permission does not solve the problem, restart the phone.
If I click on edit permissions , it opens google chrome.
If I click cancel a blank screen appears.. ( Camera opened with blank screen ).

Thank you all.

This post has been edited by Varti: Jun 4 2019, 12:32 AM
Reason for edit: Fixed multiple quoting.

Attached thumbnail(s)
Attached Image
 
Go to the top of the page
 
+Quote Post
cam1965
post Jun 3 2019, 03:10 PM
Post #5





Group: Members
Posts: 56
Joined: 28-May 19
Member No.: 848,911



Also tested as root without success

This post has been edited by Varti: Jun 4 2019, 12:33 AM
Reason for edit: Removed redundant quoting.
Go to the top of the page
 
+Quote Post
cam1965
post Jun 4 2019, 04:38 AM
Post #6





Group: Members
Posts: 56
Joined: 28-May 19
Member No.: 848,911



QUOTE(cam1965 @ Jun 3 2019, 03:10 PM) *
Also tested as root without success


sometimes camera-app only flashes on the screen and didn' t starts correctly.
Go to the top of the page
 
+Quote Post
cam1965
post Jun 7 2019, 04:53 AM
Post #7





Group: Members
Posts: 56
Joined: 28-May 19
Member No.: 848,911



QUOTE(cam1965 @ Jun 4 2019, 04:38 AM) *
QUOTE(cam1965 @ Jun 3 2019, 03:10 PM) *
Also tested as root without success


sometimes camera-app only flashes on the screen and didn' t starts correctly.


Compiled from github.

Same problems.
Go to the top of the page
 
+Quote Post
cam1965
post Jun 12 2019, 07:38 AM
Post #8





Group: Members
Posts: 56
Joined: 28-May 19
Member No.: 848,911



QUOTE(cam1965 @ Jun 7 2019, 04:53 AM) *
QUOTE(cam1965 @ Jun 4 2019, 04:38 AM) *
QUOTE(cam1965 @ Jun 3 2019, 03:10 PM) *
Also tested as root without success


sometimes camera-app only flashes on the screen and didn' t starts correctly.


Compiled from github.

Same problems.


Installed android 7 and debian ( Gemini Partition Tool - Android 7.1/Linux ) from planet. This Debian version is different from the debian version I had in the past ( Gemini Partition Tool - Android 8.1/Linux ) . Same problems as mentioned .
I've noticed that in both debian versions, I have to run /system/bin/cameraserver . If no cameraserver is running the camera-app only flashes as mentioned before. But the problem mentioned before ( see the photo attached ) persists.
Go to the top of the page
 
+Quote Post
mibry
post Jun 12 2019, 11:55 AM
Post #9





Group: Members
Posts: 19
Joined: 18-May 18
Member No.: 822,788



I had the same problem, I reflashed my gemini with the 7.1 android rom and the latest debian and the camera app works. (Just for info)

This post has been edited by Varti: Jun 13 2019, 03:15 AM
Reason for edit: Removed multiple quoting.
Go to the top of the page
 
+Quote Post
cam1965
post Jun 12 2019, 12:12 PM
Post #10





Group: Members
Posts: 56
Joined: 28-May 19
Member No.: 848,911



QUOTE(mibry @ Jun 12 2019, 11:55 AM) *
I had the same problem, I reflashed my gemini with the 7.1 android rom and the latest debian and the camera app works. (Just for info)


Thank you for the information.
Mine doesn't work even with the latest android 7 and debian ( Gemini Partition Tool - Android 7.1/Linux ). Mine has boot 1 for rooted android and boot 2 for debian . Maybe the problem is that I have a rooted android. I think maybe debian have to access some partition from android . But I am not sure about this. Who is the developer of camera-app ? Maybe he can help to solve this problem. Thank you.
Go to the top of the page
 
+Quote Post
mibry
post Jun 12 2019, 10:20 PM
Post #11





Group: Members
Posts: 19
Joined: 18-May 18
Member No.: 822,788



QUOTE(cam1965 @ Jun 12 2019, 09:12 PM) *
Thank you for the information.
Mine doesn't work even with the latest android 7 and debian ( Gemini Partition Tool - Android 7.1/Linux ). Mine has boot 1 for rooted android and boot 2 for debian . Maybe the problem is that I have a rooted android. I think maybe debian have to access some partition from android . But I am not sure about this. Who is the developer of camera-app ? Maybe he can help to solve this problem. Thank you.


That is my setup.
Go to the top of the page
 
+Quote Post
cam1965
post Jun 13 2019, 02:56 AM
Post #12





Group: Members
Posts: 56
Joined: 28-May 19
Member No.: 848,911



QUOTE(mibry @ Jun 12 2019, 10:20 PM) *
That is my setup.


Thank you. Reflashed again, but same error. Now boot 1 android , boot 2 debian , boot 3 root android.
Go to the top of the page
 
+Quote Post
Varti
post Jun 13 2019, 03:19 AM
Post #13





Group: Admin
Posts: 931
Joined: 30-April 08
From: Italy
Member No.: 21,713



@cam1965
@mibry

I have now edited your posts to remove most of the quoted text. Please try to keep the level of the quoted text limited to the minimum necessary.

Varti
Go to the top of the page
 
+Quote Post
cam1965
post Jun 13 2019, 09:28 AM
Post #14





Group: Members
Posts: 56
Joined: 28-May 19
Member No.: 848,911



QUOTE(mibry @ Jun 12 2019, 10:20 PM) *
QUOTE(cam1965 @ Jun 12 2019, 09:12 PM) *
Thank you for the information.
Mine doesn't work even with the latest android 7 and debian ( Gemini Partition Tool - Android 7.1/Linux ). Mine has boot 1 for rooted android and boot 2 for debian . Maybe the problem is that I have a rooted android. I think maybe debian have to access some partition from android . But I am not sure about this. Who is the developer of camera-app ? Maybe he can help to solve this problem. Thank you.


That is my setup.


My gemini is x27. What is yours ? Maybe the camera works only on old gemini ( x25 ) or you are using another debian image. I am using this debian image :

https://support.planetcom.co.uk/download/Li...are7/debian.zip

And this android image :

https://support.planetcom.co.uk/download/Li...ni_x27_base.zip


Thank you.
Go to the top of the page
 
+Quote Post
mibry
post Jun 13 2019, 10:51 AM
Post #15





Group: Members
Posts: 19
Joined: 18-May 18
Member No.: 822,788



QUOTE
Thank you.


I have an x27 from the second batch. Not sure. Might be an Adam question.

Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2019 - 04:44 PM