OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
mabrown doesn't have a personal statement currently.
Personal Info
53 years old
Born Jan-14-1967
No Information
Joined: 25-April 04
Profile Views: 1,317*
Last Seen: 19th June 2014 - 08:39 PM
Local Time: Jan 18 2020, 11:49 PM
21 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
24 Jul 2008
Hi Everyone,

I have compiled integer versions of libmpcdec and the console Musepack audio player mpc123.

I searched all over for an integer version of libmpcdec but all the packages I tried were too slow, so I suspect they were compiled as floating point. This version is fast enough to web surf etc while playing back Musepack encoded audio.

I think mplayer could be compiled against this for fast Musepack playback. Would be nice to be able to play Musepack audio in Quasar.

My Z now has access to my Musepack encoded CD collection, which has made me very happy biggrin.gif Hopefully it will be useful to others and hasn't already been done.
Attached File(s)
Attached File  libmpcdec.integer_1.2.6_armv5tel.ipk ( 54K ) Number of downloads: 87
Attached File  mpc123_0.2.4_armv5tel.ipk ( 8.85K ) Number of downloads: 84
8 Jun 2007
Hi Everyone,

Not sure if anyone will be able to help with this. Some time ago, I ported the Euphoria programming language to my C860 (it is available at the Euphoria Archive - do a search for "Zaurus".) I've been able to do some useful things with it (simple gtk apps for example.)

I've started work on Euphoria bindings for OpenGL based on the Mesa 6.5.3 includes. These are working fine on my Windoze box. However, I prefer to develop on my Z where possible. On my Z the simple redbook "hello" sample intialises its window OK but fails to display the expected white polygon. The window contents just display black.

I am using 1.1.0beta1 and the mesa version from that feed. I thought perhaps that GLUT might be at fault so I compiled and used freeGlut instead, which gave me the error "Unable to create direct context rendering for window..." I then tried the switch "-indirect" which gets rid of the error. I still have a black display though.

I don't care if this runs slow on my Z as what I'm working on is for the desktop anyway, I just prefer to do most of the dev work on the Z.

Any help with this would be much appreciated.

24 May 2007
Hi everyone,

Can someone point me at the feed for 1.1.0 beta1 for the C860. It seems to have disappeared (again!)


18 Feb 2006
Hi everyone.

Some time ago I compiled the Euphoria programming language for use on my C860.
Euphoria is an interpreted language with a good turn of speed.

You can check out the official versions here:

You can get the Z version for pdaXrom here:

I have used the Euphoria gtk library to create gui apps on my Z with minimal coding required. All of the examples included with the library work although some require small changes on the Z. I will provide the altered files if anyone is interested. You can get the library here:

I can provide a simple euphoria syntax highlighting file for nedit and show how to run your programs from within nedit if anyone is interested. Makes quite a nice development environment.

Please note, these are not packages and require some (simple) installation.

Hope this proves to be useful.

17 Oct 2005
Hi Everyone,

After installing an earlier rc version of Gnumeric and associated dependencies on my rc11 pdax (stupid on my part) , I now have a frozen pdax.

Pdax tries to boot but freezes at the following:

cramfs: wrong magic
FAT: bogus logical sector size 381

This wouldn't be a problem except that there is a file in my user folder that I *really* need to recover.

Is there any sort of rescue method I can use to mount and get at the partitions on my c-860 or force pdax to boot into the console.

Any help much appreciated.

Last Visitors

22 Feb 2014 - 1:59

Other users have left no comments for mabrown.

There are no friends to display.
RSS Lo-Fi Version Time is now: 18th January 2020 - 06:49 AM