OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> Lockscreen Freeze [Partial workaround found]
Adam Boardman
post Mar 25 2019, 02:24 PM
Post #16

Group: Members
Posts: 173
Joined: 29-December 17
Member No.: 815,489

TP2 is Technical Preview 2, it was just following on from the name Planet gave the first release (Technical Preview), and seemed sensible to keep as there are still many device features not supported. The release names are just a way of referring to the starting point, once upgraded to the latest stuff then you really need to refer to the date of you last apt upgrade to compare features available, on this basis TP2 is considered very old. We plan to release a TP3 sometime soon-ish, see other threads on this forum, hoping for a few more fixes first though, there would be no need to upgrade via the flash tool for those with working systems, its just to reduce the updates needed from a fresh install.

Interesting that your cifs didn't work with the modular kernel but did with the all-in one. Hopefully mithrandir can advise, in theory you should have access to more kernel modules and features with the module based one (the package is about 10 times the size after all). The plan was to orphan the all-in kernel in favor of the modular one going forwards, on the assumption of positive feedback, we may have to review that...

Flashing/dd'ing the boot partition manually is expected, once we get some consistent feedback of the advised 'dd' line being correct and the kernels working for lots of folk then we'll make it automatic for those with the new bootloader that knows what key combination was used to boot from. Obviously those who upgraded without going back to the flashtool will not have the new bootloader so we can never safely know which boot partition they use for gemian. Cite recent Sailfish upgrades where they 'assume' a boot partition and people lose their access to Android etc.
Go to the top of the page
+Quote Post
post Mar 25 2019, 03:14 PM
Post #17

Group: Members
Posts: 120
Joined: 7-January 18
Member No.: 815,997

Tried cifs myself with the modular kernel and it worked ( mount -tcifs <URI> <mountpoint>). The cifs module gets automatically loaded. It is the other way around. The non modular kernel does not support cifs since CONFIG_CIFS is not set in aeon6797_6m_n_halium_defconfig.

@klampfenfreak: Maybe you have forgotten to dd the kernel or to reboot before trying? What is the output of lsmod when you have mounted the share? What is the output of uname -a? (Build date of the modular kernel is Mar 22 00:00:17 UTC 2019. The non modular kernel should be older.)

Go to the top of the page
+Quote Post
Eric BF
post Mar 28 2019, 03:54 AM
Post #18

Group: Members
Posts: 77
Joined: 25-June 18
Member No.: 824,997

QUOTE(Adam Boardman @ Mar 22 2019, 08:54 AM) *
As well as all previous fixes which have improved some of the crashes, though there are still plenty to fix, I'm getting sleep reboots every week or two, Nikita is working on a fix for a race condition that may help this.

Ah, thanks for noting this. I have this happen roughly once a week, overnight typically. I look forward to a fix!
Go to the top of the page
+Quote Post
post Mar 28 2019, 05:50 AM
Post #19

Group: Members
Posts: 11
Joined: 29-October 18
Member No.: 835,812


ok, I reinstalled the modular kernel and flashed again. Now also mounting via cifs works well.
Sometimes I get a black desktop with only mouse after a reboot! Only I can do is rebooting again. Has someone similar issues?
Lockscreen works perfekt.
Go to the top of the page
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 13th November 2019 - 10:51 AM