OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
flotsam doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
No Information
Joined: 30-May 18
Profile Views: 720*
Last Seen: 12th July 2019 - 11:21 AM
Local Time: Dec 15 2019, 04:09 AM
18 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour



My Content
2 Jun 2019
Anyone wanting to multiboot Sailfish and Android should probably read this thread.

And I would certainly like to be informed if anyone comes up with a better solution.
31 May 2019
I have been struggling, without success, to get dual-boot Sailfish/Android working. This is using the new partition tool and firmware, doing a full flash ("firmware upgrade").

What I do is:
  • Flash the device
  • Boot into Sailfish. Everything works fine. Can reboot (to sailfish) without problems.
  • Boot into Android. All goes well.
  • Boot back to sailfish. Device is now broken.
The symptoms of the problem are:
  1. The wireless interface gets a new pseudo-random MAC address. This happens on every reboot, with both Android and Sailfish.
  2. The wifi scanning in sailfish returns a bogus network named "NVRAM Warning: Err=0x10". While harmless enough, this seems to indicate some error.
  3. Sailfish fails to recall any WiFi networks that I have connected to before. So it is necessary to reenter passwords, etc. This makes the device pretty much worthless.
The only fix that I have found is to do a full reflash of the device. I have tried various combinations (including some unsupported ones) of Android+Sailfish. I have not tried other OS combinations, so I don't know if any of them also have issues.

So is it just my device, or has someone else encountered this issue? Even better would be if someone has found a fix.

[Edited to add]: See also this thread. It appears that I'm not the only one with the problem, and that it is not specific to sailfish. Does someone from Planet Computers want to help?

[Edited to change topic title]
21 Oct 2018
I was just preparing to flash the new firmware (multi-boot), and thought I'd see if the partition tool had changed since the last time I ran it. I got a very strange result.

It changed the size of the linux partition, from just under 24 GB (correct), to just under 24 PB (yes, peta-bytes, impossibly large). Needless to say, I don't intend using this new scatter file. I have no idea what will happen if you try using it with the flash tool, but probably nothing good.

So people may want to double check the partition tool output before trying to use it.

For whomever gets to fix the bug, the details are:
Gemini x27
Boots: Rooted Android, Recovery, Sailfish OS, Standard Android
Partition sizes: 32GB for Android, 24.407GB for Linux
The bug seems to be triggered by increasing the size reserved for android, i.e. start with 31 GB for android, then nudge the slider over to 32 GB for android, and
then download the scatter file. At least this is how I managed to reproduce it.
29 Jun 2018
Does anyone know of a way to disable and/or change the sound made when activating the voice assistant with the silver button or Fn+Space? I find it obnoxious, and Saiy has a perfectly fine customisable greeting.
Last Visitors

30 May 2018 - 10:25

Other users have left no comments for flotsam.

There are no friends to display.
RSS Lo-Fi Version Time is now: 14th December 2019 - 06:09 PM