OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Disable suspend
Thiago Alves
post Jul 24 2019, 06:21 AM
Post #1





Group: Members
Posts: 11
Joined: 20-July 19
Member No.: 852,376



Hi guys! So, I've been using my Gemini for about a week and I'm loving it! The device is pretty solid and Gemian, even though it is on early development stages, works pretty well. Just one thing that is a bit annoying is that suspend is completely broken. I can live without suspend for now, but what is really disturbing is that I couldn't find a way to prevent it from sleeping after some time of "inactivity". I bought the Gemini to be my little Linux box on the go, to work on projects and code a bit. However, it is very annoying when I am compiling a large project and then all of a sudden it all fails because the device tried to suspend. Apparently Gemini is not handling power settings in the usual way because all methods I could find to disable suspend on Debian just didn't work. Is there a particular way to get rid of suspend on the Gemini?

PS: This is another side-question that is not related to my main question, but I just wanted to shout it out here in case someone knows why. Apparently the linux kernel is using only one CPU. I found the boot args and on mine it has a maxcpus=5 argument (WTF?) and looking at dmesg kernel messages I see that the kernel actually detects 5 CPUs, but apparently in the end just uses one of them maybe? The reason for that is because cat /proc/cpuinfo brings:
Processor : AArch64 Processor rev 4 (aarch64)
processor : 0
model name : AArch64 Processor rev 4 (aarch64)
BogoMIPS : 26.00
BogoMIPS : 26.00
Features : fp asimd evtstrm aes pmull sha1 sha2 crc32
CPU implementer : 0x41
CPU architecture: 8
CPU variant : 0x0
CPU part : 0xd03
CPU revision : 4

Hardware : MT6797X

Also, htop sometimes shows 2 cpus at the top, and some other times (after rebooting) shows 4 cpus. Very weird...
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies (1 - 1)
Thiago Alves
post Jul 28 2019, 06:43 AM
Post #2





Group: Members
Posts: 11
Joined: 20-July 19
Member No.: 852,376



Update: Just found the solution on the TP2 wiki. Here it is:
Controlling Screen Locking

If you desire you can disable the idle timeout display off by doing the following:

sudo nano /etc/X11/xorg.conf

At the top of the file there is a ServerFlags section. Add/replace the following in the ServerFlags section:

Option "OffTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "BlankTime" "0"
When finished your ServerFlags section should look like this:

Section "ServerFlags"
Option "OffTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "BlankTime" "0"
EndSection
Save the file (ctrl+x) and reboot your Gemini. Following the reboot your screen will now only power off on lid close and turn on again when opened.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 15th October 2019 - 03:28 AM