OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> left/middle/right mouse clicks and F1-F12 and Insert keystrokes
Jeffrey Mark Sis...
post Jul 11 2018, 12:29 PM
Post #1





Group: Members
Posts: 10
Joined: 11-July 18
Member No.: 825,932



The twm+emacs setup that I have used for four decades on all of my Unix and then later Linux machines (dekstops, laptops, PDAs, ...) relies on left/middle/right mouse clicks and ability to type the F1-F12 and Insert keystrokes. Can I do this in DebianTP2? How?

My standard setup (which at this point is neurally encoded) uses F1-F10 to select different (emacs, xpdf, xcalc, ...) windows.

I tried setting up .twmrc with

"F10" = : all : f.warpto "xcalc"
"F10" = s : all : f.warpto "xcalc"
"F10" = m1 : all : f.warpto "xcalc"
"F10" = s | m1 : all : f.warpto "xcalc"

with m1 varying among m2, m3, m4, and m5 but none of them worked. Any ideas?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
frnzndr
post Jul 15 2018, 05:52 AM
Post #2





Group: Members
Posts: 13
Joined: 14-July 18
Member No.: 826,111



So my inability to get a right mouse-click to work isn't just my own misconfiguration, it doesn't work for anyone (except for the alternative driver in another thread which uses the touchscreen as a trackpad)?

If anyone knows how to get a right click on the touchscreen, I'd love to hear about solutions! I tried using evdev instead of libinput, but that didn't help (maybe expectedly considering libinput is more modern).

The F1-F12 keys would also be useful to get to. Somewhere I read that you should be able to get them with Fn+Shift+1-12, maybe give that a try. It might work in the native Linux, does not in a chroot running via Android, but maybe that is to be expected. (I decided yesterday to try a chrooted Linux for the time being, as I need newer packages than those provided in stretch and using testing or even stretch-backports seems to break the ability to boot into the native linux.)
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th July 2019 - 11:11 AM