OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> OZ 3.5.1 installed, now what?, Z is ready, but maybe not willing....
Calvin
post Oct 4 2004, 12:19 PM
Post #1





Group: Members
Posts: 3
Joined: 27-June 04
Member No.: 3,843



I just dusted off my old Z 5500, and even ordered a new battery for it. I installed and tried both images (GPE and Opie) for OZ 3.5.1. Both are nice, and I kinda like GPE better, but not by much. I have had problems w/both though.

I seem to have lots of dependency problems in Opie, and things just don't work when they are installed. For example I couldn't get konqueror to run until I added several extra feeds to my ipkg.conf file (I'm not sure which one cleared up the problem). I still can't get gaim, IRO, OpieMediaPlayer2... etc. to install. I'm installing to an SD card in ext2 format, and using the ipkg-link command after every install.

With GPE I can never seem to get the ipkg.conf file set up correctly, so I don't know if I will have the same problems with it. At one time I did get everything running, and even got minimo and dillo2 installed, but something weird happened and the Z got caught up in a loop in a reboot and never recovered. I can't for the life of me remember what I did to get it to work.

Here are the 3.5.1 feeds I have in my ipkg.conf file to get konqueror running.
http://opie.handhelds.org/feed/5thtoe/
http://admin.di.fc.ul.pt/~bsantos/feed/
http://openzaurus.org/official/unstable/3.5.1/feed/
http://openzaurus.org/official/unstable/3.5.1/upgrades

Does anyone else have trouble installing software on OZ 3.5.1? If anyone could help, I would like to have gaim, some wordprocessor/speadsheet, IRK, a media player, and a nice webbrowser. GPE is preffered, but it really doesn't matter. If anyone has a minute, I would appreciate some help.

Thanks in advance.
,Cal

P.S. Is there a list of packages I should install immediately to avoid dependency problems? It seemed to help when i installed a bunch of simple programs first. I don't know why. Should I set Force Depends in the package manager?
Go to the top of the page
 
+Quote Post
VeeDubb
post Oct 4 2004, 12:33 PM
Post #2





Group: Members
Posts: 191
Joined: 30-October 03
Member No.: 698



I'm right there with you trying to get the GPE version working. I have just now finaly gotten my CF card to mount correctly, after a couple of re-flashes, and I have also found ipkg to be completely borked.

I have tried to add /mnt/cf/upgrades as a source (the file is there coppied directly from the oz feed) using the line
CODE
src upgrades /mnt/cf/upgrades/

but every time I try to update lists through the front end (GPE-package) or through the command line using ipkg update, it returns an error saying that there was an error with /etc/ipkg.conf or that /mnt/cf/upgrades/Packages could not be found.

This release 'looks' great but I'm still waiting for functionality.
Go to the top of the page
 
+Quote Post
Calvin
post Oct 4 2004, 01:00 PM
Post #3





Group: Members
Posts: 3
Joined: 27-June 04
Member No.: 3,843



Edit: Duh, you would think that by now I would have learned to read. Sorry for answering the wrong question....
Go to the top of the page
 
+Quote Post
Mickeyl
post Oct 4 2004, 01:14 PM
Post #4





Group: Members
Posts: 1,495
Joined: 12-November 03
From: Germany
Member No.: 907



QUOTE(VeeDubb @ Oct 4 2004, 12:33 PM)
I have tried to add /mnt/cf/upgrades as a source (the file is there coppied directly from the oz feed) using the line
CODE
src upgrades /mnt/cf/upgrades/

CODE
src upgrades file:///mnt/cf/upgrades
may be more useful.
Go to the top of the page
 
+Quote Post
lardman
post Oct 4 2004, 01:55 PM
Post #5





Group: Members
Posts: 4,512
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
I seem to have lots of dependency problems in Opie, and things just don't work when they are installed. For example I couldn't get konqueror to run until I added several extra feeds to my ipkg.conf file (I'm not sure which one cleared up the problem). I still can't get gaim, IRO, OpieMediaPlayer2... etc. to install. I'm installing to an SD card in ext2 format, and using the ipkg-link command after every install.


Konq installed fine and works fine for me. I just used the main 3.5.1 feed: http://openzaurus.org/official/unstable/3.5.1/feed/

I've also installed Opie-mediaplayer2. It runs fine but there's no icon (this is a problem with the ipk). Haven't tried gaim yet (doesn't seem to be a new build of it - the one in the feed is for GPE from the look of the dependencies), not sure what IRO is.


Si
Go to the top of the page
 
+Quote Post
Calvin
post Oct 4 2004, 02:08 PM
Post #6





Group: Members
Posts: 3
Joined: 27-June 04
Member No.: 3,843



Sorry IRO should be IRK, which is a IR keyboard driver.... Could you tell me how to run opie-media player2 from the command line?
Go to the top of the page
 
+Quote Post
VeeDubb
post Oct 4 2004, 03:32 PM
Post #7





Group: Members
Posts: 191
Joined: 30-October 03
Member No.: 698



QUOTE(Mickeyl @ Oct 4 2004, 01:14 PM)
QUOTE(VeeDubb @ Oct 4 2004, 12:33 PM)
I have tried to add /mnt/cf/upgrades as a source (the file is there coppied directly from the oz feed) using the line
CODE
src upgrades /mnt/cf/upgrades/

CODE
src upgrades file:///mnt/cf/upgrades
may be more useful.

I love you mickey.

That works like a charm, and now i can install what I need to moutn my SD card, then I can instal.........

THanks.
Go to the top of the page
 
+Quote Post
lardman
post Oct 5 2004, 12:50 AM
Post #8





Group: Members
Posts: 4,512
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
Could you tell me how to run opie-media player2 from the command line?


I can't remember exactly what it's called but I think it's opieplayer2; so:

# /opt/QtPalmtop/bin/opieplayer2


Si
Go to the top of the page
 
+Quote Post
-G-
post Oct 5 2004, 01:03 AM
Post #9





Group: Members
Posts: 15
Joined: 24-September 04
Member No.: 4,749



QUOTE(lardman @ Oct 4 2004, 09:55 PM)
I've also installed Opie-mediaplayer2. It runs fine but there's no icon (this is a problem with the ipk).

Sorry to ask such a basic question.

Is there a way to solve the missing icon problem from the console to create one?
Or is it that it will not work even if one is set up?

Thanks,

-G-
Go to the top of the page
 
+Quote Post
lardman
post Oct 5 2004, 02:19 AM
Post #10





Group: Members
Posts: 4,512
Joined: 25-October 03
From: Bath, UK
Member No.: 464



You can just create a .desktop file in opt/QtPalmtop/apps/Applications/ pointing to the correct binary.

Copy on the the existing ones and alter the bits inside and the name.


Si
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th January 2020 - 02:15 PM