Printable Version of Topic

Click here to view this topic in its original format

OESF Portables Forum _ Gemini PDA - General Discussion _ How can I restore my IMEI myself?

Posted by: uduo Mar 20 2019, 01:37 PM

Notice that I said myself, I dont have any interest in sending my phone to planet computers to be serviced.

That being said, after a flash I lost my NVRAM and subsequently my IMEI. I've tried just about everything and I THINK I could get it to work if I could find the valid MTK drivers for Windows but that doesnt seem to be working either.


I've found a few ways to go about this.

APPS: (Requires root)

Software: (Requires MTK drivers)
So, as far as my experiences with them.

Chamelephon is the only one I've been able to get to work, and somehow the only time it worked was when I had flashed rooted android, but had not fully rooted it with magisk. I was able to go from no sim card detected to invalid IMEI. With the invalid IMEI status I was able to text and call but not receive cellular data. So I thought maybe if I completed the root with Magisk and tried again I would get cellular but no, after giving Chamelephon root privileges and trying again I went back to no SIM Detected

MTK Engineering mode is supposed to let you change IMEI under CDS Information, but that was not an option listed on my phone.

Rooted Termux apparently allows you to send some 'AT' commands to /etc/radio or something or other but that seemingly had no effect.

I am unable to get ANY of the software to work because I cannot install the MTK drivers properly. I have allowed for unsigned drivers each time and installed via add legacy programs in the device manager manually each time and while I am able to get them installed the drivers are listed as Code 10 (This device cannot start) each time. I have tried the MTK 65xx drivers and the MT6577 drivers, both giving me USB VCOM 8/9 Ports with code 10.

I just want my phone to work as a phone again If anyone has any extra avenues to try, or knows of the proper drivers that work with IMEI Writing software, let me know.


Posted by: Varti Mar 21 2019, 12:41 AM

I'm also missing the CDS Information option under the MTK Engineering mode on my non-rooted Android. Have you tried the Engineering mode on a rooted system? Maybe in that case the option might become available.

How are you trying to send the AT commands under Termux? I'd like to give it a try, though I guess I'd have to root my system first, as you mentioned.

Also, do you have access to a PC with Linux installed? The MTK drivers might be already available under Linux, though I have seen that that's not the case with Void Linux, at least on my laptop.


Posted by: Sky123 Mar 26 2019, 04:50 AM

You don't need to send the device in, but the easiest way is contact Planet Computer support (, explain and ask for them to generate a replacement NVRAM partition. They'll ask for some sort of proof of IMEI (it's written on the packaging, so I just took a picture). They can then generate the right NVRAM partition for you to flash back to your Gemini.

I did this yesterday, and it definitely works.

I've been down the other route (rooted, termux) previously and managed to get IMEI working in Android, but the NVRAM partition also holds WiFi Mac and Bluetooth ids, and not having those causes a lot of other problems too. On Sailfish, I had absolutely no connectivity (wifi or 4G) without a working NVRAM partition. Likewise, I had no luck obtaining MTK drivers.

Hope that helps!

Posted by: gidds Mar 28 2019, 09:40 AM include taking a backup of your NVRAM partition before making any changes.

This thread shows just why that's important… smile.gif

So, to everyone else, please take this as a reminder!

Posted by: bluethumb Sep 18 2019, 04:32 AM

I have the same problem, I try to install Sailfish and in the process wiped out IMEI part !!
I could not get Planet Computer to help me because they where very busy, but got it now
running with this "Hack" I got back from Planet Computer

In the meantime, you can use the following method to temporarily fix the IMEI on your device. With this method, however, you can't currently run Android 8.
- Flash Android rooted image (don’t forget to install Magisk Manager)
- If connected to a PC using ADB:

1. Enable Developer mode and USB debugging
2. **adb shell**
3. **su** (a window should popup asking for permission)
4. **whoami** (you should get root as a response)
5. **echo 'AT+EGMR=1,7,"IMEI"' > /dev/radio/pttycmd1**

Please ensure IMEI is replaced with the real one which you can find on a sticker on the bottom of your original box - it's also present on the Gemini itself if you remove the top cover using the cover removal tool.

1. **Restart your Gemini**

- Typing commands directly using a terminal emulator:

1. Install a terminal emulator (for example “Terminal Emulator by Jack Palevich”)
2. **su** (a window should popup asking for permission)
3. **whoami** (you should get root as a response)
4. **echo 'AT+EGMR=1,7,"IMEI"' > /dev/radio/pttycmd1**

Please ensure IMEI is replaced with the real one which you can find on a sticker on the bottom of your original box - it's also present on the Gemini itself if you remove the top cover using the cover removal tool.

1. **Restart your Gemini**
Please note that the IMEI will be lost after a factory reset and you will have to restore it again following the previous steps.

So yes it's a pain and I hope they (PC) will soon NOT be too busy unsure.gif ph34r.gif

Powered by Invision Power Board (
© Invision Power Services (