Printable Version of Topic

Click here to view this topic in its original format

OESF Portables Forum _ GPD - Linux OS _ Live Distros That Work

Posted by: TheWalt Nov 11 2016, 08:18 AM

So I tried Ubuntu 64bit 16.10 and Ubuntu-Mate 64bit 16.10 and neither would boot. Both get to the text menu where you can pick install / live/ etc. but when I select live you see the little keyboard in the corner for a second, then half of it dissapears, then just black screen.

Am I missing some setting? Still working on other non-computer related projects but figured I'd get a live environment up and going easier than this?!?!??!

Posted by: ArchiMark Nov 11 2016, 10:07 AM

I've posted about this on various WIN forums out there.....

Posted this post yesterday on the other WIN section....

https://www.oesf.org/forum/index.php?s=&showtopic=34424&view=findpost&p=282698

Have had very mixed results so far.....

Some distros will boot up to desktop, but have had problem trying to rotate display. Weird thing is some other people have been successful rotating display after getting to desktop. Have not been able to figure out why it has not worked for me.

Some distros, that have worked for other people, have not booted up, similar to your situation.

Just downloaded Manjaro/XFCE which worked for someone else and got display to rotate.

If that doesn't work, then next up on my list is Arch, which with some tweaks worked for someone.

Will report back after I try Manjaro.......

smile.gif

Posted by: ArchiMark Nov 11 2016, 10:17 AM

OK, just tried Manjaro.....

Note to self....add to

#ListOfDistrosThatBootToDesktopButCrashWhenTryToRotateDisplay.......


Sigh....................


Good news, Manjaro booted up to desktop.....

Bad news is it crashed (screen turned black....) when I rotated display in Display Settings....

Guess next one up is Arch......

smile.gif

Posted by: greguu Nov 11 2016, 12:17 PM

QUOTE(ArchiMark @ Nov 11 2016, 07:17 PM) *
OK, just tried Manjaro.....

Note to self....add to

#ListOfDistrosThatBootToDesktopButCrashWhenTryToRotateDisplay.......


Sigh....................


Good news, Manjaro booted up to desktop.....

Bad news is it crashed (screen turned black....) when I rotated display in Display Settings....

Guess next one up is Arch......

smile.gif


Hi Mark,

I would be very happy to help but I do not have one yet and they are on pre-order...also I like to see this issue solved first before ordering one.

What kernel is Manajaro booting and can you attach the contents of /var/log/Xorg.0.log and a dmesg right after boot ?

If it boots up to Xorg, does it show the desktop rotated using all of the available screen or just a part in the middle ?

Also can you SSH to the box and troubleshoot, eg dmesg and /var/log/xorg.0.log after you rotated ? Does it freeze the thing after the screen goes black?

Cheers!

Posted by: ArchiMark Nov 11 2016, 07:10 PM

QUOTE(greguu @ Nov 11 2016, 12:17 PM) *
QUOTE(ArchiMark @ Nov 11 2016, 07:17 PM) *
OK, just tried Manjaro.....

Note to self....add to

#ListOfDistrosThatBootToDesktopButCrashWhenTryToRotateDisplay.......


Sigh....................


Good news, Manjaro booted up to desktop.....

Bad news is it crashed (screen turned black....) when I rotated display in Display Settings....

Guess next one up is Arch......

smile.gif


Hi Mark,

I would be very happy to help but I do not have one yet and they are on pre-order...also I like to see this issue solved first before ordering one.

What kernel is Manajaro booting and can you attach the contents of /var/log/Xorg.0.log and a dmesg right after boot ?

If it boots up to Xorg, does it show the desktop rotated using all of the available screen or just a part in the middle ?

Also can you SSH to the box and troubleshoot, eg dmesg and /var/log/xorg.0.log after you rotated ? Does it freeze the thing after the screen goes black?

Cheers!


That's very nice of you, Greg......

Don't know what kernel Manjaro is booting, but suppose I can find out.....

I can try to attach the log and dmesg info.....if I boot it up again....

It booted up to XFCE desktop.....problem is it shown sideways in portrait mode, since display itself is what I presume is a phone or tablet display unit, not a laptop unit. Assume this was a cost saving measure since display is 5.5".....

What I saw on desktop is the taskbar at bottom with the menu button at left end of bar, but remember it is turned sideways....rest of desktop looks OK, just very tall and narrow.

After screen turns black the device does not respond to anything I do. Only thing I can do is shut it down by pressing power button until it turns off.

Was going to try out Arch now, as one person blogged about getting it to display properly....and we all like Arch, right?...... wink.gif

See:

https://www.reddit.com/r/gpdwin/comments/5ac10q/native_linux_on_the_gpd_win/

UPDATE

Tried Arch but after grub screen, I see a few lines of text in console and then doesn't get any further.....

Still can't understand why I have so much trouble and at least a few people have been successful in rotating display........

Posted by: ArchiMark Nov 11 2016, 08:39 PM

Can't get Arch to boot.....

Trying some of the other distros again to see if I might have better luck second time around.....

Meanwhile, if interested, check out:

http://forum.gpd.hk/t23-linux-on-the-gpd-win

Posted by: greguu Nov 11 2016, 09:58 PM

QUOTE(ArchiMark @ Nov 12 2016, 05:39 AM) *
Can't get Arch to boot.....

Trying some of the other distros again to see if I might have better luck second time around.....

Meanwhile, if interested, check out:

http://forum.gpd.hk/t23-linux-on-the-gpd-win


Hi Mark,

I did read the posts and there are contradictory reports. I may question some of these as there are no screenshots too.

Also there are no log files posted . These would give some more insight.

My guess it depends on what kernel is used by the USB boot media and what kernel parameters are used.

Did you try the "nomodeset" parameter and / or as suggested "video=efifb fbcon=rotate:1" ?

You need to modify your USB media and then try again. Once Xorg loaded, then "xrandr -o right" may work.

Set up WiFi and SSH before rotating, then test if you can SSH to the GPD once the screen goes black.

The xorg.0.log would really help a lot along with a dmesg.

You can pipe dmesg to a txt file "dmesg > dmesg.log"

You can find out the kernel version by "uname -a"

Cheers!

Posted by: ArchiMark Nov 11 2016, 10:35 PM

Thanks, Greg, for your continued input and support....greatly appreciated as always.....

Thing I keep pondering is why would rotation work for several other people across several distros, yet not ever work for me on my WIN???

That makes me think that perhaps there's some other factor at play here....that is different on my WIN versus the people have been successful. Otherwise, what would explain this situation?

Have thought about whether there could be a BIOS setting that is different on my WIN or something else like this?....

I have been careful in creating my installs on USB flash drive by checking the checksums prior to doing so.

In some of the distros I did try nomodeset and the other parameter, but I can't say that I did it 100% of the time.

So, will try this again with Manjaro as it does boot to XFCE and works well when I'm in it....just this rotation issue...

Posted by: ArchiMark Nov 13 2016, 07:22 PM

QUOTE
Did you try the "nomodeset" parameter and / or as suggested "video=efifb fbcon=rotate:1" ?


Tried adding these 3 parameters and Voila! now console is rotated correctly.....yeah!...


QUOTE
You need to modify your USB media and then try again. Once Xorg loaded, then "xrandr -o right" may work.


"xrandr -o right" turns screen black......


QUOTE
Set up WiFi and SSH before rotating, then test if you can SSH to the GPD once the screen goes black.

The xorg.0.log would really help a lot along with a dmesg.

You can pipe dmesg to a txt file "dmesg > dmesg.log"


Will try this sometime soon.....

QUOTE
You can find out the kernel version by "uname -a"


It shows 4.4.28-2 MANJARO

[UPDATE]

Forgot to mention that I noticed the following boot parameters in the default setup:

nouveau.modeset=1 i915.modeset=1 radeon.modeset=1

Don't know if these make any difference in this situation.....

Posted by: greguu Nov 13 2016, 11:45 PM

QUOTE(ArchiMark @ Nov 14 2016, 04:22 AM) *
QUOTE
Did you try the "nomodeset" parameter and / or as suggested "video=efifb fbcon=rotate:1" ?


Tried adding these 3 parameters and Voila! now console is rotated correctly.....yeah!...


QUOTE
You need to modify your USB media and then try again. Once Xorg loaded, then "xrandr -o right" may work.


"xrandr -o right" turns screen black......


QUOTE
Set up WiFi and SSH before rotating, then test if you can SSH to the GPD once the screen goes black.

The xorg.0.log would really help a lot along with a dmesg.

You can pipe dmesg to a txt file "dmesg > dmesg.log"


Will try this sometime soon.....

QUOTE
You can find out the kernel version by "uname -a"


It shows 4.4.28-2 MANJARO

[UPDATE]

Forgot to mention that I noticed the following boot parameters in the default setup:

nouveau.modeset=1 i915.modeset=1 radeon.modeset=1

Don't know if these make any difference in this situation.....


Great Mark, first success.

Next is to find out the xorg driver that is loaded, and may force it to use the fbdev driver.

The boot parameters are for NVIDIA, Intel and AMD graphic cards, you can remove them.

Looking forward for a Xorg.0.log and dmesg.

Cheers!

Posted by: ArchiMark Nov 15 2016, 09:43 PM

Been struggling to be able to ssh into WIN from my other computer....

CODE
Users-MacBook:Downloads marks$ ssh 192.168.0.4
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
5c:ca:8e:2d:e0:60:64:bf:03:91:af:dc:ba:62:cb:76.
Please contact your system administrator.
Add correct host key in /Users/marks/.ssh/known_hosts to get rid of this message.
Offending RSA key in /Users/marks/.ssh/known_hosts:1
RSA host key for 192.168.0.4 has changed and you have requested strict checking.
Host key verification failed.



You can see it didn't like it.....

I switched from Manjaro to Linux Mint....wanted to see if I could get it working.....

One issue is there is no password for live version....

Maybe I need to go back to Manjaro......

blink.gif

Posted by: TheWalt Nov 16 2016, 04:48 AM

QUOTE(ArchiMark @ Nov 16 2016, 12:43 AM) *
Been struggling to be able to ssh into WIN from my other computer....

CODE
Users-MacBook:Downloads marks$ ssh 192.168.0.4
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
5c:ca:8e:2d:e0:60:64:bf:03:91:af:dc:ba:62:cb:76.
Please contact your system administrator.
Add correct host key in /Users/marks/.ssh/known_hosts to get rid of this message.
Offending RSA key in /Users/marks/.ssh/known_hosts:1
RSA host key for 192.168.0.4 has changed and you have requested strict checking.
Host key verification failed.



You can see it didn't like it.....

I switched from Manjaro to Linux Mint....wanted to see if I could get it working.....

One issue is there is no password for live version....

Maybe I need to go back to Manjaro......

blink.gif


That is normal, either remove entry #1 in your known_hosts file or just delte it all together. The latter you will have to verify each connection again once but for most users this isn't a probelm.

Posted by: ArchiMark Nov 16 2016, 07:32 AM

QUOTE(TheWalt @ Nov 16 2016, 04:48 AM) *
QUOTE(ArchiMark @ Nov 16 2016, 12:43 AM) *
Been struggling to be able to ssh into WIN from my other computer....

CODE
Users-MacBook:Downloads marks$ ssh 192.168.0.4
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
5c:ca:8e:2d:e0:60:64:bf:03:91:af:dc:ba:62:cb:76.
Please contact your system administrator.
Add correct host key in /Users/marks/.ssh/known_hosts to get rid of this message.
Offending RSA key in /Users/marks/.ssh/known_hosts:1
RSA host key for 192.168.0.4 has changed and you have requested strict checking.
Host key verification failed.



You can see it didn't like it.....

I switched from Manjaro to Linux Mint....wanted to see if I could get it working.....

One issue is there is no password for live version....

Maybe I need to go back to Manjaro......

blink.gif


That is normal, either remove entry #1 in your known_hosts file or just delte it all together. The latter you will have to verify each connection again once but for most users this isn't a probelm.


Thanks for your input, Walt!

Should have figured that out, but was a bit tired after a long day at work....

Meanwhile....

Back at work and thought I'd try to ssh into WIN here.....

Can't get WIN connected to the guest WiFi network here for some reason....it's type where you try to connect and then it should open up a webpage to complete the connection.

So, connected my WIN to my Fujitsu UG90 with a short cat6 network cable.

When I check IP (inet) address on each one, they show the same number (127.0.0.1).

Listed under connection starting with 'en', there is a inet6 string of numbers like fe80::a198:2385:c012:xxxx, etc....

How can I ssh from UG90 into WIN in this situation or do I need another connection method or ?

[ UPDATE ]

Just read that I need a 'crossover' cable if I want to direct connect the two laptops together....will have to see if I can dig one up.....

Or get connected to WiFi network here.....

Thanks.

Posted by: ArchiMark Nov 17 2016, 06:06 PM

Trying to ssh into the WIN at home now.

Problem is that it asks me to enter the WIN's pasword, but there is no password for the live USB version of Linux Mint.

Is there a a simple way to get around this issue?

Thanks.

Posted by: Varti Nov 18 2016, 05:49 AM

QUOTE(ArchiMark @ Nov 16 2016, 04:32 PM) *
Just read that I need a 'crossover' cable if I want to direct connect the two laptops together....will have to see if I can dig one up.....

Note that crossover cables are not needed anymore to connect two devices, except if used with older, pre-2000 Ethernet ports:

http://serverfault.com/questions/579951/is-crossover-cable-still-needed

A simple Ethernet cable should work.

Varti

Posted by: ArchiMark Nov 18 2016, 08:31 AM

Thanks for the cable info, varti

Any simple way to get connected since the live Linux Mint does not have a password which ssh is asking me to enter?

It just occurred to me that maybe it would improve situation if I installed Linux Mint onto my WIN instead of using the live version.

This way I would have normal user setup with password, etc, etc...and maybe avoid some of the issues I have run into with using the live version.

Agree?

Posted by: Varti Nov 18 2016, 09:06 AM

QUOTE(ArchiMark @ Nov 18 2016, 05:31 PM) *
Thanks for the cable info, varti

Any simple way to get connected since the live Linux Mint does not have a password which ssh is asking me to enter?

It just occurred to me that maybe it would improve situation if I installed Linux Mint onto my WIN instead of using the live version.

This way I would have normal user setup with password, etc, etc...and maybe avoid some of the issues I have run into with using the live version.

Agree?

The Linux Mint live version default user has no password, so if ssh is rejecting the connection when pressing Return at the password prompt (probably it does this for security reasons), I believe the only remaining option is to install it on the Win, as you suggested.

Varti

Posted by: ArchiMark Nov 18 2016, 09:47 AM

QUOTE(Varti @ Nov 18 2016, 09:06 AM) *
QUOTE(ArchiMark @ Nov 18 2016, 05:31 PM) *
Thanks for the cable info, varti

Any simple way to get connected since the live Linux Mint does not have a password which ssh is asking me to enter?

It just occurred to me that maybe it would improve situation if I installed Linux Mint onto my WIN instead of using the live version.

This way I would have normal user setup with password, etc, etc...and maybe avoid some of the issues I have run into with using the live version.

Agree?

The Linux Mint live version default user has no password, so if ssh is rejecting the connection when pressing Return at the password prompt (probably it does this for security reasons), I believe the only remaining option is to install it on the Win, as you suggested.

Varti


Thanks, Varti.....

Just have a feeling installing LM will likely eliminate various issues including the ssh login.....

Will report back after I've installed and have the Xorg log and dmesg info as Greg requested...

Mark

Posted by: ArchiMark Nov 21 2016, 10:37 AM

Had some issues LM installer...would not install grub.....

So, installed Manjaro instead. Install went OK.

Now, trying to ssh from my Fujitsu UG/90 laptop into the WIN. Still having issues...

I'm connecting the two laptops via ethernet cables.

I did ip addr on WIN and get:

CODE
$ ip addr

lo:

inet 127.0.0.1/8

inet6::1/128

enp0s20u4u4:

link/ether  00:05:1b:d0:42:c9

inet6  fe80::292:d5fe:3381:3de0:/64


So I did:

CODE
$ ssh marks-win@127.0.0.1

marks-win@127.0.0.1's password:
Permission denied, please try again.

marks-win@127.0.0.1's password:
Permission denied, please try again.

marks-win@127.0.0.1's password:
Permission denied (publickey password).


Each time I entered the password I created when I installed Manjaro.

What am I doing wrong?

Thanks!

Mark

Posted by: greguu Nov 21 2016, 08:22 PM

QUOTE(ArchiMark @ Nov 21 2016, 07:37 PM) *
Had some issues LM installer...would not install grub.....

So, installed Manjaro instead. Install went OK.

Now, trying to ssh from my Fujitsu UG/90 laptop into the WIN. Still having issues...

I'm connecting the two laptops via ethernet cables.

I did ip addr on WIN and get:

CODE
$ ip addr

lo:

inet 127.0.0.1/8

inet6::1/128

enp0s20u4u4:

link/ether  00:05:1b:d0:42:c9

inet6  fe80::292:d5fe:3381:3de0:/64


So I did:

CODE
$ ssh marks-win@127.0.0.1

marks-win@127.0.0.1's password:
Permission denied, please try again.

marks-win@127.0.0.1's password:
Permission denied, please try again.

marks-win@127.0.0.1's password:
Permission denied (publickey password).


Each time I entered the password I created when I installed Manjaro.

What am I doing wrong?

Thanks!

Mark


Hi Mark,

127.0.0.1 is localhost and not a outward facing IP address. This does not work.

You can set both, the WIN and the Fujisu, to a fixed IP for this to work.

I think Manajro is Arch based so netctl should be installed. This is just an example :

Set your IP from DHCP to static on the Fujisu:

IP : 10.1.10.1
MASK : 255.255.255.0

on the WIN create a file as root /etc/netctl/static with the following contents

CODE
Interface=enp0s20u4u4
Connection=ethernet
IP=static
Address=('10.1.10.2/24')
Gateway=('10.1.10.1')
DNS=('10.1.10.1')


Then start the network with "netctl start static"

Now you should be able to SSH from the Fujisu by doing "ssh -l marks-win 10.1.10.2"

Greg

Posted by: ArchiMark Nov 21 2016, 09:53 PM

THANK YOU, Greg!

Will give that a try tomorrow Tuesday here.....

And hopefully (finally....) report back with Xorg log and dmesg info you asked to see.....

Posted by: ArchiMark Nov 22 2016, 11:11 AM

Tried setting up static ip on WIN.....

But get the following:

CODE
# netctl start static

netctl@static.service failed because the control process exited with error code.
See "systemctl status netctl@static.service" and journalctl -xe for details.

# systemctl status netctl@static.service

● netctl@static.service - enp0s20u4u4
   Loaded: loaded (/etc/systemd/system/netctl@static.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2016-11-22 02:59:38 PST; 1min 17s ago
     Docs: man:netctl.profile(5)
Process: 2582 ExecStart=/usr/lib/network/network start %I (code=exited, status=1/FAILURE)
Main PID: 2582 (code=exited, status=1/FAILURE)

Nov 22 02:59:38 mark-win systemd[1]: Starting enp0s20u4u4...
Nov 22 02:59:38 mark-win network[2582]: Starting network profile 'static'...
Nov 22 02:59:38 mark-win network[2582]: The interface of network profile 'static' is already up
Nov 22 02:59:38 mark-win systemd[1]: netctl@static.service: Main process exited, code=exited, status=1/FAILURE
Nov 22 02:59:38 mark-win systemd[1]: Failed to start enp0s20u4u4.
Nov 22 02:59:38 mark-win systemd[1]: netctl@static.service: Unit entered failed state.
Nov 22 02:59:38 mark-win systemd[1]: netctl@static.service: Failed with result 'exit-code'.


Please note that I followed your instructions as well some of the Manjaro wiki on static IP:

https://wiki.manjaro.org/index.php?title=Setup_Static_IP


Any suggestion?

Thanks.

Posted by: ArchiMark Nov 22 2016, 02:26 PM

UPDATE

Fiddled around with things a bit more and think I made some progress...at least I think so.....on the WIN.....

After tweaking a few things, I rebooted again....

Now when I check network connections, I see:

CODE
$ ifconfig

enp0s20u4u4:  flags=4163<UP, BROADCAST, RUNNING, MULTICAST> mtu 1500
   inet 10.1.10.2 netmask 255.255.255.0 broadcast 255.255.255.0
   blah, blah, blah......................


However, on my Fujitsu, when I try to connect, I see:

CODE
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host



????

Thanks.

Posted by: greguu Nov 22 2016, 08:46 PM

QUOTE(ArchiMark @ Nov 22 2016, 11:26 PM) *
UPDATE

Fiddled around with things a bit more and think I made some progress...at least I think so.....on the WIN.....

After tweaking a few things, I rebooted again....

Now when I check network connections, I see:

CODE
$ ifconfig

enp0s20u4u4:  flags=4163<UP, BROADCAST, RUNNING, MULTICAST> mtu 1500
   inet 10.1.10.2 netmask 255.255.255.0 broadcast 255.255.255.0
   blah, blah, blah......................


However, on my Fujitsu, when I try to connect, I see:

CODE
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host



????

Thanks.


Hi Mark, you need to set the Fujitsu also to a static IP (eg 10.1.10.1) then it should work.

Posted by: ArchiMark Nov 22 2016, 09:11 PM

QUOTE(greguu @ Nov 22 2016, 08:46 PM) *
QUOTE(ArchiMark @ Nov 22 2016, 11:26 PM) *
UPDATE

Fiddled around with things a bit more and think I made some progress...at least I think so.....on the WIN.....

After tweaking a few things, I rebooted again....

Now when I check network connections, I see:

CODE
$ ifconfig

enp0s20u4u4:  flags=4163<UP, BROADCAST, RUNNING, MULTICAST> mtu 1500
   inet 10.1.10.2 netmask 255.255.255.0 broadcast 255.255.255.0
   blah, blah, blah......................


However, on my Fujitsu, when I try to connect, I see:

CODE
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host



????

Thanks.


Hi Mark, you need to set the Fujitsu also to a static IP (eg 10.1.10.1) then it should work.


Thanks, Greg......but I did that as you instructed and checked what was needed per a webpage on the subject for doing this with Linux Mint which I have on the Fujitsu.

Can check it again, to see that the static IP took effect.....

btw, I tried pinging WIN from the Fujitsu too....but it didn't work....

Will report back again.....

Posted by: ArchiMark Nov 23 2016, 09:03 PM

Checked setup again.....

I've got the static IP addresses showing correctly on each device.

I even got a little pop-up saying that device is connected on each device.

Yet, when I try to ssh as instructed, I get the same error message as before:

CODE
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host



Any other suggestions?????

huh.gif

Posted by: greguu Nov 23 2016, 10:54 PM

QUOTE(ArchiMark @ Nov 24 2016, 06:03 AM) *
Checked setup again.....

I've got the static IP addresses showing correctly on each device.

I even got a little pop-up saying that device is connected on each device.

Yet, when I try to ssh as instructed, I get the same error message as before:

CODE
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host



Any other suggestions?????

huh.gif




Do you have a switch you can use ? Maybe the network ports can not work without a cross-over cable. Do you have LED's indicating a connection on the Ethernet port ?

Check on both "ip addr" and "ipconfig" and try to ping each other.

Try another ethernet cable.

Most easy would be to have both connected to a modem/router/switch with DHCP enabled.

Posted by: ArchiMark Nov 23 2016, 11:16 PM

QUOTE(greguu @ Nov 23 2016, 10:54 PM) *
QUOTE(ArchiMark @ Nov 24 2016, 06:03 AM) *
Checked setup again.....

I've got the static IP addresses showing correctly on each device.

I even got a little pop-up saying that device is connected on each device.

Yet, when I try to ssh as instructed, I get the same error message as before:

CODE
$ ssh -l marks-win 10.1.10.2

ssh: connect to host 10.1.10.2 port 22: No route to host



Any other suggestions?????

huh.gif



Do you have a switch you can use ?

Maybe the network ports can not work without a cross-over cable. Do you have LED's indicating a connection on the Ethernet port ?

Check on both "ip addr" and "ipconfig" and try to ping each other.

Try another ethernet cable.

Most easy would be to have both connected to a modem/router/switch with DHCP enabled.


Thanks, Greg....

I have a Netgear combo DSL modem/router.....

So, just tried connecting the 2 laptops to the network....

Lights for WIN are green.....but lights for Fujitsu are orange......hmmmm.........

Tried another cable with Fujitsu, but lights are still orange.....maybe the USB ethernet adapter is having issues?

[UPDATE: Found out orange means speed is slower; 10/100....so, working but slow, need a different adapter for higher speed...]

As for DHCP, that's what I tried at first.....but didn't work.....

Hmmmm...............

I did ip addr before it only shows connections for the device I'm using, not the other one.

Also, tried pinging WIN, but couldn't.

Maybe will try to use wifi connection.....if I can get them connected to it...

Posted by: ArchiMark Nov 28 2016, 08:09 PM

Finally had some time to deal with ssh into WIN issue again....

Was reading about /etc/ssh/sshd_config file.....

Checked mine out and all the lines are commented out I assume as they have a '#' at start of each line.

Here's a copy of it:

CODE
#    $OpenBSD: sshd_config,v 1.99 2016/07/11 03:19:44 tedu Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options override the
# default value.

#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

# The default requires explicit activation of protocol 1
#Protocol 2
ccccccc
# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 1024

# Ciphers and keying
#RekeyLimit default none

# Logging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin prohibit-password
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10

#RSAAuthentication yes
#PubkeyAuthentication yes

# The default is to check both .ssh/authorized_keys and .ssh/authorized_keys2
# but this is overridden so installations will only check .ssh/authorized_keys
AuthorizedKeysFile    .ssh/authorized_keys

#AuthorizedPrincipalsFile none

#AuthorizedKeysCommand none
#AuthorizedKeysCommandUser nobody

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
ChallengeResponseAuthentication no

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

#AllowAgentForwarding yes
#AllowTcpForwarding yes
#GatewayPorts no
#X11Forwarding no
#X11DisplayOffset 10
#X11UseLocalhost yes
#PermitTTY yes
PrintMotd no # pam does that
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation sandbox
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS no
#PidFile /run/sshd.pid
#MaxStartups 10:30:100
#PermitTunnel no
#ChrootDirectory none
#VersionAddendum none

# no default banner path
#Banner none

# override default of no subsystems
Subsystem    sftp    /usr/lib/ssh/sftp-server

# Example of overriding settings on a per-user basis
#Match User anoncvs
#    X11Forwarding no
#    AllowTcpForwarding no
#    PermitTTY no
#    ForceCommand cvs server


Would greatly appreciate input as to which lines to uncomment and if any need editing.

Thanks!

Posted by: linx Dec 7 2016, 06:50 AM

I installed Xubuntu the version from the site not the customized one which would start booting from a live USB but then showed a black screen only. I could bypass that blackscreen and boot to the live distro with nomodeset as a kernel parameter. Yes display is on portrait and in the settings in rotation in Xfce there was no option to rotate it. I haven't tried any other boot parameters but I installed it in a USB and I am currently dual booting. I am going to find that WIFI file that is needed to make wifi working again and then I'll try updating etc. I will try later on the custom Xubuntu iso from http://linuxiumcomau.blogspot.com/2016/10/running-ubuntu-on-intel-bay-trail-and.html . I will keep you updated.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)