OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
mithrandir doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
No Information
Joined: 7-January 18
Profile Views: 2,768*
Last Seen: Yesterday, 03:23 PM
Local Time: Dec 6 2019, 12:27 AM
125 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
15 Apr 2019
I am mentally preparing for the Cosmo. I don't want to use Android on a phone for privacy reasons (using Debian on the Gemini, but that is not really an option for using the device as a phone), so Sailfish might be the best option. With this a few questions regarding Sailfish have arisen:

There might only be a community edition available initially. Is it possible upgrade to official without having to reflash?
Is it possible to update Sailfish without having to reflash?
What about X11 compatibility, is this possible somehow?
Hardware support (USB devices) and filesystem support is some kind restricted with the Android kernel. Has anyone tried the modular kernel with Sailfish?

21 Mar 2019
Today, just out of interest I had a look at the kernel cmdline and noticed we are are restricted to 5 cpus:

root@gemini:/home/gemini# cat /proc/cmdline
console=tty0 console=ttyMT0,921600n1 root=/dev/ram vmalloc=496M slub_max_order=0 slub_debug=OFZPU androidboot.hardware=mt6797 maxcpus=5 androidboot.verifiedbootstate=green bootopt=64S3,32N2,64N2 log_buf_len=4M printk.disable_uart=1 bootprof.pl_t=1127 bootprof.lk_t=2950 boot_reason=4 androidboot.serialno=TGRWNRQ8ORQKC6TK androidboot.bootreason=wdt_by_pass_pwk gpt=1 usb2jtag_mode=0

To prove this I tried while running sysbench ( sysbench --test=threads --num-threads=99 run ) to see the count of enabled cpus:
root@gemini:/home/gemini# cat /proc/cpuinfo |grep proc|wc -l

The count of active cpus never went above 5 (as expected). Does anybody know the reason for this restriction? Has anybody already tried to increase this number, maybe to 10? Do we all have this restriction(might be a problem with my setup, but don't think so)? Where could this be changed (it is not part of the mkbootimg call)?

13 Feb 2019
I have just tried to connect a Bluetooth headset and failed. Has anybody successfully tried?

Pairing has been successful and when turned on bluetoothctl says the headset is connected, but by no way I could get pulseaudio to playback on the device.
30 Jan 2019
Does anybody know the pinout and type of the camera connector? Just thinking about connecting a NFC reader/writer to it instead of the outer camera... Anyways, the metal cover might prevent this. Still, this might be interesting for other upgrades.
15 Jan 2019
After performing the latest updates repowerd fails to start form me. Thus i.e. standby on close does not work any more.

root@gemini:/home/gemini# journalctl --unit=repowerd|cat
-- Logs begin at Tue 2019-01-15 18:12:52 CET, end at Tue 2019-01-15 18:32:29 CET. --
Jan 15 18:12:54 gemini.mittelerde.ldr repowerd[1473]: main: Starting repowerd 2017.03
Jan 15 18:12:54 gemini.mittelerde.ldr repowerd[1473]: SysfsBacklight: Using backlight /sys/class/leds/lcd-backlight
Jan 15 18:12:54 gemini.mittelerde.ldr repowerd[1473]: Loading module: 'libubuntu_application_api_touch_mirclient.so.3.0.0'
Jan 15 18:12:54 gemini.mittelerde.ldr repowerd[1473]: Unable to load selected module, using dummy.
Jan 15 18:12:54 gemini.mittelerde.ldr repowerd[1473]: Loading module: 'libubuntu_application_api_test.so.3.0.0'
Jan 15 18:12:54 gemini.mittelerde.ldr repowerd[1473]: TestSensor INFO: Setup for DYNAMIC event injection over named pipe /tmp/sensor-fifo-1473
Jan 15 18:12:54 gemini.mittelerde.ldr repowerd[1473]: TestSensor WARNING: Requested sensor light not yet created, blocking thread until create event received

However, I cannot find any information on libubuntu_application_api_touch_mirclient.so. It looks like recently this got used by (at least it worked before) libubuntu_application_api.so.

root@gemini:/usr/lib/aarch64-linux-gnu# egrep -r touch_mirclient
Binary file libubuntu_application_api.so.3.0.0 matches

One of these updates seems to have caused the problem:

Start-Date: 2019-01-14 01:24:11
Commandline: apt upgrade
Requested-By: gemini (100000)
Upgrade: libsystemd0:arm64 (232-25+deb9u6, 232-25+deb9u7), udev:arm64 (232-25+deb9u6, 232-25+deb9u7), libudev1:arm64 (232-25+deb9u6, 232-25+deb9u7), systemd-sysv:arm64 (232-25+deb9u6, 232-25+deb9u7), libpam-systemd:arm64 (232-25+deb9u6, 232-25+deb9u7), systemd:arm64 (232-25+deb9u6, 232-25+deb9u7)
End-Date: 2019-01-14 01:24:28

Start-Date: 2019-01-14 02:25:59
Commandline: apt remove desktop-mirror
Requested-By: gemini (100000)
Remove: desktop-mirror:arm64 (0.8.1)
End-Date: 2019-01-14 02:26:01

Start-Date: 2019-01-14 20:46:08
Commandline: apt upgrade
Requested-By: gemini (100000)
Upgrade: qtdeclarative5-ubuntu-telephony-phonenumber0.1:arm64 (0.2+gemian+0~20190112143006.17~1.gbp1b2b0b, 0.2+gemian+0~20190114151319.18~1.gbp784b7f), qtdeclarative5-ubuntu-telephony0.1:arm64 (0.2+gemian+0~20190112143006.17~1.gbp1b2b0b, 0.2+gemian+0~20190114151319.18~1.gbp784b7f), gemian-leds:arm64 (0.2+0~20190109163524.18~1.gbp42eccd, 0.2+0~20190114170611.20~1.gbp05ed0a), telephony-service:arm64 (0.2+gemian+0~20190112143006.17~1.gbp1b2b0b, 0.2+gemian+0~20190114151319.18~1.gbp784b7f)
End-Date: 2019-01-14 20:46:14

Start-Date: 2019-01-14 23:42:36
Commandline: apt upgrade
Requested-By: gemini (100000)
Install: libubuntu-application-api3:arm64 (3.0.3+gemian+0~20181125114448.15~1.gbp734b8b, automatic), libubuntu-platform-hardware-api3:arm64 (3.0.3+gemian+0~20181125114448.15~1.gbp734b8b, automatic), ubuntu-application-api3-test:arm64 (3.0.3+gemian+0~20181125114448.15~1.gbp734b8b, automatic)
Upgrade: repowerd-data:arm64 (2017.03+gemian+0~20181111171657.32~1.gbp0646ca, 2017.03+gemian+0~20190114210411.41~1.gbp3a0332), libzmq5:arm64 (4.2.1-4, 4.2.1-4+deb9u1), gemian-lock:arm64 (2.10+0~20180429112217.12~1.gbp94657a, 2.10+0~20190114215247.15~1.gbp2b698d), repowerd:arm64 (2017.03+gemian+0~20181111171657.32~1.gbp0646ca, 2017.03+gemian+0~20190114210411.41~1.gbp3a0332)
End-Date: 2019-01-14 23:44:14

Start-Date: 2019-01-15 02:10:44
Commandline: apt upgrade
Requested-By: gemini (100000)
Upgrade: qtdeclarative5-ubuntu-telephony-phonenumber0.1:arm64 (0.2+gemian+0~20190114151319.18~1.gbp784b7f, 0.2+gemian+0~20190114210353.19~1.gbpf74835), qtdeclarative5-ubuntu-telephony0.1:arm64 (0.2+gemian+0~20190114151319.18~1.gbp784b7f, 0.2+gemian+0~20190114210353.19~1.gbpf74835), telephony-service:arm64 (0.2+gemian+0~20190114151319.18~1.gbp784b7f, 0.2+gemian+0~20190114210353.19~1.gbpf74835)
End-Date: 2019-01-15 02:10:47

Is anybody else facing the same problem? Ideas how to fix or where to get the missing lib (assuming it is the cause)?


Last Visitors

21 Nov 2019 - 13:50

23 Jun 2019 - 8:11

30 May 2019 - 10:53

28 Feb 2019 - 13:40

25 Feb 2019 - 20:08

Other users have left no comments for mithrandir.

There are no friends to display.
RSS Lo-Fi Version Time is now: 6th December 2019 - 12:27 AM