OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
sylvain doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
No Information
Joined: 6-March 06
Profile Views: 1,345*
Last Seen: 9th January 2007 - 10:43 PM
Local Time: Nov 21 2019, 11:59 AM
17 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
15 Aug 2006

I managed to port and run Stackless to OpenBSD for Zaurus.

WARNING: Stackless installed itselfs as a standard Python distribution, and will crush yours if no installation prefix is provided. I install mine in /usr/local/stackless to avoid this problems.

First, download and uncompress the version 2.4.3 on http://www.stackless.com

Here is a link to the files to use for patching : http://basy.free.fr/stackless_arm_zaurus.tgz

The recursive diff arm32.patch should work on any platform, with a little tweaking. The files specific to OpenBSD/Zaurus are the patch_* files.

To build for arm32 :
- apply the arm32 patch;
- ./configure=installationprefix;
- add a -D__arm32__ to the OPT and the CPPFLAGS
- make, make install

To build for OpenBSD/Zaurus
- apply the arm32 patch;
- ./configure --prefix=installationprefix
- apply the patch_* on the proper files
- make, make install

Sorry to produce post configure patches I'm not very fond/skilled in ./configure scripts.
9 Aug 2006

I try to make Stackless Python work on OpenBSD Zaururs, starting from a port made for Nintendo DS.

This port uses a thumb assembly module (used for implementing C stack black magic).

I therefore tried to compile the whole bunch of file using the -mthumb -mthumb-interwork options of GCC, but the compilation fails, the gcc assembler complaining about "bad instructions".

Did anyone already managed to build/make work some thumb compiled software on OpenBSD ?

Thanks in advance.

PS: maybe something I said here is complete nonsense, but I'm not familiar with this kind of low level sorcery...
5 Aug 2006
Is there an existing port of Stackless Python on Zaurus ?
28 Jul 2006

Which tools do you use, to connect to open Wi-Fi Access Points ? Do you use handmade scripts, particular tools ?
7 Mar 2006

I am a newcomer in the Zaurus world, and after a few day of installing/reinstalling all ROMs on my new 3100, I chose Cacko + pocketworkstation Debian as a good compromise between PIM use and mini-laptop use.

I now have a fully functional debian (updated through apt) but when I launch it, the window manager and all processes are started for the user "root". Does anyone know how to launch it for the user "zaurus" ?

I need to add that I run qtopia as "zaurus". I understand that launching X/Qt goes through a sudo, but is it possible to abandon privileges as soon as possible ?

Last Visitors
sylvain has no visitors to display.

Other users have left no comments for sylvain.

There are no friends to display.
RSS Lo-Fi Version Time is now: 21st November 2019 - 11:59 AM