OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Netboot OpenEmbedded on a PXIe chassis from National Instruments, Netboot configuration help needed
falcn
post Dec 13 2019, 01:49 PM
Post #1





Group: Members
Posts: 1
Joined: 13-December 19
Member No.: 861,261



I'm a Linux newbie, and new here to the forum as well, so I hope I don't anger anyone with asking basic questions biggrin.gif

I am attempting to configure (or attempting to learn to configure, step 1) our National Instruments PXIe-8840QC system that is running what is purportedly OpenEmbedded Linux with the Preempt-RT patch to Netboot with a Linux Server that I have demonstrated and gotten working with CentOS for Netbooting NUC with the help of a coworker.

I'm having trouble trying to figure out how to capture or build the initramfs .img file that I need to reference on the Server.

I have found a folder on the system labeled ./lib/modules/4.14.87-rt49-cg-7.0.0f0-x64-189-build/include/config/intramfs when I do a find for initramfs - but there is not an .img file in the /boot folder like I have been used to seeing.

Anyone have any insight to impart on building the initramfs~.img file from my existing Linux system?

Dracut is not installed - I have seen this tool referenced on CentOS/RHEL for building an initramfs file.

I'm sure I am not providing enough information - so let me know what info you need and I will try to get it. Also - feel free to tell me a better place to go ask this question biggrin.gif

Regards,
Ryan
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 29th March 2020 - 04:41 PM