OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> UK Keyboard in Sailfish 3, How to set UK variant of Keyboard
mgfm99
post Mar 3 2019, 08:57 AM
Post #1





Group: Members
Posts: 12
Joined: 2-March 18
Member No.: 818,566



I have the new Sailfish X edition installed - which works quite slickly, though I miss both Aliendalvik and editing functions in Sailfish Office (which seem to be available in the underlying Calligra port but are just not available in the UI).

One irritation I have which I suspect is just my own stupidity is that I cannot select a UK layout hardware keyboard. Selecting EN on the language option in Settings assumes a US keyboard - ';' is where '@' is on the keyboard and '@' is where '"' is on the keyboard which matches a US layout.

When one checks the definition files under /usr/share/X11 these list en_GB as well as en_US with the different codings. But the normals ways of setting LANG in locale don't work with this version of Sailfish.

Does anyone happen to know how to make the device use a UK keyboard?

Many thanks.
Go to the top of the page
 
+Quote Post
idc
post Mar 3 2019, 10:23 AM
Post #2





Group: Members
Posts: 32
Joined: 22-June 18
Member No.: 824,860



It may not be just you. I have a UK keyboard (hardware layout), and selected as such in setting up Sailfish 3.0.1.13 (beta community edition), and when I booted it for the first time a few days ago it gave me the option of choosing a UK English keyboard, which I did. I still find that the key layout is different from the gemini printed keys. So for @ I have to type shift-2, rather than fn-J. Other characters are also in odd positions, including apostrophe ('), pipe and tilde (~). It is irritating, so I'm also keen to learn if someone has a fix for this.

I'm also missing the ability to edit something in OpenOffice. I can't understand why that functionality should be missing in a machine so obviously intended for work!
Go to the top of the page
 
+Quote Post
mgfm99
post Mar 4 2019, 07:53 AM
Post #3





Group: Members
Posts: 12
Joined: 2-March 18
Member No.: 818,566



QUOTE(idc @ Mar 3 2019, 06:23 PM) *
It may not be just you. I have a UK keyboard (hardware layout), and selected as such in setting up Sailfish 3.0.1.13 (beta community edition), and when I booted it for the first time a few days ago it gave me the option of choosing a UK English keyboard, which I did. I still find that the key layout is different from the gemini printed keys. So for @ I have to type shift-2, rather than fn-J. Other characters are also in odd positions, including apostrophe ('), pipe and tilde (~). It is irritating, so I'm also keen to learn if someone has a fix for this.

I'm also missing the ability to edit something in OpenOffice. I can't understand why that functionality should be missing in a machine so obviously intended for work!

I worked out a kludge solution myself after checking with together.jolla.com and getting no useful response.

The keyboard definition for the hardware keyboard is stored at /usr/share/X11/xkb/symbols/planet_vndr/gemini.

I would back this file up before editing.

Keyboard mappings are defined first for the gb layout, and then for others as a modification for the gb layout. So, for US keyboard it defines 'include gb' and then specifies specific key mapping modifications below.

So, I simply commented out all of the modifications under the us definition and rebooted. Keyboard now operates as printed as a UK one.

I think this is such a simple mistake that between last May and now, Jolla and Planet ought to have come up with a fix. At a certain level, it is a problem with the Sailfish OS, since it seems just to define English with no recognition of the differences among en_GB and en_US or en_HK, which are standard part of Linux. On the other hand, this is Planet's device and they have been advertising the availability of Sailfish.
Go to the top of the page
 
+Quote Post
Murple2
post Mar 4 2019, 04:38 PM
Post #4





Group: Members
Posts: 138
Joined: 5-January 18
Member No.: 815,856



I just assumed I was being dense and was missing a configuration option somewhere. It is beyond poor that we are missing functionality for a core component like the physical keyboard.
Go to the top of the page
 
+Quote Post
idc
post Mar 7 2019, 02:34 PM
Post #5





Group: Members
Posts: 32
Joined: 22-June 18
Member No.: 824,860



QUOTE(mgfm99 @ Mar 4 2019, 03:53 PM) *
...

So, I simply commented out all of the modifications under the us definition and rebooted. Keyboard now operates as printed as a UK one.

I think this is such a simple mistake that between last May and now, Jolla and Planet ought to have come up with a fix. At a certain level, it is a problem with the Sailfish OS, since it seems just to define English with no recognition of the differences among en_GB and en_US or en_HK, which are standard part of Linux. On the other hand, this is Planet's device and they have been advertising the availability of Sailfish.


Thanks. That's really helpful.
Ian
Go to the top of the page
 
+Quote Post
andrewl
post Mar 21 2019, 01:37 AM
Post #6





Group: Members
Posts: 122
Joined: 3-January 18
Member No.: 815,731



Updating to 3.0.2.8 Oulanka will knock the UK keyboard back to US layout.

However, Andy Branson on Jolla forums has provided this fix:

dconf write /desktop/lipstick-jolla-home/layout "'gb'"

should set the correct layout keyboard for UK hardware keyboard without having to directly edit any files.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
3 User(s) are reading this topic (3 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th December 2019 - 03:13 PM