OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )


aaaweez
Posted on: Sep 27 2006, 05:14 PM





Group: Members
Posts: 8
Joined: 9-February 06
Member No.: 9,101


There have been at least two posters besides myself who had problems restoring japanese support to cacko 1.23. I posted some of my investigation in the pinned "Cacko Rom 1.23 With Full Japanese Language Support" topic, but I was hoping to get a few more eyeballs, so I am posting this here.

Ater restoring japanese support, changing input mode to japanese in most apps causes the apps to instantly disappear (crash). I have tried running the apps from ssh prompts, and with strace, but so far, I have not found anything to help me (not to say I didn't miss something in the extensive strace output). Using the handwriting method appears to work without crashing apps. I can handwrite something in japanese, and then google search for it using netfront for example. it is only if I try to use a keyboard which would change the input language that causes problems.

Relating to the instructions posted in the pinned topic mentioned above there are several points of interest:
* The extra zip file with libs from rokugo is no longer available. I am not sure if there is something in there that would help this issue.
* One of the ipks (japanese_help I believe) failed to install. Do we care? The busybox ipkg binary isn't very functional, so I have not yet been able to look inside these ipks to see what could be wrong.

That is all i can think of at the moment. if anyone knows anything, i would love to hear it.

Thank you,
John
  Forum: Sharp ROMs · Post Preview: #142501 · Replies: 1 · Views: 1,057

aaaweez
Posted on: Sep 24 2006, 01:33 PM





Group: Members
Posts: 8
Joined: 9-February 06
Member No.: 9,101


QUOTE(aaaweez @ Sep 24 2006, 01:05 PM)
QUOTE(moku @ Sep 8 2006, 01:21 AM)
QUOTE(xotica @ Jul 8 2006, 02:36 PM)

Hi xamindar, thanks for your guide.
I am having a little trouble setting up the Japanese fonts on my c3100.  First I installed the two japanese support packages.  Next (without rebooting) I replaced the old libCRIM files with the libCRIM files in the attatched .tar.  After I reboot I am able to change the language input icon at the bottom of the screen to hiragana but cannot input japanese characters.  Am I missing something obvious here?  Any help would be welcomed.

Thanks,
Allen
*



Like the above poster I am having the same problems. I can input japanese from CRIM but japanese keyboard input is a no go. When i press the kanji button next to the "-" button most programs just close. Ive tried both meanies japanese-suport ipk and the other one from this thread, neither have allowed me to enter japanese characters via the keyboard. I even reflashed cacko with the japanese kernel to no avail. Does anyone have any ideas? Ohh by the way this is on a c3100 and the ipks i installed were the ones made for the c3100.

Thanks in Advance
*



Just finished following the instructions myself on my C3100 and I had the same problem. Most applications would just close if I opened the "50on" input method. I sshed in, ran netfront3 under strace and discovered that one of the Settings files had the wrong permissions. It was root:qpe instead of zaurus:qpe and that apparently was causing netfront to freak out. After changing it:

chown zaurus:qpe /home/zaurus/Settings/kogatagaku.da

Things seem to be working better now.

Just a quick summary of what I did:
Installed japanese-help_1.23_arm.ipk and japanese-support-c3100_1.23_arm.ipk
untarred input_icons.tar and libCRIM.tar as per the instructions in the earler post
changed lang=jp
restarted qtopia
fixed the permissions on the above mentioned file.
*



I spoke too soon. It turns out that netfront did not have focus or something when the keyboard was activated. As soon as I clicked on it, it disappeared. I will have to do some further looking.
  Forum: Sharp ROMs · Post Preview: #142197 · Replies: 48 · Views: 53,044

aaaweez
Posted on: Sep 24 2006, 01:05 PM





Group: Members
Posts: 8
Joined: 9-February 06
Member No.: 9,101


QUOTE(moku @ Sep 8 2006, 01:21 AM)
QUOTE(xotica @ Jul 8 2006, 02:36 PM)

Hi xamindar, thanks for your guide.
I am having a little trouble setting up the Japanese fonts on my c3100.  First I installed the two japanese support packages.  Next (without rebooting) I replaced the old libCRIM files with the libCRIM files in the attatched .tar.  After I reboot I am able to change the language input icon at the bottom of the screen to hiragana but cannot input japanese characters.  Am I missing something obvious here?  Any help would be welcomed.

Thanks,
Allen
*



Like the above poster I am having the same problems. I can input japanese from CRIM but japanese keyboard input is a no go. When i press the kanji button next to the "-" button most programs just close. Ive tried both meanies japanese-suport ipk and the other one from this thread, neither have allowed me to enter japanese characters via the keyboard. I even reflashed cacko with the japanese kernel to no avail. Does anyone have any ideas? Ohh by the way this is on a c3100 and the ipks i installed were the ones made for the c3100.

Thanks in Advance
*



Just finished following the instructions myself on my C3100 and I had the same problem. Most applications would just close if I opened the "50on" input method. I sshed in, ran netfront3 under strace and discovered that one of the Settings files had the wrong permissions. It was root:qpe instead of zaurus:qpe and that apparently was causing netfront to freak out. After changing it:

chown zaurus:qpe /home/zaurus/Settings/kogatagaku.da

Things seem to be working better now.

Just a quick summary of what I did:
Installed japanese-help_1.23_arm.ipk and japanese-support-c3100_1.23_arm.ipk
untarred input_icons.tar and libCRIM.tar as per the instructions in the earler post
changed lang=jp
restarted qtopia
fixed the permissions on the above mentioned file.
  Forum: Sharp ROMs · Post Preview: #142194 · Replies: 48 · Views: 53,044

aaaweez
Posted on: Feb 9 2006, 10:45 PM





Group: Members
Posts: 8
Joined: 9-February 06
Member No.: 9,101


You were dead on about need for a name. That fixed it up promptly.

Unfortunately, I am running a 1.5 server here on my desktop, so it might not eve
n be possible to connect. Here is what I am getting when I run the following:
./nxrun config/hoopyfoo.conf -i -l ide

I am only including the last bit of the output, as I imagine the rest is not nee
ded, and this is a buttload of output. I apologize in advance if ths is too muc
h output to post. Should I be using a link to the content elsewhere?
CODE
---
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: *******
DEBUG:
---
READ: NX> 103 Welcome to: hoopy user: aaaweez
NX> 105
---
DEBUG: NXProtocol: parsed line has code '103' and string 'Welcome to: hoopy user
: aaaweez'.
INFO: NXProtocol: authenticated.
DEBUG: NXProtocol: parsed line has code '105' and string ''.
DEBUG: NXProtocol: starting session...
DEBUG: WRITE: startsession
DEBUG: NXProtocol: creating options for server connection.
DEBUG: NXProtocol: set option 'session' to 'config/hoopyfoo'.
DEBUG: NXProtocol: set option 'cookie' to 'd83a23653651b4855474ca19374a4776'.
DEBUG: NXProtocol: set option 'type' to 'unix-kde'.
DEBUG: NXProtocol: set option 'cache' to '4m'.

DEBUG: NXProtocol: set option 'link' to 'LAN'.
DEBUG: NXProtocol: set option 'geometry' to '800x600+0+0'.
DEBUG: NXProtocol: set option 'keyboard' to 'us'.
DEBUG: NXProtocol: set option 'encryption' to '0'.
DEBUG: NXProtocol: set option 'cache' to '1'.
DEBUG: NXProtocol: set option 'nodelay' to '1'.
DEBUG: NXProtocol: set option 'stream' to '1'.
DEBUG: NXProtocol: set option 'media' to '0'.
DEBUG: NXProtocol: set option 'samba' to '0'.
DEBUG: NXProtocol: set option 'images' to '16m'.
DEBUG: NXProtocol: options for server = '--session="config/hoopyfoo" --cookie="d
83a23653651b4855474ca19374a4776" --type="unix-kde" --cache="4m" --link="LAN" --g
eometry="800x600+0+0" --keyboard="us" --encryption="0" --cache="1" --nodelay="1"
--stream="1" --media="0" --samba="0" --images="16m"'.
DEBUG: NXProtocol: sending parameters...
DEBUG: WRITE: --session="config/hoopyfoo" --cookie="d83a23653651b4855474ca19374a
4776" --type="unix-kde" --cache="4m" --link="LAN" --geometry="800x600+0+0" --key
board="us" --encryption="0" --cache="1" --nodelay="1" --stream="1" --media="0" -
-samba="0" --images="16m"


DEBUG: NXProtocol: parameters sent '--session="config/hoopyfoo" --cookie="d83a23
653651b4855474ca19374a4776" --type="unix-kde" --cache="4m" --link="LAN" --geomet
ry="800x600+0+0" --keyboard="us" --encryption="0" --cache="1" --nodelay="1" --st
ream="1" --media="0" --samba="0" --images="16m"'.
INFO: Negotiating session parameters.
I> Negotiating session parameters.
DEBUG:
---

READ: Start session with: --session="config\057hoopyfoo" --cookie="*************
*******************" --type="unix-kde" --cache="4m" --link="LAN" --geometry="800
x600+0+0" --keyboard="us" --encryption="0" --cache="1" --nodelay="1" --stream="1
" --media="0" --samba="0" --images="16m"

---
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: Start session with: --session="config\057hoopyfoo" -
-cookie="********************************" --type="unix-kde" --cache="4m" --link
="LAN" --geometry="800x600+0+0" --keyboard="us" --encryption="0" --cache="1" --n
odelay="1" --stream="1" --media="0" --samba="0" --images="16m"
DEBUG:
---
READ: NX> 700 Session id: hoopy-1002-7C43DE0B0CE8565A4EE6E056EA3F0662
NX> 705 Session display: 1002
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: E755826A242CAF2854DA9700B04770F0
NX> 702 Proxy IP: 192.168.xx.36
NX> 706 Agent cookie: d83a23653651b4855474ca19374a4776
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 0
NX> 710 Session status: running
NX> 105
---
DEBUG: NXProtocol: parsed line has code '700' and string 'Session id: hoopy-1002
-7C43DE0B0CE8565A4EE6E056EA3F0662'.
DEBUG: NXProtocol: skip NX code '700'
DEBUG: NXProtocol: parsed line has code '705' and string 'Session display: 1002'
.
DEBUG: NXProtocol: skip NX code '705'
DEBUG: NXProtocol: parsed line has code '703' and string 'Session type: unix-kde
'.
DEBUG: NXProtocol: skip NX code '703'
DEBUG: NXProtocol: parsed line has code '701' and string 'Proxy cookie: E755826A
242CAF2854DA9700B04770F0'.
DEBUG: NXProtocol: skip NX code '701'
DEBUG: NXProtocol: parsed line has code '702' and string 'Proxy IP: 192.168.xx36
'.
DEBUG: NXProtocol: skip NX code '702'
DEBUG: NXProtocol: parsed line has code '706' and string 'Agent cookie: d83a2365
3651b4855474ca19374a4776'.
DEBUG: NXProtocol: skip NX code '706'
DEBUG: NXProtocol: parsed line has code '704' and string 'Session cache: unix-kd
e'.
DEBUG: NXProtocol: skip NX code '704'
DEBUG: NXProtocol: parsed line has code '707' and string 'SSL tunneling: 0'.
DEBUG: NXProtocol: skip NX code '707'
DEBUG: NXProtocol: parsed line has code '710' and string 'Session status: runnin
g'.
INFO: NXProtocol: session accepted (proxy needed).
DEBUG: NXProtocol: parsed line has code '105' and string ''.
DEBUG: NXProtocol: setting parameters negotiated with server.
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: nxssh
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: -nx
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: -i
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: /usr/NX/share/client.id_dsa.key
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: nx@192.168.xx.31
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: -p
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: 22
DEBUG: NXProtocol: line does not contain token NX.

DEBUG: NXProtocol: line is: DEBUG: - end process args
DEBUG: NXProtocol: parsed line has code '203' and string 'NXSSH running with pid
: 15285'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '200' and string 'Connected to address:
192.168.xx.31 on port: 22'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '202' and string 'Authenticating user: n
x'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '208' and string 'Using auth method: pub
lickey'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '105' and string 'Hello NXCLIENT - Versi
on 1.4.0'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '134' and string 'Accepted protocol: 1.4
.0'.
DEBUG: NXProtocol: setting parameter from server

DEBUG: NXProtocol: parsed line has code '105' and string 'Set shell_mode: shell'
.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '105' and string 'Login '.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '101' and string 'User: aaaweez'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '102' and string 'Password: *******'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '103' and string 'Welcome to: hoopy user
: aaaweez'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '105' and string 'Start session with: --
session="config\057hoopyfoo" --cookie="********************************" --type=
"unix-kde" --cache="4m" --link="LAN" --geometry="800x600+0+0" --keyboard="us" --
encryption="0" --cache="1" --nodelay="1" --stream="1" --media="0" --samba="0" --
images="16m" '.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parsed line has code '700' and string 'Session id: hoopy-1002
-7C43DE0B0CE8565A4EE6E056EA3F0662'.

DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: set parameter = hoopy-1002-7C43DE0B0CE8565A4EE6E056EA3F0662
DEBUG: NXProtocol: set ID = hoopy-1002-7C43DE0B0CE8565A4EE6E056EA3F0662
DEBUG: NXProtocol: parsed line has code '705' and string 'Session display: 1002'
.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: set parameter = 1002
DEBUG: NXProtocol: set Port = 1002.
DEBUG: NXProtocol: parsed line has code '703' and string 'Session type: unix-kde
'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: set parameter = unix-kde
DEBUG: NXProtocol: set Session Type = unix-kde.
DEBUG: NXProtocol: parsed line has code '701' and string 'Proxy cookie: E755826A
242CAF2854DA9700B04770F0'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: set parameter = E755826A242CAF2854DA9700B04770F0
DEBUG: NXProtocol: set Cookie = E755826A242CAF2854DA9700B04770F0.
DEBUG: NXProtocol: parsed line has code '702' and string 'Proxy IP: 192.168.xx.3
6'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: set parameter = 192.168.xx.36
DEBUG: NXProtocol: set Server = 192.168.xx.36.
DEBUG: NXProtocol: parsed line has code '706' and string 'Agent cookie: d83a2365
3651b4855474ca19374a4776'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: set parameter = d83a23653651b4855474ca19374a4776
DEBUG: NXProtocol: set Agent Cookie = d83a23653651b4855474ca19374a4776.
DEBUG: NXProtocol: parsed line has code '704' and string 'Session cache: unix-kd
e'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: set parameter = unix-kde
DEBUG: NXProtocol: parsed line has code '707' and string 'SSL tunneling: 0'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: set parameter = 0

DEBUG: NXProtocol: set SSL Tunneling = 0.
DEBUG: NXProtocol: parsed line has code '710' and string 'Session status: runnin
g'.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: set parameter = running

DEBUG: NXProtocol: parsed line has code '105' and string ''.
DEBUG: NXProtocol: setting parameter from server
DEBUG: NXProtocol: parameters stored.
DEBUG: NXProtocol: Sending Bye...
DEBUG: WRITE: bye

DEBUG: NXProtocol: closing connection...
DEBUG: WRITE: exit

INFO: Starting session.
I> Starting session.
S> hoopy-1002-7C43DE0B0CE8565A4EE6E056EA3F0662
DEBUG: create proxy connection.
DEBUG: NXProxy: initializing...
DEBUG: NXProxy: creating new process.
DEBUG: NXProxy: new process created.
DEBUG: NXProxy: set flags for redirection.
DEBUG: NXProxy: set default parameter 'NX_ProxyName'.
DEBUG: NXProcess: argument '-S' added.
DEBUG: NXProxy: parameter 'NX_ProxyLogPath' is empty.
DEBUG: NXProtocol: parameter 'NX_ProxySessionId' is empty.
DEBUG: NXProxy: set default parameter 'NX_ProxyLogPath'.
DEBUG: NXProxy: initializing options.
DEBUG: NXProxy: parameter 'NX_ProxyRoot' is empty.
DEBUG: NXProxy: set default parameter 'NX_ProxyRoot'.
DEBUG: NXProtocol: creating options for proxy connection.
DEBUG: NXProtocol: set option 'session' to 'config/hoopyfoo'.
DEBUG: NXProtocol: set option 'cookie' to 'E755826A242CAF2854DA9700B04770F0'.
DEBUG: NXProtocol: set option 'root' to '/home/root/.nx'.
DEBUG: NXProtocol: set option 'id' to 'hoopy-1002-7C43DE0B0CE8565A4EE6E056EA3F06
62'.
DEBUG: NXProtocol: set option 'connect' to '192.168.xx.31:1002'.
DEBUG: NXProtocol: options for proxy = 'nx,session=config/hoopyfoo,cookie=E75582
6A242CAF2854DA9700B04770F0,root=/home/root/.nx,id=hoopy-1002-7C43DE0B0CE8565A4EE
6E056EA3F0662,connect=192.168.xx.31:1002'.
DEBUG: NXProxy: parameter 'NX_ProxyOptionsPath' is empty.
DEBUG: NXProxy: set default parameter 'NX_ProxyOptionsPath'.
DEBUG: NXProcess: argument 'options=/home/root/.nx/S-hoopy-1002-7C43DE0B0CE8565A
4EE6E056EA3F0662/options:1002' added.
DEBUG: NXProxy: buffer cleared.
DEBUG: NXProxy: starting...
DEBUG: NXProxy: using library path '/usr/NX/lib'.
DEBUG: NXProxy: using library path '/usr/NX/lib:/usr/lib/kde/lib:/opt/native/arm
/3.4.5-xscale-softvfp/lib'.
DEBUG: new library path: /usr/NX/lib:/usr/lib/kde/lib:/opt/native/arm/3.4.5-xsca
le-softvfp/lib
DEBUG: NXProcess: process being spawned /usr/NX/bin/nxproxy
DEBUG: NXProxy: connecting...
DEBUG:
---
READ: Bye
NX> 999 Bye

---
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: Bye
DEBUG: NXProtocol: parsed line has code '999' and string 'Bye'.
INFO: NXProtocol: connection closed.
DEBUG: NXProtocol: searching for error...
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: nxssh
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: -nx
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: -i
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: /usr/NX/share/client.id_dsa.key
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: nx@192.168.xx.31

DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: -p
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: 22
DEBUG: NXProtocol: line does not contain token NX.
DEBUG: NXProtocol: line is: DEBUG: - end process args
DEBUG: NXProtocol: parsed line has code '203' and string 'NXSSH running with pid
: 15285'.
DEBUG: NXProtocol: parsed line has code '200' and string 'Connected to address:
192.168.xx.31 on port: 22'.
DEBUG: NXProtocol: parsed line has code '202' and string 'Authenticating user: n
x'.
DEBUG: NXProtocol: parsed line has code '208' and string 'Using auth method: pub
lickey'.
DEBUG: NXProtocol: parsed line has code '105' and string 'Hello NXCLIENT - Versi
on 1.4.0'.
DEBUG: NXProtocol: parsed line has code '134' and string 'Accepted protocol: 1.4
.0'.
DEBUG: NXProtocol: parsed line has code '105' and string 'Set shell_mode: shell'
.
DEBUG: NXProtocol: parsed line has code '105' and string 'Login '.
DEBUG: NXProtocol: parsed line has code '101' and string 'User: aaaweez'.
DEBUG: NXProtocol: parsed line has code '102' and string 'Password: *******'.
DEBUG: NXProtocol: parsed line has code '103' and string 'Welcome to: hoopy user
: aaaweez'.
DEBUG: NXProtocol: parsed line has code '105' and string 'Start session with: --
session="config\057hoopyfoo" --cookie="********************************" --type=
"unix-kde" --cache="4m" --link="LAN" --geometry="800x600+0+0" --keyboard="us" --
encryption="0" --cache="1" --nodelay="1" --stream="1" --media="0" --samba="0" --
images="16m" '.
DEBUG: NXProtocol: parsed line has code '700' and string 'Session id: hoopy-1002
-7C43DE0B0CE8565A4EE6E056EA3F0662'.
DEBUG: NXProtocol: parsed line has code '705' and string 'Session display: 1002'
.
DEBUG: NXProtocol: parsed line has code '703' and string 'Session type: unix-kde
'.
DEBUG: NXProtocol: parsed line has code '701' and string 'Proxy cookie: E755826A
242CAF2854DA9700B04770F0'.
DEBUG: NXProtocol: parsed line has code '702' and string 'Proxy IP: 192.168.xx.3
6'.
DEBUG: NXProtocol: parsed line has code '706' and string 'Agent cookie: d83a2365
3651b4855474ca19374a4776'.
DEBUG: NXProtocol: parsed line has code '704' and string 'Session cache: unix-kd
e'.
DEBUG: NXProtocol: parsed line has code '707' and string 'SSL tunneling: 0'.
DEBUG: NXProtocol: parsed line has code '710' and string 'Session status: runnin
g'.
DEBUG: NXProtocol: parsed line has code '105' and string 'Bye '.
DEBUG: NXProtocol: parsed line has code '999' and string 'Bye'.
DEBUG: NXProtocol: error not found.
DEBUG:
---
READ: DEBUG: nxproxy
DEBUG: -S
DEBUG: options=/home/root/.nx/S-hoopy-1002-7C43DE0B0CE8565A4EE6E056EA3F0662/opti
ons:1002
DEBUG: - end process args

---
DEBUG: NXProtocol: DEBUG: nxproxy
DEBUG: NXProtocol: DEBUG: -S
DEBUG: NXProtocol: DEBUG: options=/home/root/.nx/S-hoopy-1002-7C43DE0B0CE8565A4E
E6E056EA3F0662/options:1002
DEBUG: NXProtocol: DEBUG: - end process args
INFO: Negotiating link parameters.
DEBUG:
---
READ: NX> 596 Error: Session restore failed: Couldn't open the display.

---

DEBUG: NXProtocol: parsed line has code '596' and string 'Error: Session restore
failed: Couldn't open the display.'.
DEBUG: NXProtocol: skip NX code '596'
ERROR: NXProtocol: error found.
ERROR: NXProtocol: error code 596 = Error: Session restore failed: Couldn't open
the display..

DEBUG: NXTransport (nxssh): break connection.
Error: Session restore failed: Couldn't open the display.
ERROR: Error: Session restore failed: Couldn't open the display.
E> Error: Session restore failed: Couldn't open the display.
INFO: Error occurred. For more info check '/home/root/.nx/temp/15278/sshlog'.
I> Error occurred. For more info check '/home/root/.nx/temp/15278/sshlog'.
DEBUG: NXConnection's destructor called.
DEBUG: cleaning up NXConnection.
DEBUG: deleting Server Connection
DEBUG: NXConnection clean.


contents of /home/root/.nx/temp/15278/sshlog is a more succinct version of above
.
CODE
DEBUG: nxssh
DEBUG: -nx
DEBUG: -i
DEBUG: /usr/NX/share/client.id_dsa.key
DEBUG: nx@192.168.xx.31
DEBUG: -p
DEBUG: 22
DEBUG: - end process args
NX> 203 NXSSH running with pid: 15285
NX> 200 Connected to address: 192.168.xx.31 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
HELLO NXSERVER - Version 1.5.0-91
NX> 105 Hello NXCLIENT - Version 1.4.0
NX> 134 Accepted protocol: 1.4.0
NX> 105 Set shell_mode: shell
NX> 105 Login
NX> 101 User: aaaweez
NX> 102 Password: *******
NX> 103 Welcome to: hoopy user: aaaweez
NX> 105 Start session with: --session="config\057hoopyfoo" --cookie="***********
*********************" --type="unix-kde" --cache="4m" --link="LAN" --geometry="8
00x600+0+0" --keyboard="us" --encryption="0" --cache
="1" --nodelay="1" --stream="1" --media="0" --samba="0" --images="16m"
NX> 700 Session id: hoopy-1002-7C43DE0B0CE8565A4EE6E056EA3F0662
NX> 705 Session display: 1002
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: E755826A242CAF2854DA9700B04770F0
NX> 702 Proxy IP: 192.168.xx.36
NX> 706 Agent cookie: d83a23653651b4855474ca19374a4776
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 0
NX> 710 Session status: running
NX> 105 Bye
NX> 999 Bye
NX> 596 Error: Session restore failed: Couldn't open the display.
Killed by signal 15.


Server side showed this:
CODE
Feb 10 00:29:36 hoopy sshd[862]: Connection from 192.168.xx.36 port 1087
Feb 10 00:29:36 hoopy sshd[862]: Found matching DSA key: 4b:9b:38:6b:24:33:6b:48
:e4:f8:c4:5b:c9:f1:fd:98
Feb 10 00:29:36 hoopy sshd[862]: Accepted publickey for nx from 192.168.xx.36 po
rt 1087 ssh2
Feb 10 00:29:36 hoopy sshd(pam_unix)[864]: session opened for user nx by (uid=0)
Feb 10 00:29:37 hoopy sshd[871]: Connection from 127.0.0.1 port 60271
Feb 10 00:29:37 hoopy sshd[871]: Accepted keyboard-interactive/pam for aaaweez f
rom 127.0.0.1 port 60271 ssh2
Feb 10 00:29:37 hoopy sshd(pam_unix)[874]: session opened for user aaaweez by (u
id=0)
Feb 10 00:29:37 hoopy sshd[874]: Connection closed by 127.0.0.1
Feb 10 00:29:37 hoopy sshd(pam_unix)[874]: session closed for user aaaweez
Feb 10 00:29:37 hoopy 1.5.0-91[865]: User 'aaaweez' logged in from '192.168.xx.3
6'. 'NXLogin::set'
Feb 10 00:29:37 hoopy sshd[874]: Closing connection to 127.0.0.1
Feb 10 00:29:37 hoopy 1.5.0-91[865]: Found a suspended session with id '7C43DE0B
0CE8565A4EE6E056EA3F0662' 'NXShell::Static'
Feb 10 00:29:37 hoopy 1.5.0-91[865]: Suspended session is the same type 'unix-kd
e' 'NXShell::Static'
Feb 10 00:29:37 hoopy 1.5.0-91[865]: Suspended session has compatible geometry '
NXShell::Static'
Feb 10 00:29:37 hoopy 1.5.0-91[865]: Restoring session with id: 7C43DE0B0CE8565A
4EE6E056EA3F0662 'NXShell::handler_session_start'
Feb 10 00:29:37 hoopy sshd[876]: Connection from 127.0.0.1 port 60272
Feb 10 00:29:37 hoopy sshd[876]: Found matching DSA key: a8:b4:c5:0c:40:50:fd:c1
:de:20:f9:e5:21:c2:72:e7
Feb 10 00:29:37 hoopy sshd[876]: Found matching DSA key: a8:b4:c5:0c:40:50:fd:c1
:de:20:f9:e5:21:c2:72:e7
Feb 10 00:29:37 hoopy sshd[876]: Accepted publickey for aaaweez from 127.0.0.1 p
ort 60272 ssh2
Feb 10 00:29:37 hoopy sshd(pam_unix)[878]: session opened for user aaaweez by (u
id=0)
Feb 10 00:29:38 hoopy 1.5.0-91[879]: INFO: Using port '1002' on node 'hoopy' for
session 'unix-kde'. 'main:nxnode:6263'
Feb 10 00:29:38 hoopy 1.5.0-91[865]: User 'aaaweez' from '192.168.xx.36' logged
out. 'NXLogin::reset'
Feb 10 00:29:40 hoopy 1.5.0-91[20584]: ERROR: Ignoring message status 'Terminati
ng' on session id: 7C43DE0B0CE8565A4EE6E056EA3F0662 'NXShell::nxsessionSetStatus
'
Feb 10 00:29:43 hoopy sshd[878]: Connection closed by 127.0.0.1
Feb 10 00:29:43 hoopy sshd(pam_unix)[878]: session closed for user aaaweez
Feb 10 00:29:43 hoopy sshd[878]: Closing connection to 127.0.0.1
Feb 10 00:29:50 hoopy sshd[864]: Connection closed by 192.168.xx.36
Feb 10 00:29:50 hoopy sshd(pam_unix)[864]: session closed for user nx
Feb 10 00:29:50 hoopy sshd[864]: Closing connection to 192.168.xx.36


thank you for any light you can shed on this.

-aaaweez
  Forum: Zaurus - pdaXrom · Post Preview: #114353 · Replies: 26 · Views: 6,423

aaaweez
Posted on: Feb 9 2006, 09:47 PM





Group: Members
Posts: 8
Joined: 9-February 06
Member No.: 9,101


QUOTE(anunakin @ Feb 9 2006, 12:38 PM)
aaaweez:
You using pdaXrom 1.10 beta1?

For works in portrait mode we need recompile... with a patch in .c files.... and some portions of HP48 keyboard goes out of screen  ph34r.gif
*


yes. I am using 1.1.0beta1. I am wondering if the problems I experienced had something to do with the fact that I was running it from a shell on my desktop. When I ran it just now from the desktop, here is what I had to run:
CODE
cd; cd .hp48
x48 -rom l48r -medium '-*-charter-bold-r-normal-*-15-*-*-*-*-*-iso8859-1' -large '-*-charter-bold-r-normal-*-20-*-*-*-*-*-iso8859-1'


oh wait. that would be the problem. Looking in the directory I see that I left a copy of the rom with the filename "rom". I thought I had moved the file everytime I tried a different filename, but evidently not. That is why it started working from the icon. Well, now everyone knows how to launch it on their desktop machine. Yay biggrin.gif

Out of curiosity, I checked out the screen running on my desktop and measured it using kruler. I was wondering if it would be possible to shave stuff off and make it fit in a 480x640 landscape mode. KDE reports the window size to be 640x425. If we simply stick the top half and bottom half back together into one bitmap, it would make a window size of around 320x850. As you said, this would definately not fit on the zaurus screen. However, if we were willing to shave off unused pieces of the display, it might just fit.

Measurements:
From top of calculator to top of LCD ~80 pixels
From bottom of LCD to top of A-F keys ~20 pixels
From bottom of A-F keys to bottom of screen ~90 pixels

If we shave all of that out of the bitmap, that saves ~190 pixels, which would make the window size 320x660.

I know I don't have the time to mess with doing this right now, but it is something I might pursue at some point, if no one beats me to it. In the meantime, I will just enjoy it in landscape mode tongue.gif .

-aaaweez
  Forum: Zaurus - pdaXrom · Post Preview: #114352 · Replies: 10 · Views: 8,888

aaaweez
Posted on: Feb 9 2006, 12:17 PM





Group: Members
Posts: 8
Joined: 9-February 06
Member No.: 9,101


cool, that sounds pretty reasonable. I will check that out later today/tonight. Thanks so much for the reply.

-aaaweez
  Forum: Zaurus - pdaXrom · Post Preview: #114300 · Replies: 26 · Views: 6,423

aaaweez
Posted on: Feb 9 2006, 12:13 PM





Group: Members
Posts: 8
Joined: 9-February 06
Member No.: 9,101


thanks for the work on this.

I managed after some minor trial and error to get it going, and it is great to have access to my trusty hp calculator without having to drag it along.

Briefly here is what I vaguely remember about some of the problems I ran into:
I had no idea where to put the rom, so I just tried running it. At first running it from the icon did nothing, so I opened a shell and ran it. It was complaining that it didn't have a .hp48 directory, and no rom.dump file I believe.

Creating a .hp48 directory and experimenting with rom.dump and rom for the filename was getting me nowhere, so I tried command line options instead. I ran it with "x48 -rom romfile", and then it complained about missing a medium font.

I opened xfontsel, and saw that the font it was looking for didnt seem to exist, so I looked around in the package feed to see if there were any packages I was missing. I could not find anything so I swapped around font specifier info on xfontsel until I found a font that rendered, and then plugged that into the mediumfont command line parameter (check help output for exact parameter). So the command I ran from command line was something like "x48 -rom romfile -mediumfont 'somestuff-charter-rest-same-as-error'". (the only part of my font name that changed was the charter part. everything else stayed the same).

It then complained about the large font missing. Same drill again, adding the large font specifier. In the end it ran, and everything works fine.

The icing on the cake is that somehow that config info got written to a file, because without any help from me, it now runs from the icon.

* end of rambling *

It works great on landscape mode, and fits perfectly on the screen. Anyone have any idea how much work it would be to make it rotate when the clamshell is rotated to portrait mode? I briefly looked at the source, and can only guess it would take some real trickery to pull it off without have to fix some of the assumptions there.

-aaaweez
  Forum: Zaurus - pdaXrom · Post Preview: #114299 · Replies: 10 · Views: 8,888

aaaweez
Posted on: Feb 9 2006, 12:48 AM





Group: Members
Posts: 8
Joined: 9-February 06
Member No.: 9,101


I have created a config directory as specified in the directions above:
b. You need to create the config directory. mkdir /usr/NX/bin/config/

CODE
# ls -lh /usr/NX/bin/
drwxr-xr-x    2 root     root            0 Feb  9 07:20 config
lrwxrwxrwx    1 root     root           28 Feb  9 07:17 nxproxy -> /mnt/card/usr/NX/bin/nxproxy
lrwxrwxrwx    1 root     root           26 Feb  9 07:17 nxrun -> /mnt/card/usr/NX/bin/nxrun
-rwxr-xr-x    1 root     root        64.5k Feb  9 07:19 nxrun_gui.py
lrwxrwxrwx    1 root     root           26 Feb  9 07:18 nxssh -> /mnt/card/usr/NX/bin/nxssh
-rwxr-xr-x    1 root     root        43.8k Feb  9 07:19 pickle.py
-rw-r--r--    1 root     root        36.6k Feb  9 07:22 pickle.pyc
-rwxr-xr-x    1 root     root        41.4k Feb  9 07:20 subprocess.py
-rw-r--r--    1 root     root        29.3k Feb  9 07:22 subprocess.pyc


but this is what I am seeing..

CODE
# ./nxrun_gui.py
Traceback (most recent call last):
File "./nxrun_gui.py", line 692, in config_dlg_do_response
  self.save_options()
File "./nxrun_gui.py", line 1606, in save_options
     FD = open("./config/" + service, "w")
     IOError: [Errno 21] Is a directory: './config/'
     Traceback (most recent call last):
File "./nxrun_gui.py", line 688, in config_dlg_do_response
       self.save_options()
File "./nxrun_gui.py", line 1606, in save_options
        FD = open("./config/" + service, "w")
        IOError: [Errno 21] Is a directory: './config/'


I look at the code a bit, but python is not my main thing, and I seriously need to go to bed soon, so I thought I would post some feedback.

BTW thanks for the instructions and thanks pgas for the compiling work smile.gif. I cant wait to get this working, as i use nomachine for everything.

-aaaweez
  Forum: Zaurus - pdaXrom · Post Preview: #114223 · Replies: 26 · Views: 6,423


New Posts  New Replies
No New Posts  No New Replies
Hot topic  Hot Topic (New)
No new  Hot Topic (No New)
Poll  Poll (New)
No new votes  Poll (No New)
Closed  Locked Topic
Moved  Moved Topic
 

RSS Lo-Fi Version Time is now: 15th December 2019 - 05:17 AM