OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Bluetooth Watches, What Bluetooth watch stays connected with Cosmo (Gemini)?
Tom D
post Nov 20 2019, 08:49 AM
Post #1





Group: Members
Posts: 27
Joined: 5-January 18
Member No.: 815,874



I have tried 2 different watches with the Cosmo, and I am having the same issue I had with the Gemini - which I never solved with the Gemini and had to carry a second device to sync the watch.

Whenever the Cosmo goes to sleep, the watch will eventually disconnect, thus getting no notifications. My first try was my Pebble. It worked fine with my Pixel 3 and Android 9 or 10. I did not work with the Gemini either. The Pebble App kept running at all times, but the Bluetooth connection would go away.

Since the Pebble was an older watch, I decided to try a new watch, so I purchased an Amazfit Bip. It also would disconnect, but for a different reason - the AmazFit would eventually get kicked out. I tried setting the app to "Not Battery Optimized", and Bluetooth to "Not Battery Optimized", but the app still gets killed.


So...I am ready to blame the AmazFit app for being improperly written to stay as a Foreground Process as the reason it is getting recycled, but:

1. Is there anyway to keep the Bluetooth connection alive when the device sleeps so I can use the Pebble?

2. Is there anyway to keep the AmazFit app from being recycled?

3.Has anyone had success with a smartwatch staying connected and receiving notifications when the Cosmo sleeps? It all works as long as I keep the Cosmo plugged in, as I have developer options setup to prevent the device from sleeping when it is plugged in.
Go to the top of the page
 
+Quote Post
maki.jouni
post Nov 20 2019, 01:17 PM
Post #2





Group: Members
Posts: 47
Joined: 22-June 19
From: Finland
Member No.: 850,543



I don't have Cosmo yet, but I have same kind of issues with other android phone and Amazfit Stratos and Plantronics PLT Legend combination. Now I have Garmin Fenix 6 and it has worked just fine for about 2 months.

Hopfully it's just poor Amazfit software and Garmin will work just fine with Cosmo...

I have Fin/Swe layout so, I just have to wait a little longer to get my Cosmo that I can test how it work with my smartwatch.
Go to the top of the page
 
+Quote Post
Tom D
post Nov 20 2019, 01:44 PM
Post #3





Group: Members
Posts: 27
Joined: 5-January 18
Member No.: 815,874



QUOTE(maki.jouni @ Nov 20 2019, 03:17 PM) *
I don't have Cosmo yet, but I have same kind of issues with other android phone and Amazfit Stratos and Plantronics PLT Legend combination. Now I have Garmin Fenix 6 and it has worked just fine for about 2 months.

Hopfully it's just poor Amazfit software and Garmin will work just fine with Cosmo...

I have Fin/Swe layout so, I just have to wait a little longer to get my Cosmo that I can test how it work with my smartwatch.


Thanks, let me know if it works when your Cosmo comes!
Go to the top of the page
 
+Quote Post
vader
post Nov 20 2019, 06:02 PM
Post #4





Group: Members
Posts: 275
Joined: 21-January 18
Member No.: 816,775



QUOTE(Tom D @ Nov 21 2019, 02:49 AM) *
1. Is there anyway to keep the Bluetooth connection alive when the device sleeps so I can use the Pebble?

2. Is there anyway to keep the AmazFit app from being recycled?

3.Has anyone had success with a smartwatch staying connected and receiving notifications when the Cosmo sleeps? It all works as long as I keep the Cosmo plugged in, as I have developer options setup to prevent the device from sleeping when it is plugged in.


I've got a galaxy active 2, and have similar problems. I've researched it a bit and can hopefully answer your questions. Firstly, the watch worked perfectly with the gemini and android 8 - pie introduced some strict power monitoring which is not limited to the cosmo (even the galaxy s10 drops the galaxy watch in pie). I switched to the cosmo, and had problems. There are two problems, bluetooth and the watch app that runs on android. I have bluetooth staying up, so I can make/receive calls. The galaxy app, however, disconnects a few minutes after the device goes to sleep. I have tried adding it to the background apps, and removed it from battery optimisation with no success. The other annoying thing is that in pie, it doesn't scan bluetooth when in low power (sleep) mode, so that if you disconnect (go too far away), the bluetooth will disconnect and never reconnect. It is a simple matter to reconnect in the usual bluetooth way on the cosmo (ie. long hold bluetooth icon, and click on your device to connect). It is annoying, but neither the cosmo's or the watch's fault. Blame is on android pie.

So, to answer,

1) I went in and removed battery optimisation for the bluetooth app:
a) select settings->Apps & Notifications
b ) scroll down, and click on See all xx apps (xx is just the number you have installed)
c) click on the three dots, top right and select Show System
d) scroll to and click Bluetooth (and later your watch app)
e) scroll down and select Advanced
f) scroll down and select Battery
g) scroll down and select Battery Optimization
h) if you don't see your app (eg Bluetooth), click the dropdown (which says Not Optimised) and select All Apps
i) Select your app (eg Bluetooth), then select Don't optimize from the popup, then click done.

** they made that easy, didn't they smile.gif **

Allow the app to run in the background
a) select settings->Dura Speed
b ) find your app (eg Galaxy Wearable)
c) turn the toggle on the right to on

This should allow your apps to run in the background. If I have left anything out, could someone add some steps - they may be what I am missing to get the wearable app working too!

Doing this allowed me to connect my watch by bluetooth and at least get calls working. The galaxy wearable app works until it goes to sleep, then the watch is disconnected from the app (but still stays connected via bluetooth). I've done a lot of reading and it is the number one complaint for galaxy watches at the moment. It is definitely not limited to the cosmo.

Hopefully, you will have better luck with your fitbit app than the galaxy wearable app.
Go to the top of the page
 
+Quote Post
shinkamui
post Nov 20 2019, 09:06 PM
Post #5





Group: Members
Posts: 43
Joined: 6-June 18
Member No.: 823,980



Duraspeed is broken on the cosmo. Regardless of what apps you allow it will kill all of your apps eventually when the device is sleeping (which ODDLY isn't even what its supposed to do...). Disable it entirely and the battery optimization whitelist is honored. I've found no discernable difference in battery longevity with duraspeed on or off. When they fix it in an update, it may become more useful. Power management in general seems to be buggy to nonfunctional on the cosmo right now. Looking forward to the first ota, which has been indicated will fix a number of day 1 issues.
Go to the top of the page
 
+Quote Post
vader
post Nov 21 2019, 03:49 AM
Post #6





Group: Members
Posts: 275
Joined: 21-January 18
Member No.: 816,775



QUOTE(shinkamui @ Nov 21 2019, 03:06 PM) *
Duraspeed is broken on the cosmo. Regardless of what apps you allow it will kill all of your apps eventually when the device is sleeping (which ODDLY isn't even what its supposed to do...). Disable it entirely and the battery optimization whitelist is honored. I've found no discernable difference in battery longevity with duraspeed on or off. When they fix it in an update, it may become more useful. Power management in general seems to be buggy to nonfunctional on the cosmo right now. Looking forward to the first ota, which has been indicated will fix a number of day 1 issues.


shinkamui is right. I was just logging in to say that disabling duraspeed appears to fix the watch connection issue! So do everything in the previous post, except instead of setting the wearable app to on in the duraspeed settings, disable duraspeed. All seems good now.
Go to the top of the page
 
+Quote Post
Tom D
post Nov 21 2019, 06:46 AM
Post #7





Group: Members
Posts: 27
Joined: 5-January 18
Member No.: 815,874



QUOTE(vader @ Nov 21 2019, 05:49 AM) *
QUOTE(shinkamui @ Nov 21 2019, 03:06 PM) *
Duraspeed is broken on the cosmo. Regardless of what apps you allow it will kill all of your apps eventually when the device is sleeping (which ODDLY isn't even what its supposed to do...). Disable it entirely and the battery optimization whitelist is honored. I've found no discernable difference in battery longevity with duraspeed on or off. When they fix it in an update, it may become more useful. Power management in general seems to be buggy to nonfunctional on the cosmo right now. Looking forward to the first ota, which has been indicated will fix a number of day 1 issues.


shinkamui is right. I was just logging in to say that disabling duraspeed appears to fix the watch connection issue! So do everything in the previous post, except instead of setting the wearable app to on in the duraspeed settings, disable duraspeed. All seems good now.


I just shut DuraSpeed off, thanks for the tip! I switched from the Amazfit app to GadgetBridge, and so far it is doing much better. Thanks everyone for all the tips. This kind of reminds me of the difference between Apple and Android.

In the Apple world things tend to just work, BUT if they don't, or if what you want isn't supported (Landscape desktop on non-plus iPhone, Hotspot always on, etc), then you are just out of luck - Apple knows better than you. On the other hand, there is almost always a way to get what you want in Android, BUT, sometimes it should just work - C'Mon, a smart watch is supposed to get notifications, Duh - and you might just have to stand on your head, twirl, unlock the bootloader and search the vast regions of the internet to get it done.
Go to the top of the page
 
+Quote Post
Phoxford
post Nov 21 2019, 10:51 PM
Post #8





Group: Members
Posts: 10
Joined: 12-January 18
Member No.: 816,363



QUOTE(Tom D @ Nov 21 2019, 05:49 AM) *
I have tried 2 different watches with the Cosmo, and I am having the same issue I had with the Gemini - which I never solved with the Gemini and had to carry a second device to sync the watch.

Whenever the Cosmo goes to sleep, the watch will eventually disconnect, thus getting no notifications. My first try was my Pebble. It worked fine with my Pixel 3 and Android 9 or 10. I did not work with the Gemini either. The Pebble App kept running at all times, but the Bluetooth connection would go away.

Since the Pebble was an older watch, I decided to try a new watch, so I purchased an Amazfit Bip. It also would disconnect, but for a different reason - the AmazFit would eventually get kicked out. I tried setting the app to "Not Battery Optimized", and Bluetooth to "Not Battery Optimized", but the app still gets killed.


So...I am ready to blame the AmazFit app for being improperly written to stay as a Foreground Process as the reason it is getting recycled, but:

1. Is there anyway to keep the Bluetooth connection alive when the device sleeps so I can use the Pebble?

2. Is there anyway to keep the AmazFit app from being recycled?

3.Has anyone had success with a smartwatch staying connected and receiving notifications when the Cosmo sleeps? It all works as long as I keep the Cosmo plugged in, as I have developer options setup to prevent the device from sleeping when it is plugged in.


I have run the Bip with the Gemini for eighteen months and now with the Cosmo for nearly a week - the connection is rock solid. Make sure you have Duraspeed turned OFF in the settings and the MiFit app not optimised and all should be good. Unless your Gemini/Cosmo/Bip has a fault.
Go to the top of the page
 
+Quote Post
Tom D
post Nov 22 2019, 03:49 AM
Post #9





Group: Members
Posts: 27
Joined: 5-January 18
Member No.: 815,874



QUOTE(Phoxford @ Nov 22 2019, 12:51 AM) *
I have run the Bip with the Gemini for eighteen months and now with the Cosmo for nearly a week - the connection is rock solid. Make sure you have Duraspeed turned OFF in the settings and the MiFit app not optimised and all should be good. Unless your Gemini/Cosmo/Bip has a fault.

It all good now - turning off Duraspeed was the key. Thanks!
Go to the top of the page
 
+Quote Post
NormMonkey
post Nov 25 2019, 08:01 AM
Post #10





Group: Members
Posts: 26
Joined: 22-November 19
Member No.: 860,015



QUOTE(vader @ Nov 21 2019, 06:49 AM) *
shinkamui is right. I was just logging in to say that disabling duraspeed appears to fix the watch connection issue! So do everything in the previous post, except instead of setting the wearable app to on in the duraspeed settings, disable duraspeed. All seems good now.


Thank you so much for this @vader, @shinkamui and the others who worked this out.

I was having a ton of difficulty getting my Gear S2 to connect and stay connected to my Cosmo. Disabling Duraspeed and then setting Bluetooth and the various Gear related apps (Galaxy Wear, Gear S2 Plugin, Samsung Accessory Service) to "Not Battery Optimized" seems to have done the trick.

Mind you I just did this so I'll have to wait and see whether it really stays connected over the longer term, and whether this kills the battery overly quick.

Anyways just wanted to give thanks, this was frustrating me to no end until this helped me.

Go to the top of the page
 
+Quote Post
Tom D
post Nov 25 2019, 02:05 PM
Post #11





Group: Members
Posts: 27
Joined: 5-January 18
Member No.: 815,874



QUOTE(Tom D @ Nov 22 2019, 05:49 AM) *
QUOTE(Phoxford @ Nov 22 2019, 12:51 AM) *
I have run the Bip with the Gemini for eighteen months and now with the Cosmo for nearly a week - the connection is rock solid. Make sure you have Duraspeed turned OFF in the settings and the MiFit app not optimised and all should be good. Unless your Gemini/Cosmo/Bip has a fault.

It all good now - turning off Duraspeed was the key. Thanks!

Actually, since with Duraspeed off the battery was going down too quickly, I was able to turn it back on and set GadgeBridge to an exception in Duraspeed, AND THEN REBOOT! Settings often don't take effect on the Gemini/Cosmo until you reboot, so I have just gotten used to restarting after a change.
Go to the top of the page
 
+Quote Post
vader
post Nov 25 2019, 03:29 PM
Post #12





Group: Members
Posts: 275
Joined: 21-January 18
Member No.: 816,775



QUOTE(Tom D @ Nov 26 2019, 08:05 AM) *
Actually, since with Duraspeed off the battery was going down too quickly, I was able to turn it back on and set GadgeBridge to an exception in Duraspeed, AND THEN REBOOT! Settings often don't take effect on the Gemini/Cosmo until you reboot, so I have just gotten used to restarting after a change.

What sort of battery drain do you see? I am at about 40% at the end of the day. Are you getting a lot better with duraspeed on?
Go to the top of the page
 
+Quote Post
Tom D
post Nov 26 2019, 06:18 AM
Post #13





Group: Members
Posts: 27
Joined: 5-January 18
Member No.: 815,874



QUOTE(vader @ Nov 25 2019, 05:29 PM) *
QUOTE(Tom D @ Nov 26 2019, 08:05 AM) *
Actually, since with Duraspeed off the battery was going down too quickly, I was able to turn it back on and set GadgeBridge to an exception in Duraspeed, AND THEN REBOOT! Settings often don't take effect on the Gemini/Cosmo until you reboot, so I have just gotten used to restarting after a change.

What sort of battery drain do you see? I am at about 40% at the end of the day. Are you getting a lot better with duraspeed on?

I am a heavy user, so results may vary. I judged by what my battery was when I arrived at work. I use it a lot during breakfast, and on a train ride to work. With it off, I was hitting 60% arriving at work. With it on I was hitting 80%. I am such a heavy user that it will never go a whole day. I get about 6-8 hours, so I always just leave it plugged in at work, and if all goes well, don't plug it in again until night.
Go to the top of the page
 
+Quote Post
iJacks
post Nov 26 2019, 02:52 PM
Post #14





Group: Members
Posts: 23
Joined: 4-June 18
Member No.: 823,791



Interestingly turning off Duraspeed has not only fixed the Bluetooth connection being dropped to my Galaxy Watch - it has also stopped (or seems to) the external screen process crashing.

However, in just 5 1/2 hours my device has dropped down to 37% battery...so I'm thinking that something just isn't right. It spent a few hours playing music to my Bluetooth headset, but my Note 8 could do that and barely flinch so i think power management is an issue on the Cosmo right now.
Go to the top of the page
 
+Quote Post
NormMonkey
post Nov 27 2019, 06:54 AM
Post #15





Group: Members
Posts: 26
Joined: 22-November 19
Member No.: 860,015



It's been a couple of days since I disabled DuraSpeed and set Bluetooth and the related Samsung apps into Battery-No-Optimize mode.
It hasn't seemed to have a significant effect on battery drain (although I haven't yet tried listening to music over Bluetooth for a couple of hours).
It has solved the problem, though. My watch now stays connected all the time. A couple of times I switched into Airplane mode, they immediately connected back up after.
TaskS2 is working reliably also.
The only annoyance I have is that I cannot silence alarms from the watch anymore. I imagine this is a Samsung custom thing they built into their Alarm app.

I have noticed that *something* occasionally causes high battery drain, accompanied by a warm cover display screen. I don't know if this is the cover display itself or if the main processor is in that area and something else is driving it hard. It usually goes away just by opening up and focusing an app. Doesn't seem to matter which app.
I suspect that the Cover Display has a power drain issue. Battery drain is improved and I don't see the aforementioned occasional high draining if I turn of Cover Display completely.
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 7th December 2019 - 05:44 AM