OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Mono headphone output?
defunked
post Jul 23 2018, 08:06 AM
Post #1





Group: Members
Posts: 24
Joined: 21-July 18
Member No.: 826,576



I have come across two audio related problems with Sailfish CE on the Gemini. First, when headphones are plugged in to the device, the speakers continue to produce audio along with the headphone. It is my understanding that the Gemini has a single stereo audio DAC, but I expected the OS/driver to switch the output path from the speakers/amplifier to the headphones, when the headphones are inserted. In addition, the headphone are mono, along with the speakers.. That is certainly not right. I know the speakers are mono (and apparently phase inverted), but my understanding was that this hardware bug did not apply to the headphone jack. Has any one else noticed this behavior?

Bluetooth audio sending works fine.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
vader
post Jul 23 2018, 01:28 PM
Post #2





Group: Members
Posts: 285
Joined: 21-January 18
Member No.: 816,775



QUOTE(defunked @ Jul 24 2018, 02:06 AM) *
I have come across two audio related problems with Sailfish CE on the Gemini. First, when headphones are plugged in to the device, the speakers continue to produce audio along with the headphone. It is my understanding that the Gemini has a single stereo audio DAC, but I expected the OS/driver to switch the output path from the speakers/amplifier to the headphones, when the headphones are inserted. In addition, the headphone are mono, along with the speakers.. That is certainly not right. I know the speakers are mono (and apparently phase inverted), but my understanding was that this hardware bug did not apply to the headphone jack. Has any one else noticed this behavior?

Bluetooth audio sending works fine.


I thought I was the only one who had this - due to my tinkering with trying to get SDL audio to work. The sound should automatically switch to headphones when they are inserted, but on mine (and apparently yours) they don't. Most fixes I found online involve using alsamixer to set the automute, although I can only see the master volume. On a positive, I have a command that will fix this, and I am writing an app (learning QML) which will do it in a friendly way. To get headphone output only (in stereo), you change the pulseaudio output port with (type in thumbterm or whatever terminal you use):

pactl set-sink-port output-wired_headphone

This routes the audio to the headphones. To set it back to the speakers, type:

pactl set-sink-port output-speaker

I'm sure there is a setting somewhere to control the automute, but I can't find it. I am still learning about Sailfish, but I do love that you *can* actually change things when they aren't right. For example, I added my SD card to /etc/fstab so it automounts when I reboot. I am still playing with the sound, and maybe I will find a proper fix, but until then, at least you can listen via headphones smile.gif


NOTE: If you don't set the port back after listening, then all sound will go to the headphones - alerts, ringtones etc! You won't hear the phone ringtone from the speakers, even when you unplug them.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th May 2020 - 01:24 AM